The MU forums have moved to

Install w/o Sub Domains (10 posts)

  1. TwisterMc
    Posted 18 years ago #

    I'm doing my WP install and not using the sub domains, I'm using directories. Now if I install WP in the main directory, is that just as good as in it's own directorie? Or am I just setting myself up for issues?

    So far I've noticed that the invites don't work and neither does the robots.txt file.

    Are these bugs or can't WP 1.6 be in the main directory when using directories?


  2. mspecht
    Posted 18 years ago #

    Twister not sure about other people but I was not able to get directories going when I gave it a go a couple of weeks ago.

  3. TwisterMc
    Posted 18 years ago #

    It's working, and quite well. Juts a few errors so far. Not sure if it's normal and they'll get fixed, or if you have to set it up specially for directories.

  4. MadameX
    Posted 18 years ago #

    How did you get them to work? Mine are working, per se, but the list in the admin area shows the link as a sub now.

    It made the new blog as a directory at first and you can still get to it putting in the url as a directory. But it later, for some reason, reverted the link in the admin list to a sub.

    I posted about this and other issues in another thread and mspecht pointed me here. I was wondering if you had some of the same issues as I do.


  5. TwisterMc
    Posted 18 years ago #

    Yea, some things in the admin area say that the blog URLs are subdomains but they actually aren't. Oh well, it works and works right on the outside. The URL for the main blog was incorrect (http://com/twisterhill or something like that), but I fixed that by editing the home template and hard coded in the correct URLs. Everything else seems to work just fine with the exception of the invites and robots.txt so far.

    Make sure you have virtual hosts (subdomains) turned off in the config file and make sure the .htaccess file has been created by WordPress.

    The main blog won't be editable, but just set one up another blog and use that as the main one. You can see my stuff at

  6. MadameX
    Posted 18 years ago #

    So, you had to hard code the urls in the home template? Did you do that to the new blogs too, or are they somewhere else? Sorry, I'm not as php savvy as some, but I'm learning all the time.

    I did make sure virtual hosts was off this last install though I haven't checked the .htaccess file. It shows that apache owns it, but I figure WP made it do that, since it wasn't there to begin with.

    And I did set up that new blog just for using as the main site. How do you get the main page to not have the sidebar, but the rest does? And how did you fix it so that the sign-up page looks like the rest of the blog?

    Wow, just took another look and you have the signup pass protected. Ok, don't think I'd really need that, but any help/hints you can give me to get mine to look like I want it would be most appreciated.

    You've done a great job with yours. :)

    Btw, does anyone know why there is no plugin section in the admin panel? The folder is on the server, but the link isn't in the admin area of the blog.

  7. TwisterMc
    Posted 18 years ago #

    There may be no plugin tab if the plugin folder is empty. But that's just a guess.

    I only had to hard code the URLs on the home template, not the others as they all work correctly. On it's own, the homepage template was 99% correct. I only edited the URL back to itself.

    To get the sidebar off the home template, just edit the template and remove any instances of sidebar code. The home template is in a different theme folder than the rest.

    The signup page, for some reason, didn't have any template code associated with it so I add it by copying code into wp-newblog.php that I took out of other pages.

  8. MadameX
    Posted 18 years ago #

    Thanks for replying, TwisterMc.

    Actually, I do have one plugin on the server now, but no link to the folder at all in the admin area, so that can be ruled out. Maybe someone else knows what the deal is with it.

    I'll be messing with those templates and see what damage i can do before I get them right! Don't think it should be tooo hard, but the way my week's been going...ya never know.

    And thanks again, it's very much appreciated! :)

  9. jaseone
    Posted 18 years ago #

    You have to enable the plugins menu in Site Admin / Options.

  10. MadameX
    Posted 18 years ago #

    That's just it....there ISN'T any plugins menu ANYWHERE in the admin area. And not in the Site/Admin/Options either.

    I've looked everywhere. The link simply isn't there.

    Opps.......sorrreee! (need an embarrassed smiley here) I didn't see it at the very bottom of the page. All is well now.

    Thanks for that. I was looking for the links at the top....not a checkbox.

About this Topic

  • Started 18 years ago by TwisterMc
  • Latest reply from MadameX