The MU forums have moved to WordPress.org

Installing on localhost (14 posts)

  1. maerk
    Member
    Posted 10 years ago #

    Just managed to get WordPress mu working on my localhost installation. I use MAMP, which is simimlar to XAMPP or LAMPP. I noticed that people have had problems installing to localhost, and are requested to try using 'localhost.localdomain'.

    Setting up 'localhost.localdomain' is very easy. You just need to edit the HOSTS file as per http://www.hiveminds.co.uk/node/3151

    That's for Windows users, for Unix and Unix-like (e.g. Mac OS, Linux) users the procedue is exactly the same, only the hosts file is located in

    /etc/hosts

    And that's it. It's really as simple as adding a single line to a file!

  2. ryanfitzer
    Member
    Posted 10 years ago #

    Thanks for the tip maerk. Sounds easy enough. The only problem is getting to the file (etc/hosts). Is this something you're using terminal to get to? Tried Macs "Go to Folder" with no luck. Could you elaborate more. Thanks for posting. I've wanted to get this running on MAMP for quite some time.

  3. lunabyte
    Member
    Posted 10 years ago #

    terminal, and the vi or emacs. ;)

    You can even have it do subdomains for testing, but you'll have to manually add the subdomain in the hosts file. For some reason it doesn't like *.what.ever

  4. rogper
    Member
    Posted 10 years ago #

    On Mac OS X 10.2 or later,

    1. Open /etc/hosts with "sudo emacs /etc/hosts" in terminal, or use the freetext-editor TextWrangler. (You must authenticate as root.)

    2. Edit and add this last in the file:
    127.0.0.1 localhost.localdomain

    3. Save the file and assuming you have web-sharing turned on (Apache), check if you can reach http://localhost.localdomain from your webbrowser.

    http://docs.info.apple.com/article.html?artnum=88158

  5. maerk
    Member
    Posted 10 years ago #

    System files and folders are invisible under Finder by default, and there's no check box to make them visible. At least, none I've found anyway -- which seems crazy to me, but there it is.

    To view system files I had to download TinkerTool:

    http://www.bresink.com/osx/TinkerTool.html

    There's an option on the Finder panel to show invisible files. I switch it on when I need access, then switch it off again once I'm done.

  6. rogper
    Member
    Posted 10 years ago #

    That is right, they are invisible. However, you can also show invisible files with an akward command in terminal:

    $ defaults write com.apple.finder AppleShowAllFiles TRUE
    $ killall Finder

    The second command killall restarts finder.

  7. samhare
    Member
    Posted 10 years ago #

    I managed to install locally on a Mac by using http://<computername>.local/, where <computername> is the computer name as displayed in System Prefs/Sharing. This avoided having to add an entry into the HOSTS file.

  8. lunabyte
    Member
    Posted 10 years ago #

    I edit /etc/hosts, and add domainname.loc, then edit httpd.conf and add a new virtual host. Works like a champ.

  9. suleiman
    Member
    Posted 10 years ago #

    for some reason it keeps on redirecting to wp-signup.php and then goes through infinite redirects.

    this is even after editing my hosts file.

  10. drew3000
    Member
    Posted 10 years ago #

    Thanks loads Samhare!

    While over the last few days I've enjoyed getting to know the various dark crevices of my Mac via terminal, I'm much happier using this route plus MAMP. Your fix worked like a charm.

  11. lunabyte
    Member
    Posted 10 years ago #

    I <3 terminal. :D

  12. katzwebdesign
    Member
    Posted 9 years ago #

    Make sure that you don't have Web Sharing turned on, or you may see the default Apache screen.

  13. Ganylina
    Member
    Posted 8 years ago #

    try it without "localhost" - just leave it empty

  14. umbro101
    Member
    Posted 8 years ago #

    I'm a newbie here and I'm trying to make sense out of all of this. I'm working with XP and using WAMP. Can anyone explain the steps in order for WPMU to work. I keep getting 'localhost.localdomain'.

About this Topic