The MU forums have moved to

Error (Need your help) :| (4 posts)

  1. Martynas
    Posted 17 years ago #

    Hi there,

    My users get error when they want to upload their stuff.

    It always gets:

    Unable to create directory /xxx./wp-content/blogs.dir/7/files/. Is its parent directory writable by the server?
    'Back to Image Uploading

    Subdirectory wp-content exists under WPMU's root, the blogs.dir subdirectory under that and that both are set to 0777.

    It seems that mu wordrpess just cannot create it automatically :(

    Any solutions?


  2. drmike
    Posted 17 years ago #

    That is strange.

    Can you check with your host and see if they have anything in place that would be preventing the subdirectories being created?

  3. pumpkinslayer
    Posted 17 years ago #

    These directories have to be writeable by web server (for me, apache). Set blogs.dir and ALL subdirectories to that user and group (for me, that's user and group "nobody"). Then set the priviledges to 755 for directories and 644 for files. 777 is just asking for trouble, I caused some for me.

    That worked for my install.

    If you are on shared hosting, tell support to,

    "Change blogs.dir and all subdirs and files to web server user and group."

    These lines will change the permissions of all the files and directories to the right thing.

    "# cd /wordpres_directory/wp-content
    # chmod nobody:nobody -R blogs.dir
    # find blogs.dir -type f -print -exec chmod 644 {} \;
    # find blogs.dir -type d -print -exec chmod 755 {} \;"

    It helped to just give my host the commands for this.

    See if it helps.

    I had to ask them to change the owner and group of blogs.dir again, for whatever reason.

    Good luck

  4. Anonymous
    Posted 15 years ago #

    This worked for me, using a Plesk environment:

    Make sure the web server user (apache in my case) is a member of the group owner of the blogs.dir folder (psacln in my case.) Doing this enabled me to keep the blogs.dir and subfolders 775.

    usermod -G psacln apache

About this Topic

  • Started 17 years ago by Martynas
  • Latest reply from Paul B.