The MU forums have moved to

Getting rid of Word Press (20 posts)

  1. MadameX
    Posted 18 years ago #

    I can't use virtual hosts. So I uninstalled and reinstalled for the third time now, going by instructions given to not select virtual hosts.

    Now I find out that the blogs will NOT be on my site. I don't like that, not one bit. This is MY server and I am the host, but the server is located elsewhere and THAT company will not allow the dns wildcard.

    So there is no way for me to use subdomains. I am very upset that logging in took me to someone else's site. This is not what I wanted and not what I expected.

    I am tired of this and extremely frustrated and mad.

  2. lafrance
    Posted 18 years ago #

    When you deleted the directory did you remember to log to mysqladmin to remove all the tables if you dont will still be there.
    If you want to use vhost like will have a fixes soon for it that will work with plesk

  3. rocksolid
    Posted 18 years ago #

    Time to get a new server

  4. MadameX
    Posted 18 years ago #

    I will NOT get a new server. Don't even try to be funny. It is NOT an option.

    And I DID remove all the tables.

    What I DON'T like is the fact that I was misled into believing the directories would be on MY OWN server.....NOT someone elses. Imagine my surprise when I find out I can't post to the main page AND logging into admin.....takes me to a TOTALLY SEPERATE WEBSITE!

    I have a security website and forum. There is NO WAY on God's green earth, I'm going to allow any blogs used by my staff to be hosted SOMEWHERE else under SOMEONE ELSE'S control.

    No where did I see that this was the way the directories were handled. It is NOT acceptable. If the subdomains can be made to work via the wildcard dns, then the directories can be made to work on the original host.....NOT SOMEWHERE ELSE.

  5. wugga
    Posted 18 years ago #

    I'm sensing some anger. just not sure who its directed at :-)

  6. MadameX
    Posted 18 years ago #

    Like I said above:

    If the subdomain option can be made to work via the wildcard dns, then directories can be made to work on MY server.....NOT someone else's.

    I've tried for the past week and a half to get this to work on my server. This is the third time I've installed it. I have searched here for answers for every problem I've had, and figured out others on my own. I cannot use virtual hosts with this as I said above, and changing servers is NOT AN OPTION. So forget that. It's out of the equation.

    People, you cannot imagine how I felt when I logged into admin.....and found myself on SOMEONE ELSE'S WEBSITE! NO, no no! This ain't gonna happen on MY server. No way in hell....o!

  7. MadameX
    Posted 18 years ago #

    Also, I don't use Plesk. I have Ensim Pro on Linux.

  8. jaseone
    Posted 18 years ago #

    Uhm what exactly are you talking about when you say you logged in and ended up on someone else's server? I'm totally lost on that one... Whose website were you on? Where are you hosted? This all seems very strange and I actually have no idea what you are talking about so can you please break it down and explain what exactly (with URL's) is happening?

  9. LifeIsPain
    Posted 18 years ago #

    I have a similar issue (I think) but I'm not the original poster. I really don't care about virtual hosts working, only for a very limited number of users. This is all using 2005-09-17.

    I have a address (note .net) and set up wpmu on /blog/. In links though, WP thinks it is http://net/blog/example (probably some mess up in a regex, I will look into it myself if no quick response, and note where the "example" is, it is the same as my domain name). This means firefox is sending me to after looking up http://net/ from Google. Similar responses may happen on whatever other top level domain is used, going to the google result.

    MadameX: the site is NOT hosted on the other place, there is just a problem in the script, but nothing is being sent to that other location, except for what your browser sends (form all I can tell) Your browser is being sent a redirect command, and it is going. Nothing is stored over on some other site, wpmu is just borked right now.

    Edit: sitename is set to "" so it seems to be doing the regex for when wildcard is set, but it isn't set.

  10. MadameX
    Posted 18 years ago #

    No, it was a website. Something like or .org. There was no admin area. Nothing. I logged in three times and it took me to the same place.A website.

    I've already deleted the database tables, though I haven't removed the wpmu. Not using virtual host gave me a white page with everything on the left and a message telling me because I wasn't using virtual host, that I couldn't post to that page, but I could change the appearance of it with the file (don't remember what it was now). I can do that, that is no problem. But this isn't what I was expecting, nor wanted. I execept a blog, not a page. And logging in to the admin, gave me that website.

    I used the latest unstable version from the download page, downloaded last night.

    I've decided to try this again, and see what happens. I'll get back to you and let you know what site that was.

    LifeisPain, I'm not sure what you are telling me.

  11. mspecht
    Posted 18 years ago #

    MadameX there have been several posts about issues with directories, I wonder as has anyone got them working? Also remember this is pre Alpha software which means there are known bugs and issues.

  12. MadameX
    Posted 18 years ago #

    After running the installer, I got this message:

    Creating Database Config File:
    Warning: chmod(): Operation not permitted in /home/virtual/site1/fst/var/www/html/wpmu/index.php on line 363

    When I first ran it, there was a long list of this error, all in the same file: /wpmu/index.php on line 363

    That line told me to chmod wp_config.php to 666, which I did. All the errors, except this one, disappeared.

    Then there was the instructions to name my blog and put in my email...etc. then submit.

    Then I got the page telling me it was all set up, and I could visit the url to the blog.

    This time, everything worked as it should EXCEPT it tells me that I don't have my own blog! I have to edit that file
    to change the appearance, but this is aggravating. In other words, it looks like I'd have to create my own SEPERATE
    blog, and use that page for my staff to sign up?

    I don't know what happened the first time. I did everything exactly the way I did it before, well, except this time I
    didn't have to chmod wp_config.php, because it was already done.

    I've created a blog now. It looks like it's done what it's supposed to do. I was concerned when it told me that
    my site name would be "". That looks like it would be somewhere else. (But this isn't what
    I was talking about earlier. It actually sent me to another site completely. No admin area, nothing. I was at a totally
    different site.)

    It has created the directory as it should. So, I think it's going to work the way it's supposed to. I'm sorry I got so
    worked up, but after being at this for so long, and having to uninstall and reinstall so many times, only to find myself
    on someone else's site, I think that was the straw that broke the camel's back. Like I said, I have no idea how it
    happened, as I did everything exactly the way I did it the first time with this download.

    Be advised, though, I will be back if I have any more problems. I promise to be more subdued and count to ten before
    I post! It just really threw me for a loop when I found myself at that other site and not in the admin area.

    I do appreciate you all being patient with me too, and trying to help with this.

    And so far, it looks like I've got it to work making directories.

  13. MadameX
    Posted 18 years ago #

    Spoke too soon...

    The new blog I created started out as a directory. But now it's been changed somehow into a subdomain! Now it won't work.


  14. jaseone
    Posted 18 years ago #

    I think the problem is that most people and probably all of the developers are using WPMU with the sub domain method.

    As another poster stated this is pre-alpha code meaning there hasn't even been a numbered version of WPMU released for development testing so you either have to live with the bugs and patiently wait for them to be fixed (preferably after reporting them, is there a Trac for WPMU?) or know how to fix them yourself.

    One day soon WPMU will be fit for release but it isn't quite there yet.

  15. lafrance
    Posted 18 years ago #

    Hello MadameX!
    See if this step help you.
    1 umpack you should get wpmu-2005-09-16 folder upload all files inside it to root of your servers run installation.
    2.Once complete you will notice a new directory created in wp-inst/wp-content/blog.dir
    that were all blog created to subdomain are located no need to used plesk or cpanel or what ever it create the sub domain on the fly in that directory.
    Hope this help been testing it at so far so good :)

  16. MadameX
    Posted 18 years ago #

    Yes, it's buggy! LOL!

    I went to bed after that last night. The directory works, in that putting in the url like so:

    is still there and can be accessed. But in the admin area, it shows the new blog's addy as:

    When it was first created, the list of blogs had the url correct. After a bit, though, it somehow reverted to the subdomain link there. Very odd.

    It also rejected the password sent to me for that new blog and accepted the password for the Admin of the Blog site. I'm talking about the one that was given when I first installed it. Another bug, looks like.

    I also noticed that there is no category for Plugins. Has that been removed? I can put in new themes, but there is no section for plugins neither in the new blog, nor in the original blog site. I hope that made sense!

    laFrance, yes there is that directory, and you really didn't tell me anything to do, so I'm not sure what you are saying, except that the directory is there. Trust me, I know it's there. And I know it creates new folders and files there when a newblog is created. I don't think there is anythng I can do with it, as the server itself does that and anything apache does on it's own is unavailable for me to do anything with. In other words, I'm not allowed to change or delete anything that apache puts in anywhere.

    I'm going to ask one of my staff members to test this out and create a new blog, then report to me what is in their admin area. If it is identical to what I have, then that doesn't bode well, I don't think.

    Also, signing out gave me an error last nite. I'm afraid I don't remember what it was something like "Can't find this Blog! This blog doesn't exist on this server!" ..or something similar to that. Then it gave a list of tables that the db should have and asks if they exist (yes they do). So I'm not sure why that happened, unless it was just a temporary thing, as I've just signed out of the new blog and it took me to the sign-in form, as it should.

    This is the error:

    Fatal Error
    Could Not Find Blog!
    Searched for in carmainc_org_-_wordpress::wp_blogsblogs table. Is that right?
    Please check that your database contains the following tables:

    * wp_blogsblogs
    * wp_blogsusers
    * wp_blogsusermeta
    * wp_blogssite
    * wp_blogssitemeta
    * wp_blogssitecategories

    If you suspect a problem please report it to support forums!

    This happens also with the Import link but I know that there are issues with the import function. All these tables are present and accounted for in the db.

  17. mspecht
    Posted 18 years ago #

    MadameX you might want to check with TwisterMac over in thread he seems to have got the directories working.

  18. anderworder
    Posted 15 years ago #

    Did you remember to wave some scorched chicken feathers over your head and chant, "Boo ugga boo ugga boo boo ugga"?

  19. sombra
    Posted 15 years ago #

    I think there's help to be found but this post doesn't make a lick of sense.

  20. lunabyte
    Posted 15 years ago #

    Not to mention it's 2 years old, and nothing applies to it any more.

    And no, it didn't make sense when it was written. Should have had a nice "for me" sticky post back then. :D

About this Topic

  • Started 18 years ago by MadameX
  • Latest reply from lunabyte