The MU forums have moved to WordPress.org

ImageManager beta for WPMU (28 posts)

  1. PerS
    Member
    Posted 15 years ago #

  2. suleiman
    Member
    Posted 15 years ago #

    YESSSSSSSSS!!!!!!!!!!!!!

    Thankyou! Thankyou! Thankyou!

  3. PerS
    Member
    Posted 15 years ago #

    Thank you suleiman :)

    Note, this is beta and I need testers

  4. suleiman
    Member
    Posted 15 years ago #

    Pers it works great.

    So far I have tested it in blogs that had the previous image manager plugin activated and those that didn't. I had of course deleted the old imagemanager plugin (which resided in the plugins folder), but I didn't know whether the old imagemanager's settings would be retained or not.

    I have also tested uploading, deleting, and resizing. All of the various panes load up as they should, and the button appears in every blog that has the Rich Text Editor enabled.

    I will now test all of the above while logged into a restricted account (I was logged in as admin before), but I wanted to post to let you know how truly grateful I am for this plugin. Several of my users are looking to do some serious photo blogging, and this will be an early birthday present for many of them :)

  5. PerS
    Member
    Posted 15 years ago #

    Thank you very much for testing this suleiman :)

    Since my WPMU site is down (waiting for new hardware), I had to do all the wpmu coding 'on paper'.

    btw: does the ImageManager button appear when you select the Code tab ? Does it appear when you disable rich editing ?

  6. suleiman
    Member
    Posted 15 years ago #

    it does appear when you select the code tab and also when you disable rich editing.

    No bugs so far and I've been doing some fairly extensive testing. Will keep you posted Pers. Thanks again!

    BTW, when is your Sandbox editor making its debut?

  7. suleiman
    Member
    Posted 15 years ago #

    Double Post

  8. Ovidiu
    Member
    Posted 15 years ago #

    @PerS

    please unban my nick: ovizii from your forum, I posted from an IP that your akismet forum plugin did not like and now I am not even allowed to read your forum!

    thx :-)

    oh, and does this new version mean we don't need the old version, hacked accordingly to a post somewhere in this forum? there was a post floating around that explained how to hack the last version so that it works (I rememebr it fixed the upload paths)..

  9. dsader
    Member
    Posted 15 years ago #

    When I log in as user 63 on blog 63 I expect to see /wp-content/blogs.dir/63/files, but I don't. I can only see/wp-content/blogs.dir/1/files

    I'll try other users, blogs, tomorrow.

  10. Ovidiu
    Member
    Posted 15 years ago #

    @PerS

    this post: http://mu.wordpress.org/forums/topic.php?id=1325&replies=18

    explained how to fix the paths to upload files, could you have a look and check whether thats still needed in your version or maybe you could incorporate that into your plugin?

  11. PerS
    Member
    Posted 15 years ago #

    ref path problems; You can fix this your self by editing ImageManager/configure/wpmu.php

  12. Ovidiu
    Member
    Posted 15 years ago #

    thx - thats great, I saw all those options in wpmu.php

    btw, I found out something about hspace and vspace which your plugin is using:

    Differences Between HTML and XHTML

    In HTML the <img> tag has no end tag.

    In XHTML the <img> tag must be properly closed.

    The "align", "border", "hspace", and "vspace" attributes of the image element were deprecated in HTML 4.01.

    The "align", "border", "hspace", and "vspace" attributes of the image element are not supported in XHTML 1.0 Strict DTD.

    could you also change your vspace and hspace into another atribute like padding maybe? should have the same efect, right?

  13. PerS
    Member
    Posted 15 years ago #

    Ovidiu, the plan is to rewrite it all, but my work demands to much time at the moment. My WP plugins are done around midnight i.e. they are real midnight hacks :)

  14. Ovidiu
    Member
    Posted 15 years ago #

    no need for explanations PerS - I am happy for what we have right now, I know a lot of ppl are writing these nifty plugins in their spare time and get nothing back :-)
    I was not requesting, just pointing out

  15. dsader
    Member
    Posted 15 years ago #

    New version 2.3.9 fixes my issue. Thanks, http://www.soderlind.no.

  16. PerS
    Member
    Posted 15 years ago #

  17. pumpkinslayer
    Member
    Posted 15 years ago #

    And 2.4.1 with bug fix...

  18. merqtio
    Member
    Posted 15 years ago #

    When the initial JS box pops up I get the following displayed within the box:

    Invalid base directory: /home/myserver/public_html/wp-content/blogs.dir/1/files/

    If I try to make a subdir I get:
    Warning: mkdir(/home/myserver/public_html/wp-content/blogs.dir/1/files/test/) [function.mkdir]: No such file or directory in /home/myserver/public_html/wp-content/mu-plugins/ImageManager/classes/files.php on line 81
    Warning: chmod() [function.chmod]: No such file or directory in /home/myserver/public_html/wp-content/mu-plugins/ImageManager/classes/files.php on line 82

    I get the same problem on sub-blogs and with different users.

    When I go to files.php the function looks fine with chmod set to 777. In configure/wpmu.php, I have the options for user upload and making subdir set to true.

    If I upload an image with MU's native image uploader, then the problem goea away, so I think the issue is in the initial creation of the upload directory when the ImageManager JS starts... I'm running MU 1.0

    Any thoughts?

  19. merqtio
    Member
    Posted 15 years ago #

    Anyone have any ideas about the above problem? The default image uploader creates a "files" folder for each blog and then adds year/month/ folders while ImageManager does not. I doubt that is the problem but it's the only thing that's different.

    Also, the plugin homepage mentions that it is possible to deactivate the default uploader, but I did not see an obvious way to do that without jumping into the code...

  20. PerS
    Member
    Posted 15 years ago #

    Re path error: You have to edit ImageManager/configure/wpmu.php

    Re 'deactivate the default uploader', thank you for reporting this. At the end of imagemanager-plugin.php change the following

    if (! IS_WPMU) {
    add_action('admin_menu', 'ps_imagemanager_admin');
    add_filter('uploading_iframe_src','ps_imagemanager_disable_wpupload');
    }

    to
    if (! IS_WPMU) {
    add_action('admin_menu', 'ps_imagemanager_admin');
    }
    add_filter('uploading_iframe_src','ps_imagemanager_disable_wpupload');

  21. merqtio
    Member
    Posted 15 years ago #

    Thanks much for the help, but still having trouble...

    1) Regarding editing paths in /configure/wpmu.php, here is my current code:
    $IMConfig['base_dir'] = str_replace( "\\", "/",ABSPATH) . UPLOADS;
    $atmp = parse_url(get_settings('siteurl'));
    $IMConfig['base_url'] = str_replace( "\\", "/",$atmp['path']) . '/' . UPLOADS;

    For me, UPLOADS is defined as
    wp-content/blogs.dir/{$wpdb->blogid}/files/

    This seems like it should be correct but I keep getting the error seen 3 posts ago. It seems to me that the path is correct but that the folder will not be created...

    2) Regarding disabling the built in uploader, I changed the code to reflect the above post, but nothing happened. Does this plugin disable the uploader by default or does that have to be set somewhere?

  22. pumpkinslayer
    Member
    Posted 15 years ago #

    Installed this plugin over the weekend and looks like its working great. I have to test it a little more fully, but everything did pop up as it should and went to the right places.

    My uploader didn't go away though, but it a great thing.

  23. merqtio
    Member
    Posted 15 years ago #

    I got the default uploader to disappear by removing the conditionals in imagemanager-plugin.php at line 342 so that the function there reads:

    function ps_imagemanager_disable_wpupload($uploading_iframe_src) {
    return "";
    }

    I'm not sure why the conditionals don't work in the first place...

    Also, going back to my directory problem... even changing the paths in configure/wpmu.php does not change the error messages (see above). Can anyone show me an example of how you edited wpmu.php to get it to work? Thanks...

  24. dsader
    Member
    Posted 15 years ago #

    I use 2.4.1, I edited nothing except to enable for wpmu as per the instructions in the plugin. Sorry.

    I have nothing that sets perms to 777. Any file/folder in my entire site is never more than 755. My wpmu creates the files folder with 755, imagemanager imitates for its folders.

  25. merqtio
    Member
    Posted 15 years ago #

    Here's a better way to fix the problem with the native WP uploader not disappearing:

    add the following anywhere in configure/wpmu.php
    //Disable default uploader
    $IMConfig['wpupload_disabled'] = true;

    This does require the edit mentioned by Per on 2007-02-02

    EDIT: Well, this works for the main blog, but not for other blogs. Guess I'll have to dig some more...

  26. suleiman
    Member
    Posted 15 years ago #

    why would you want to disable the native uploader?

    your users can't use the image manager plugin to upload mp3, flv, swf, or mov files as far as i know.

  27. merqtio
    Member
    Posted 15 years ago #

    Point well taken. I suspect that most of my users will only upload pics given the nature of the blog, so the goal of disabling the native uploader is to simplify the interface.

    Still, that's sacrificing functionality for ease-of-use, which I'd prefer not to do, so I'll probably end up reactivating the native uploader when it's all said and done.

    Ideally, it would be nice to have MediaManager that would allow similar uploading and editing for flash and mp3s, but understandably, that's a lot more complicated...

  28. apertureboy
    Member
    Posted 14 years ago #

    Hi,

    Ive got imagemanager loading but get the Invalid base directory message:

    /home/fhlinux169/p/paradoxbangkok.com/user/htdocs/
    wp-content/blogs.dir/1/files/

    I understand that this can be set in wpmu.php file, but
    how do I determine what the valid directory is?

    If anyone can assist that would be great.

    Thanks

    Rob

About this Topic

  • Started 15 years ago by PerS
  • Latest reply from apertureboy