The MU forums have moved to

Strange problem (1 post)

  1. topherrosado
    Posted 17 years ago #


    I don't know how to figure this one out. Earlier today, I implemented drmike's solution for domain hosting, and it worked perfectly. I decided then to go ahead and register a personal account to import posts into so my blog would have an account on my WPMU site. That's when I noticed the problem.

    Several days ago, I implemented Toucouleur's solution for restricting users to a single blog. It worked the way it was supposed to afterward, and I did test it several times on different browsers and platforms, just to make sure. In the end, I was satisfied with it. Being logged in and trying to register would redirect the browser to the main page, as it was supposed to. No issues.

    Today, when I tried to register my personal account after making sure I was logged out of the admin account, I went to my wp-signup.php, only to get redirected to the main page. I tried on a different browser. Same thing.

    Then I started source-diving, and I even commented out the code in wp-signup.php that does the redirect. I was still ending up on the main page instead of the signup page. I even removed the parked domain I was using for testing purposes and reset the demo blog to its original domain just to make sure it wasn't the domain hosting. Still got redirected to /.

    My last attempt was to completely replace wp-signup.php with an unaltered version. It didn't help. I've gone ahead and restored my hacked wp-signup.php (with the redirect still commented-out) since that didn't work.

    I have no problems logging in or out.

    I'm at a loss to figure this one out. I do know for a fact that a few days ago, the signup page was accessible, and I haven't made any other changes to it since then aside from commenting out the redirect code today. I'm not even certain it was the domain hosting test because it has been a few days since I checked the signup page (and I've completely reversed the domain changes).

    The domain I used for testing it was previously a domain pointer (on Site5) before I changed it over to a parked domain (it's now a pointer again). Again, the domain hosting test did work -- no issues with that.

    Obviously, I need wp-signup.php to work, or there's simply no point in having WPMU. If anyone has any ideas, I'd love to hear them. Here's the link to the problem:

About this Topic

  • Started 17 years ago by topherrosado