The MU forums have moved to WordPress.org

How do I change the permissions of blogs.dir? (10 posts)

  1. sgrundy
    Member
    Posted 13 years ago #

    Whenever I try to upload an image I get the following error:
    Unable to create directory /home/virtual/site9/fst/var/www/html/wp-content/blogs.dir/4/files/. Is its parent directory writable by the server?
    I try to chmod it to 777 but I can't because it's owned by apache. I can delete it, but it just get's recreated with chmod 755.... what do I need to do? I'm about to give an inservice on podcasting and I need to be able to upload files!

  2. sgrundy
    Member
    Posted 13 years ago #

    Grrrr... Ok, I cheated and recreated the folder myself with the correct permissions. Now I get this error:
    The uploaded file could not be moved to /home/virtual/site9/fst/var/www/html/wp-content/blogs.dir/4/files/.
    The directory is there and chmoded 777, but it won't move the file there... What do I do?

  3. amanzi
    Member
    Posted 13 years ago #

    Is this on your own server, or a hosted service?

  4. sgrundy
    Member
    Posted 13 years ago #

    Hosted Virtual Server.

  5. drmike
    Member
    Posted 13 years ago #

    Hmm, that's strange as mine's owned by my user.

    I'd ask your host to change the permissions on it as they can sign in as root and root overrides apache anyday. :)

    Hope this helps,
    -drmike

  6. sgrundy
    Member
    Posted 13 years ago #

    thought of that, and managed to "remake" the folder so it was owned by me. And it works fine - for any account I manually make the files for. But any folder that MU tries to make... which is very odd because all the directories are chmod 777 - I just don't get it.
    Update - Hmmmm... it will create the "blog" folder in blogs.dir (ie. 1, 2, 3 based on the blog id) and chmod it to 777 (with apache as the owner) but it says it doesn't have the permission to create the "files" folder.
    "Unable to create directory /home/virtual/site9/fst/var/www/html/wp-content/blogs.dir/1/files/. Is its parent directory writable by the server?"
    I can do it manulally with my FTP program, but that will be a pain to have to keep doing it for all my clients. any suggestions?

  7. crownbacca
    Member
    Posted 12 years ago #

    I face the exact same problem as yourself. What i did was to manually create the directories in blogs.dir 1,2,3,4,5,6...100 before and include the files folder inside with chmod 777. This would then work for at least the first 100 users.

    I really hope that there is a better way of doing this..

  8. Farms2
    Member
    Posted 12 years ago #

  9. jdesilva
    Member
    Posted 12 years ago #

    I encountered the same issues as described by others on this thread, despite having the correct permissions.

    I disabled both: Safe Mode & Open BaseDir, and now everything seems to be working.

    If it's just one, or both, that is causing the problem, I don't know.

  10. Anonymous
    Unregistered
    Posted 11 years ago #

    This worked for me, using a Plesk environment:

    Make sure the web server user (apache in my case) is a member of the group owner of the blogs.dir folder (psacln in my case.) Doing this enabled me to keep the blogs.dir and subfolders 775.

    usermod -G psacln apache

About this Topic