The MU forums have moved to WordPress.org

can't add new category (8 posts)

  1. Ovidiu
    Member
    Posted 16 years ago #

    hi there,

    I had a category: "cultura" I used for as a blogroll category. now I need a category with the same name for posting, but seeing its not possible to have 2 categories with the same name, I renamed the first one to "culturale" and tried creating a new category called "cultura", but I get an error: Something strange happened. Try refreshing the page. If I refresh, I am back in the manage categories tab and the new category has not been created...

    any ideas whats wrong here?

  2. Ovidiu
    Member
    Posted 16 years ago #

    I found out I have to manually change the category_nicenameinside my wp_{blogid}_categories ` table

    are users not suposed to be able to edit their categories nicenames? just like they can change the permalinks and slugs?

  3. drmike
    Member
    Posted 16 years ago #

    Have you added that to trac? Please do so if you haven't.

    One of the category's names stay the same site wide. That way the system can do the global categories.

  4. Ovidiu
    Member
    Posted 16 years ago #

    well, no I did not...
    never used trac but I just searched, found this: http://trac.mu.wordpress.org/ and I see you login and create a ticket with an error or bug you found - so far so good.

    I found out I can use my forum username to log in, but before I go ahead, can you explain a bit what you saw in this error?

    I just saw a pain in the a** and was surprised I am not allowed to change nicenames or maybe surprised that wpmu did not change the nicenames according to the category name - you seem to see beyond that - do you mean that if this is a feature not a bug :-) we could use it to set up global categories?

    can you explain your idea or just submit it yourself to trac? I can't go ahead and submit an idea I did not comprehend yet :-)

  5. asterix
    Member
    Posted 15 years ago #

    The solution for me to get categories working correctly, after trying various suggestions including clearing the cache, resetting browser profiles, etc. was to access the site via the non-www version (ie. example.com instead of http://www.example.com).

    I had an htaccess rewrite setting that was redirecting to http://www.example.com - I've now reversed that so everything goes to example.com.

  6. lunabyte
    Member
    Posted 15 years ago #

    (Note: Which is how MU should be set-up to begin with. ;) )

  7. drmike
    Member
    Posted 15 years ago #

    Agreed although I think Donncha recently removed it from htaccess. He made changes to the codebase but from what I see, it's just in the install routein.

  8. kingler
    Member
    Posted 15 years ago #

    There has been some debates over whether www. is still needed.

    But in general, you want only one site to be indexed by search engines like Google. So you have to decide which one you want (with or without the www prefix).

About this Topic