The MU forums have moved to WordPress.org

kses and the <!--more--> tag (5 posts)

  1. wugga
    Member
    Posted 18 years ago #

    It looks like the 2005-09-23 version that I installed has the recent changes to kses. I think that change prevents the WordPress tags <!--more--> and <!--nextpage--> from working.

    Can someone confirm this and post a fix? I'm working on it but it's something new to learn and I'm probably gonna be slow.

  2. jaseone
    Inactive
    Posted 18 years ago #

    Try just adding them to the list of allowed post tags in wp-inst/wp-includes/kses.php

    Am I reading that right in that inline styling was disabled but you can still create forms? Why not just disable forms in posts given the reason given for disabling inline styling was to prevent people from creating a fake login form? Why would anyone want to create a form within a post anyway?

  3. wugga
    Member
    Posted 18 years ago #

    I tried that but apparantly I'm adding the wrong thing. I appened this to allowedtags and allowedposttags:

    '!--more--' => array() but no luck. I believe I'm adding it in the correct place but its still not working for some reason.

  4. jaseone
    Inactive
    Posted 18 years ago #

    I think allowed_html is coming into play as well but it sent my head into a spin trying to track down all the filtering that was going on...

  5. akbigdog
    Member
    Posted 18 years ago #

About this Topic