The MU forums have moved to

links all messed up!?http://net/blogs/korptix/blogs/ (14 posts)

  1. Ruens
    Posted 17 years ago #

    well i got a dedicated ip on godaddy and i installed everything again... well... take a look for yourself...i need help... i get links like this


  2. lunabyte
    Posted 17 years ago #

    Server OS version, Apache version, Php version, MySQL version, and MU version please.

    Also, need to know if this was a fresh install, how it was installed, and whether it is a subdomain or subdirectory install.

  3. Ruens
    Posted 17 years ago #

    ok its latest mu version, also it is a clean fresh install all new mysql db, and its a subdir install, any ideas?
    Operating System
    Red Hat Linux
    Version 2.4.21-4.0.1 elsmp
    Web Server
    Apache 1.3
    Web Programming Languages
    PHP 4.3.11
    Tomcat (Java) 5.0.27
    CGI / Perl 5.8
    Python 2.2
    MySQL 4.0.24

  4. drmike
    Posted 17 years ago #

  5. lunabyte
    Posted 17 years ago #

    Agreed Doc. I'm curious as to "why" it happens though, so I went fishing for a little bit of info in Donncha reads the thread. :D

    Can't say it helps much though, unless it's a subdirectory issue or something.

    I just tested this again with 1.1.1, and it was fine on the test box I used.

    It was my "bare minimum" box, which is OS X (Jaguar), Apache 1.3.26, php 4.3.3, and mysql 3.23.49.

    It also works on a couple other boxes I have as well, that are more up to date than this one. I have mysql 4.1.x though, not 4.0.x on my mysql 4 box.

  6. drmike
    Posted 17 years ago #

    We were thinking it was because folks were putting the 'http://www' bit in when the installer asked for the domain but we've never gotten any feedback from folks as to what they had done.

  7. lunabyte
    Posted 17 years ago #

    Maybe, but I would think that would present other errors before someone created a new blog in the back.

    I could run a test install of it, and see what happens when I do that.

    Looking at the install script, it only checks for "www.", and excludes it. So if someone were to add http:// in there, that might be an issue.

    Let me set up another install and try to break it.

  8. lunabyte
    Posted 17 years ago #


    doesn't filter out the www, or the
    , and it really, really hoses up a site.

    All links end up with 404's, trying to go to a double http.

    Same with http in there, but without the www.

    That was trying to use subdomains, btw.

    Donncha tried to reproduce it with a subdirectory test, which he couldn't either.

    So, I'm out of ideas at the moment unless it can be tied to a specific thing like a certain php or mysql version, or maybe an upload error or something.

  9. SOrginal
    Posted 17 years ago #

    this is a linux problem because my localhost (win xp) is ok. :) Maybe i were put IP for domain name.

    Whatever, My host is linux so the same problem that i have seen.
    I tried this,

    but there is nothing.

    domains seems like com/domain/ ... like this :(

  10. lunabyte
    Posted 17 years ago #

    I've tried to reproduce this, and can't.

    And that's on linux, and Mac OS X.

    Although there isn't a default checked for subdomain or subdirectory install (radio buttons), and not checking one kinda makes things a little goofy. Nothing too bad, it still works though.

  11. redbox
    Posted 17 years ago #

    I had the same problem. DrMike, I didn't use the http://www in the installer, I only listed

    I had to edit data using phpMyAdmin to make it work properly.

    I'm on a dedicated server.
    PHP 4.3.11
    MySql 4.0.27 standard
    Linux x86_64
    4gb ram
    Apache 1.3.34

  12. lunabyte
    Posted 17 years ago #


    Common items so far are:

    MySQL 4.0.24, and 4.0.27.


    PHP 4.3.11

    Not that it means much, but it's the common glue between those two installs.

    Anyone reading the over the next day or so (note, not 6 months from now), please feel free to post your specs as well.

  13. drmike
    Posted 17 years ago #

    I've done about three dozen installs now and I have yet to see it.

  14. lunabyte
    Posted 17 years ago #

    I agree, I haven't seen this either. Even trying to make it happen on purpose, I couldn't break it.

    Which leads me to think it's a version conflict or something, somewhere with it.

    So far with the above 2 install details, it would make you think it's either that specific version of php, or a mysql 4.0 problem.

    Oh, and I did add a ticket to trac for a default setting for the radio buttons which select subdom/subdir install type.

    Ticket #264

About this Topic