The MU forums have moved to WordPress.org

New pages/blogs are all 404'd. (8 posts)

  1. ndcoonen
    Member
    Posted 10 years ago #

    First-time installer of WPMU. I have blogs currently set as subdirectories, but I've also tried subdomains, with the same results. Additionally, any new pages I try to create are unviewable. wp-content dir is set to '777', and I feel like I'm just missing something tiny and dumb here.

    I've even tried changing the permalink styles, with effect.

    Helpful suggestions would be appreciated!

  2. kingler
    Member
    Posted 10 years ago #

    New page? only new page? How about the default post?

    I assume you are using .htaccess file, right?

  3. lunabyte
    Member
    Posted 10 years ago #

  4. ndcoonen
    Member
    Posted 10 years ago #

    Is VHOST true or false?
    Unknown. I've searched the forums and see that the VHOST setting is supposed to be in the wp-settings.php file, but there is literally no VHOST reference that I can find in said file.

    This very well could be my issue, but without knowing where to find the VHOST setting, I'm at a bit of a loss. I've noticed that my permalinks seem to include the /blog/ subdirectory, despite the fact that my WPMU installation at the root level of my domain.

    Is the path to your WordPress? MU install "/" or some directory?
    "/"

    Anything in the error logs? If you didn't get a welcome email, check your mail logs.
    No errors and all posts, entries, users, blogs, pages, etc. all show up properly within the database as they are created.

    Does the information in wp_blogs, wp_users and wp_site match your blog, user and site?
    Yes.

    Mention the version number, SVN check-in number or the date you downloaded the snapshot.
    wpmu 1.1.1

    Thanks again, and again, any more kind and helpful words will be appreciated.

  5. lunabyte
    Member
    Posted 10 years ago #

    VHOST is defined in wp-config, not wp-settings.

    For a subdomain install it should read:

    define('VHOST', 'yes');

    use "no" for subdirectories.

    As an additional note, you are on an apache web server, and mod_rewrite and FollowSymLinks is activated right?

    Kinda off the wall, but I suppose there could be a host out there that turns off these "default" options.

  6. ndcoonen
    Member
    Posted 10 years ago #

    VHOST is defined in wp-config, not wp-settings.

    For a subdomain install it should read:

    define('VHOST', 'yes');use "no" for subdirectories.
    Hmmmm ... VHOST is defined as 'no' in wp-config, as it should be for my subdirectory configuration.

    As an additional note, you are on an apache web server, and mod_rewrite and FollowSymLinks is activated right?
    Correct on both counts. It's Apache 1.3.3, and according to the host, mod_rewrite is enabled.

  7. ndcoonen
    Member
    Posted 10 years ago #

    OK, it's been fixed. I worked with the host some more, and after a bit of research and work on their end, they found that they needed to enable 'AllowOverride', which they had not done.

  8. unodewaal
    Member
    Posted 10 years ago #

    I have the same problem... I'm hosting over here: http://www0.sun.ac.za/diematie/blogs
    I've changed everything to 777 (everything... is that a bad thing?)
    I have (had) a perfectly sound Wordpress install running.
    I've done this 500 times but can't seem to get it right. Is there a way for me to check the AllowOverride setting?

About this Topic

  • Started 10 years ago by ndcoonen
  • Latest reply from unodewaal