The MU forums have moved to WordPress.org

URL bug with get_bloginfo('url') template tag (10 posts)

  1. kingler
    Member
    Posted 15 years ago #

    Check out the link in the footer.

    http://test.72pines.com/ (WPMU 1.1.1, link error)
    http://test2.edublogs.org/ (from James, WPMU 1.0, RSS link error)

    Notice the link looks like:
    http://http//***
    or
    feed://http//***

    The default template is using the get_bloginfo() tag to get the options.

    I have tested using WPMU 1.0, 1.1.1 and the latest r915 in SVN. All having this same issue.

    Is this new or it is an old bug? I seems not able to find anyone mentioning this bug before.

  2. drmike
    Member
    Posted 15 years ago #

    Depends on whick link you're talking about.

  3. kingler
    Member
    Posted 15 years ago #

    Go to http://test2.edublogs.org/

    Look at the footer links for Entries (RSS) and Comments (RSS). It showed up as feed://http//test2.edublogs.org/feed/

    This also happens in a fresh install of WPMU 1.1.1 and the latest SVN nightly.

  4. rmwb
    Member
    Posted 15 years ago #

    IE7 displays it as feed:http://test2.edublogs.org/feed/

  5. rmwb
    Member
    Posted 15 years ago #

    as does Opera 9.10 & Mozilla & Safari in a Mac.
    I think you want to be here:
    http://www.mozilla.org/support/firefox/bugs
    as this is a FireFox bug.

  6. kingler
    Member
    Posted 15 years ago #

    Anyway, a temporary fix is to replace the

    <a href="http://<?php echo get_bloginfo('url') ?>">

    in your theme footer.php files into this:

    <a href="<?php echo get_bloginfo('url') ?>">

    Basically, just strip out the "http://" prefix.

  7. rmwb
    Member
    Posted 15 years ago #

    I can't see such a thing in any of my footer.php files
    Don't you mean remove the "feed:" prefix:
    replace the

    <a href="feed:<?php bloginfo('rss2_url'); ?>">

    with

    <a href="<?php bloginfo('rss2_url'); ?>">

    ?

  8. lunabyte
    Member
    Posted 15 years ago #

    <a href="http://<?php echo get_bloginfo('url') ?>">

    There shouldn't be an http:// in there. get_bloginfo is the same as bloginfo, only that it returns the value instead of prints it.

    Why someone would use it as nothing more than an echo is beyond me.

    <a href="<?php bloginfo('url') ?>">
    is the cleaner option, unless you want to further parse the result.

  9. kingler
    Member
    Posted 15 years ago #

    You are right, lunabyte. The best way is to just use this:

    <a href="<?php bloginfo('url') ?>">

    The default WPMU home theme has the "feed:" prefix, which I think should be removed just as in the default theme.

  10. suleiman
    Member
    Posted 15 years ago #

    I'm having trouble with <?php bloginfo('rss2_url'); ?>. It isn't returning any feeds!

    I find myself having to use /feed/"> instead. And it feels poo.

About this Topic

  • Started 15 years ago by kingler
  • Latest reply from suleiman