The MU forums have moved to WordPress.org

WPMU 1.0 and bbPress - Login Integration (3 posts)

  1. zappoman
    Member
    Posted 15 years ago #

    I am trying to get bbPress and WordpresMU to integrate. (I happen to be using MU1.0, but I doubt that that is at all related to my current problems).

    I followed the instructions linked to in many locations on this forum and the bbPress docs as well, and most everything seems to work. Except, one problem (so far)...

    Namely I am not getting shared login working. What I mean by this is that if I login on MU as user "test1" and then go to my bbPress main page, bbPress thinks I am not logged in. If I login to bbPress it uses the user info correctly so that my mu credentials are used (that's working great) but if I log out of bbPress, I don't get logged out of mu.

    To make matters more complicated, I can login as "test1" in mu and "test2" in bbPress and they don't seem to complain.. of course it's a totally confusing situation to the user.

    So I am sure this is related to cookie sharing, and I must have missed some step somewhere.

    The one thing I was confused by was the following instruction...

    In bbpress/config.php you're supposed to set wp_home and wp_siteurl, and it says to go to Options->General to get these values. Well, clearly this is a wordpress (non-MU) instruction since the General tab in MU doesn't show these values... so what should it be?

    I've tried using the full url "http://www.domain.com" to my main MU home page, but that didn't seem to work.

    Thanks in advance for any help you can provide.

  2. drmike
    Member
    Posted 15 years ago #

    Try using domain.com for the cookie.

  3. zappoman
    Member
    Posted 15 years ago #

    Ok, I got things working... I am not 100% sure how I did it, I think I must have previously attempted to do the cookie integration using the old instructions, and I had messed up some of my wordpressmu settings.

    Thanks for the tip Dr. Mike, definitely changing the wp_siteurl and wp_home to not include http:// helped... But I also needed to spelunk around with firefox cookie inspector to realize what was going wrong.

About this Topic

  • Started 15 years ago by zappoman
  • Latest reply from zappoman