The MU forums have moved to WordPress.org

Yeah, the same DB errors spit after adding/deleting blog... (26 posts)

  1. spencerp
    Member
    Posted 13 years ago #

    Here's the deal folks, after reading just about all of the threads related to the DB errors spitting after a blog is made, and even deleted. I'm *still* getting the following errors:

    WordPress database error: [Table 'mydbname.2_options' doesn't exist]
    SELECT option_value FROM 2_options WHERE option_name = '2_user_roles'
    LIMIT 1

    WordPress database error: [Table 'mydbname.2_options' doesn't exist]
    SELECT option_value FROM 2_options WHERE option_name = 'blogname' LIMIT 1

    WordPress database error: [Table 'mydbname.2_options' doesn't exist]
    SELECT option_value FROM 2_options WHERE option_name = 'siteurl' LIMIT 1

    WordPress database error: [Table 'mydbname.2_options' doesn't exist]
    SELECT option_value FROM 2_options WHERE option_name = 'post_count' LIMIT 1

    This is NOT my personal testing MU blog, this is someone else's blog I'm setting up. This is going on a recent download of MU from the download page here.

    This is running on the following:

    PHP 4.3.11
    MySQL client version: 4.1.22
    Server version: 4.1.22-standard
    Memory limit in the php.ini file: 20M
    Mysql STRICT mode is not turned on.
    Max open file size in DB is: 2048 from original: 1024
    Not hosted on Dreamhost.com

    This is running on the root of the domain name, "BASE" is set right in the .htaccess file as well. I had tried various things to get this puppy running, yet it's *still* a no-go with those database errors.

    Don't get me wrong, the blog is up and running fine. Any created blog is working, just those database errors still spit.

    Anyone with any suggestions, besides "search"? Been there, done it numerous of times already, didn't find any really valuable informations. I'm not a nOOb with the overall WP Community either, please don't treat me like one.

    However! I am new to these forums lmao! Thanks folks. :)

    spencerp

  2. drmike
    Member
    Posted 13 years ago #

    Current issue. The blog still is created though.

    Not hosted on Dreamhost.com

    heh heh...

  3. spencerp
    Member
    Posted 13 years ago #

    Haha. Mine was setup just fine though on Dreamhost.com whee! Only issue I had at first was setting up the DNS wild card for it:

    http://mu.spencerp.net
    http://jeremyvisser.mu.spencerp.net

    Test blog of course.. ;) :P

    spencerp

  4. spencerp
    Member
    Posted 13 years ago #

    UPDATE: This just in from the person's support reps >

    "We have provided a best effort situation on resolving this however are unable to find what exactly is causing the options table for the sub blogs to be generated. We have exhausted all organic resources on this issue from this point and must remind that third party web applications
    are given an unsupported status by DataPipe's support. We will be more than happy to provide additional changes, server modifications and the like however this particular issue is related to the Wordpress software and further information on it should be received from the developers of
    said software.

    Thank you,

    -- Jay Gordon
    Unix Systems Administrator
    DataPipe Support Team"

    Any way to by pass these issues? Correctly if possible of course! I just spent the last three or so days, basically riding on no sleep whatsoever on the issue and still can't get it running right..

    Only other option is to upgrade everything to PHP 5.X.X and MySql 5.X.X versions on his whole server. Which is sad, because he only needs it done on ONE domain name sigh. But, some hosts do it that way.. too bad they don't all do like Dreamhost.com does ...

    spencerp

  5. andrea_r
    Moderator
    Posted 13 years ago #

    Didn't we fix this in trac? Or does Donncha keep breaking it again? ;)

    I remember one time something like this got fixed, and all he did was add the "hide errors" line.

    spencerp - don't worry, your rep has preceeded you. ;) ;)

  6. drmike
    Member
    Posted 13 years ago #

    I thought we were still waiting for a fix.

  7. spencerp
    Member
    Posted 13 years ago #

    Didn't we fix this in trac? Or does Donncha keep breaking it again? ;)

    I remember one time something like this got fixed, and all he did was add the "hide errors" line.

    Yeah, I seen posts about that too. :) I checked those lines, and it was in fact done the "way" of the "fix". Which means what Donncha had "fixed" before, is still there.

    However, I tried reversing it once on a "what the heck do I have to lose" option.. haha.. Still no-go. I uploaded the original file and went back to bawling.. Must have gone through two boxes of tissues with the person I'm installing it for... And I'm not one to shed tears often either.. :P /Well, unless it's with some chick, while watching a nice chick flick with her lmao... Alright, waaay off-topic here.. lmao..

    spencerp - don't worry, your rep has preceeded you. ;) ;)

    Aww, thank you. :) I'd give a virtual hug n such, but Wank might see it and post about it lmao.. :P JK! LOL! You'll have to excuse my craziness here, riding on -20 some hours of sleep, how many 24oz bottles of Pepsi.. and who knows what else.. haha..

    I thought we were still waiting for a fix.

    I hope something gets fixed soon. The guy hasn't replied back to me nor his host about what he wants to do, so...right now the current option from the host is to Upgrade his PHP and MySql to 5.X.X versions... I guess it's back to crossing fingers again sigh...

    spencerp

  8. Speedboxer
    Member
    Posted 13 years ago #

    Go into the Config file and add:

    error_reporting(0);

    That'll get rid of those errors. :P Won't solve the problem, but you shouldn't see the errors anymore. :P LOL...

  9. spencerp
    Member
    Posted 13 years ago #

    LMAO!! I'll do that once.. I'll report back! Well, wouldn't have too, but just to be nice and do right thing! LOL!

    spencerp

  10. spencerp
    Member
    Posted 13 years ago #

    UPDATE: Still a no-go. Error's still spitting out... =/ Is there another possible quick work around LoL!

    Is there an option that maybe uses "false" rather then "0"? I don't know myself, I'm not a total DB professional yet. hahaha.. =P

    spencerp
    /Well, I suppose "0" would be same equivalent to "false" right, so.. hmm. =/

  11. Speedboxer
    Member
    Posted 13 years ago #

    Well, error_reporting(0) would be "false" to errors. Meaning, it should turn them off completely. You could change the PHP settings to turn them off that way, if you're allowed Custom PHP.ini files (or can get the host to change it)...

  12. spencerp
    Member
    Posted 13 years ago #

    Thanks Speedboxer! I just informed the host of that. :D ;)

    Main Ticket on the issue:
    Was started: Sat Mar 24 22:35:08 2007
    Last Updated: Mon Mar 26 20:51:22 2007

    This is just ONE ticket regarding most of this, but there is another ticket regarding same issue as well. I'm not totally sure on it's "size" alone, but it's enough sigh.

    Hopefully they'll take care of that in the php.ini file. At least for time being until "fix" comes through... I'd keep him updated/ upgraded on the latest files and needed informations as well.

    I do that with all the folks I upgrade for, and install for.. Thanks again Speedboxer for the tips. ;) :) You're a life saver!

    spencerp

  13. drmike
    Member
    Posted 13 years ago #

    Still shouldn't be the errors though.

  14. JeremyVisser
    Member
    Posted 13 years ago #

    Yeah, but if you hide the errors, there'll still be the issue of the blank page leading nowhere.

  15. nolageek
    Member
    Posted 13 years ago #

    Getting this as well.

    WordPress database error: [Table 'username_wordpressmu.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'wp_3_user_roles' LIMIT 1
    
    WordPress database error: [Table 'username_wordpressmu.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'blogname' LIMIT 1
    
    WordPress database error: [Table 'username_wordpressmu.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'siteurl' LIMIT 1
    
    WordPress database error: [Table 'username_wordpressmu.wp_3_options' doesn't exist]
    SELECT option_value FROM wp_3_options WHERE option_name = 'post_count' LIMIT 1
  16. spencerp
    Member
    Posted 13 years ago #

    UPDATE: Doing what Speedboxer suggested didn't work. I wonder if going to line 157 in the: wp-includes/wp-db.php file and setting it to false would help....? Hmmm..

    //Turn error handling on or off..

    function show_errors() {
    $this->show_errors = true;

    Hahaha. Nah.. Anyway, I just uploaded the TARBALL version of 1.1.1 - still don't work for a dang version of MU.. to a subdomain name on there: mu.vindictivebastard.net of course the wild card domain isn't on it.. but while adding/deleting it still spits errors..

    What I'm running on there:
    PHP version 4.4.4
    MySQL version 4.1.21-standard

    But like drmike says, "Still shouldn't be the errors though." If only ALL hosts operated like Dreamhost.com ...LoL!

    Nah, but really, there shouldn't be any error hiding going on correct? If it was awesomely coded to begin with, there wouldn't be anything to hide... hahaha. Just kidding course!

    Hopefully it will be "fixed" soon, and Jeremy is working on something at the moment... Not sure what, but he's working.. :P

    spencerp

  17. spencerp
    Member
    Posted 13 years ago #

    Also, on the VB.net MU site when deleting a blog.. I got same error as this person:
    http://mu.wordpress.org/forums/topic.php?id=3819&replies=9

    spencerp

  18. spencerp
    Member
    Posted 13 years ago #

    Just another update on this.. When having the host turn error reporting OFF in the PHP.INI file, and doing that little hack/fix suggestion of mine above.. Errors go away of course..

    However, turning error reporting ON in PHP.INI, and doing my little "hack/fix" .. errors still spit.. Here's what I got:

    WordPress database error: [Table 'mydatabasename.2_options' doesn't exist]
    SELECT option_value FROM 2_options WHERE option_name = '2_user_roles' LIMIT 1

    array(7) {
    [0]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(254)
    ["function"]=>
    string(11) "print_error"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(44) "Table 'mydatabasename.2_options' doesn't exist"
    }
    }
    [1]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(322)
    ["function"]=>
    string(5) "query"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(77) "SELECT option_value FROM 2_options WHERE option_name = '2_user_roles' LIMIT 1"
    }
    }
    [2]=>
    array(6) {
    ["file"]=>
    string(60) "/home/sites/www.mydomain.net/web/wp-includes/functions.php"
    ["line"]=>
    int(232)
    ["function"]=>
    string(7) "get_row"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(77) "SELECT option_value FROM 2_options WHERE option_name = '2_user_roles' LIMIT 1"
    }
    }
    [3]=>
    array(4) {
    ["file"]=>
    string(63) "/home/sites/www.mydomain.net/web/wp-includes/capabilities.php"
    ["line"]=>
    int(23)
    ["function"]=>
    string(10) "get_option"
    ["args"]=>
    array(1) {
    [0]=>
    &string(12) "2_user_roles"
    }
    }
    [4]=>
    array(6) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(360)
    ["function"]=>
    string(5) "_init"
    ["class"]=>
    string(8) "wp_roles"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(0) {
    }
    }
    [5]=>
    array(4) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-admin/admin-db.php"
    ["line"]=>
    int(520)
    ["function"]=>
    string(14) "switch_to_blog"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(2)
    }
    }
    [6]=>
    array(4) {
    ["file"]=>
    string(57) "/home/sites/www.mydomain.net/web/wp-admin/wpmu-edit.php"
    ["line"]=>
    int(254)
    ["function"]=>
    string(16) "wpmu_delete_blog"
    ["args"]=>
    array(2) {
    [0]=>
    ∫(2)
    [1]=>
    &bool(true)
    }
    }
    }

  19. JeremyVisser
    Member
    Posted 13 years ago #

    That's the stack trace I ordered Spence to do to help debug the issue.

  20. spencerp
    Member
    Posted 13 years ago #

    This is when deleting a blog.. by the way.. I'll do it for "adding a blog" once.. and report back with error..

    spencerp

  21. spencerp
    Member
    Posted 13 years ago #

    Here are the errors I get when ADDING A BLOG.. ;)

    WordPress database error: [Table 'mydatabasename.5_options' doesn't exist]
    SELECT option_value FROM 5_options WHERE option_name = '5_user_roles' LIMIT 1

    array(10) {
    [0]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(254)
    ["function"]=>
    string(11) "print_error"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(44) "Table 'mydatabasename.5_options' doesn't exist"
    }
    }
    [1]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(322)
    ["function"]=>
    string(5) "query"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(77) "SELECT option_value FROM 5_options WHERE option_name = '5_user_roles' LIMIT 1"
    }
    }
    [2]=>
    array(6) {
    ["file"]=>
    string(60) "/home/sites/www.mydomain.net/web/wp-includes/functions.php"
    ["line"]=>
    int(232)
    ["function"]=>
    string(7) "get_row"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(77) "SELECT option_value FROM 5_options WHERE option_name = '5_user_roles' LIMIT 1"
    }
    }
    [3]=>
    array(4) {
    ["file"]=>
    string(63) "/home/sites/www.mydomain.net/web/wp-includes/capabilities.php"
    ["line"]=>
    int(23)
    ["function"]=>
    string(10) "get_option"
    ["args"]=>
    array(1) {
    [0]=>
    &string(12) "5_user_roles"
    }
    }
    [4]=>
    array(6) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(360)
    ["function"]=>
    string(5) "_init"
    ["class"]=>
    string(8) "wp_roles"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(0) {
    }
    }
    [5]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(178)
    ["function"]=>
    string(14) "switch_to_blog"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [6]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(198)
    ["function"]=>
    string(16) "get_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [7]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1220)
    ["function"]=>
    string(20) "refresh_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [8]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1180)
    ["function"]=>
    string(11) "insert_blog"
    ["args"]=>
    array(3) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(1) "1"
    }
    }
    [9]=>
    array(4) {
    ["file"]=>
    string(57) "/home/sites/www.mydomain.net/web/wp-admin/wpmu-edit.php"
    ["line"]=>
    int(139)
    ["function"]=>
    string(16) "wpmu_create_blog"
    ["args"]=>
    array(6) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(12) "spencerp 2.0"
    [3]=>
    &string(1) "3"
    [4]=>
    &string(0) ""
    [5]=>
    &string(1) "1"
    }
    }
    }

    WordPress database error: [Table 'mydatabasename.5_options' doesn't exist]
    SELECT option_value FROM 5_options WHERE option_name = 'blogname' LIMIT 1

    array(9) {
    [0]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(254)
    ["function"]=>
    string(11) "print_error"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(44) "Table 'mydatabasename.5_options' doesn't exist"
    }
    }
    [1]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(322)
    ["function"]=>
    string(5) "query"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(73) "SELECT option_value FROM 5_options WHERE option_name = 'blogname' LIMIT 1"
    }
    }
    [2]=>
    array(6) {
    ["file"]=>
    string(60) "/home/sites/www.mydomain.net/web/wp-includes/functions.php"
    ["line"]=>
    int(232)
    ["function"]=>
    string(7) "get_row"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(73) "SELECT option_value FROM 5_options WHERE option_name = 'blogname' LIMIT 1"
    }
    }
    [3]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(293)
    ["function"]=>
    string(10) "get_option"
    ["args"]=>
    array(1) {
    [0]=>
    &string(8) "blogname"
    }
    }
    [4]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(180)
    ["function"]=>
    string(15) "get_blog_option"
    ["args"]=>
    array(2) {
    [0]=>
    ∫(5)
    [1]=>
    &string(8) "blogname"
    }
    }
    [5]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(198)
    ["function"]=>
    string(16) "get_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [6]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1220)
    ["function"]=>
    string(20) "refresh_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [7]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1180)
    ["function"]=>
    string(11) "insert_blog"
    ["args"]=>
    array(3) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(1) "1"
    }
    }
    [8]=>
    array(4) {
    ["file"]=>
    string(57) "/home/sites/www.mydomain.net/web/wp-admin/wpmu-edit.php"
    ["line"]=>
    int(139)
    ["function"]=>
    string(16) "wpmu_create_blog"
    ["args"]=>
    array(6) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(12) "spencerp 2.0"
    [3]=>
    &string(1) "3"
    [4]=>
    &string(0) ""
    [5]=>
    &string(1) "1"
    }
    }
    }

    WordPress database error: [Table 'mydatabasename.5_options' doesn't exist]
    SELECT option_value FROM 5_options WHERE option_name = 'siteurl' LIMIT 1

    array(9) {
    [0]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(254)
    ["function"]=>
    string(11) "print_error"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(44) "Table 'mydatabasename.5_options' doesn't exist"
    }
    }
    [1]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(322)
    ["function"]=>
    string(5) "query"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(72) "SELECT option_value FROM 5_options WHERE option_name = 'siteurl' LIMIT 1"
    }
    }
    [2]=>
    array(6) {
    ["file"]=>
    string(60) "/home/sites/www.mydomain.net/web/wp-includes/functions.php"
    ["line"]=>
    int(232)
    ["function"]=>
    string(7) "get_row"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(72) "SELECT option_value FROM 5_options WHERE option_name = 'siteurl' LIMIT 1"
    }
    }
    [3]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(293)
    ["function"]=>
    string(10) "get_option"
    ["args"]=>
    array(1) {
    [0]=>
    &string(7) "siteurl"
    }
    }
    [4]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(181)
    ["function"]=>
    string(15) "get_blog_option"
    ["args"]=>
    array(2) {
    [0]=>
    ∫(5)
    [1]=>
    &string(7) "siteurl"
    }
    }
    [5]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(198)
    ["function"]=>
    string(16) "get_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [6]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1220)
    ["function"]=>
    string(20) "refresh_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [7]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1180)
    ["function"]=>
    string(11) "insert_blog"
    ["args"]=>
    array(3) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(1) "1"
    }
    }
    [8]=>
    array(4) {
    ["file"]=>
    string(57) "/home/sites/www.mydomain.net/web/wp-admin/wpmu-edit.php"
    ["line"]=>
    int(139)
    ["function"]=>
    string(16) "wpmu_create_blog"
    ["args"]=>
    array(6) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(12) "spencerp 2.0"
    [3]=>
    &string(1) "3"
    [4]=>
    &string(0) ""
    [5]=>
    &string(1) "1"
    }
    }
    }

    WordPress database error: [Table 'mydatabasename.5_options' doesn't exist]
    SELECT option_value FROM 5_options WHERE option_name = 'post_count' LIMIT 1

    array(9) {
    [0]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(254)
    ["function"]=>
    string(11) "print_error"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(44) "Table 'mydatabasename.5_options' doesn't exist"
    }
    }
    [1]=>
    array(6) {
    ["file"]=>
    string(56) "/home/sites/www.mydomain.net/web/wp-includes/wp-db.php"
    ["line"]=>
    int(322)
    ["function"]=>
    string(5) "query"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(75) "SELECT option_value FROM 5_options WHERE option_name = 'post_count' LIMIT 1"
    }
    }
    [2]=>
    array(6) {
    ["file"]=>
    string(60) "/home/sites/www.mydomain.net/web/wp-includes/functions.php"
    ["line"]=>
    int(232)
    ["function"]=>
    string(7) "get_row"
    ["class"]=>
    string(4) "wpdb"
    ["type"]=>
    string(2) "->"
    ["args"]=>
    array(1) {
    [0]=>
    &string(75) "SELECT option_value FROM 5_options WHERE option_name = 'post_count' LIMIT 1"
    }
    }
    [3]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(293)
    ["function"]=>
    string(10) "get_option"
    ["args"]=>
    array(1) {
    [0]=>
    &string(10) "post_count"
    }
    }
    [4]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(182)
    ["function"]=>
    string(15) "get_blog_option"
    ["args"]=>
    array(2) {
    [0]=>
    ∫(5)
    [1]=>
    &string(10) "post_count"
    }
    }
    [5]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(198)
    ["function"]=>
    string(16) "get_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [6]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1220)
    ["function"]=>
    string(20) "refresh_blog_details"
    ["args"]=>
    array(1) {
    [0]=>
    ∫(5)
    }
    }
    [7]=>
    array(4) {
    ["file"]=>
    string(65) "/home/sites/www.mydomain.net/web/wp-includes/wpmu-functions.php"
    ["line"]=>
    int(1180)
    ["function"]=>
    string(11) "insert_blog"
    ["args"]=>
    array(3) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(1) "1"
    }
    }
    [8]=>
    array(4) {
    ["file"]=>
    string(57) "/home/sites/www.mydomain.net/web/wp-admin/wpmu-edit.php"
    ["line"]=>
    int(139)
    ["function"]=>
    string(16) "wpmu_create_blog"
    ["args"]=>
    array(6) {
    [0]=>
    &string(23) "spencerp.mydomain.net"
    [1]=>
    &string(1) "/"
    [2]=>
    &string(12) "spencerp 2.0"
    [3]=>
    &string(1) "3"
    [4]=>
    &string(0) ""
    [5]=>
    &string(1) "1"
    }
    }
    }

  22. spencerp
    Member
    Posted 13 years ago #

    Another Update: I just tested a few things on my MU copy on Dreamhost.com account too.

    I changed the PHP 5.2.1 to 4.4.2 and tried adding a blog, I got those errors again. Then, put it back to PHP 5.2.1 and tried to delete it.. no errors but when hitting the "confirm" button it just keeps on that page. It don't redirect back to the "section" of which I was at to begin with...

    Had to manually remove excess crap at end of URL to go back to where I was at...

    spencerp

  23. spencerp
    Member
    Posted 13 years ago #

    UPDATE AGAIN: Here below is what I have done......

    I added these two lines to the .htaccess file:
    php_flag display_errors off
    php_value error_reporting 7

    PLEASE ADVISE: Does this turn error reporting off for just that domain, or is it server wide action?

    This goes along with the "error_reporting(0);" in the wp-config.php file, and that other little "hack/fix" to the wp-db.php file on line 153...setting to: false.

    Errors seemed to be down! However, I'm stuck on the redirecting back to where I was from, after clicking on the confirm "blog delete" buttons...

    Here's the code in reference...

    wp-admin/wpmu-edit.php
    <?php
    break;
    default:
    wpmu_admin_do_redirect( "wpmu-admin.php" );
    break;
    }
    ?>

    wp-admin/wpmu-functions.php
    // wpmu admin functions

    function wpmu_admin_do_redirect( $url = '' ) {
    if( $_REQUEST[ 'ref' ] ) {
    $ref = $_REQUEST[ 'ref' ];
    $ref = wpmu_admin_redirect_add_updated_param( $_REQUEST[ 'ref' ] );
    header( "Location: {$ref}" );
    die();
    }
    if( empty( $_SERVER[ 'HTTP_REFERER' ] ) == false ) {
    wp_redirect( $_SERVER[ 'HTTP_REFERER' ] );
    die();
    }

    $url = wpmu_admin_redirect_add_updated_param( $url );
    if( isset( $_GET[ 'redirect' ] ) ) {
    if( substr( $_GET[ 'redirect' ], 0, 2 ) == 's_' ) {
    $url .= "&action=blogs&s=". wp_specialchars( substr( $_GET[ 'redirect' ], 2 ) );
    }
    } elseif( isset( $_POST[ 'redirect' ] ) ) {
    $url = wpmu_admin_redirect_add_updated_param( $_POST[ 'redirect' ] );
    }
    header( "Location: {$url}" );
    die();
    }
    function wpmu_admin_redirect_add_updated_param( $url = '' ) {
    if( strpos( $url, 'updated=true' ) === false ) {
    if( strpos( $url, '?' ) === false ) {
    return $url . '?updated=true';
    } else {
    return $url . '&updated=true';
    }
    }
    return $url;
    }

    function wpmu_admin_redirect_url() {
    if( isset( $_GET[ 's' ] ) ) {
    return "s_".$_GET[ 's' ];
    }
    }

    Is there a possible hard code REDIRECT that could be done up in the "wpmu-edit.php file? Or, maybe hard code in there a "link" so someone could go back to the originating place? Or..? Thanks..

    spencerp

  24. donncha
    Key Master
    Posted 13 years ago #

    This has been fixed in this changeset - http://trac.mu.wordpress.org/changeset/952

    Unfortunately not in time for the 1.2.1 release, but if you apply the diff above to wpmu-functions.php that will hide the errors.

  25. spencerp
    Member
    Posted 13 years ago #

    donncha, thanks. :) For the most part this is working! :) However, the error below still occurs when after deleting blog, after hitting second "confirm" button.

    WordPress database error: [Table 'databasename.13_options' doesn't exist]
    SELECT option_value FROM 13_options WHERE option_name = '13_user_roles' LIMIT 1

    But, if doing the method I said before: At line 157 in the: wp-includes/wp-db.php file and setting it to false, does help hide those errors...

    Change this:

    //Turn error handling on or off..

    function show_errors() {
    $this->show_errors = true;

    To this:

    //Turn error handling on or off..

    function show_errors() {
    $this->show_errors = false;

    That error when deleting blog doesn't occur then when after doing my "work around". I'd like to know though, does hiding these errors from showing, just cover an actual existing problem? Or, do those errors really occur by mistake and everything is actually working fine?

    Because shouldn't we be trying to fix the actual issue(s) rather then just hiding them lmao? :P

    Also, that redirect issue still exists after deleting the blog, on second "confirm" button submitting.. It just sits there.. doesn't take the user back to the initial page he came from ... :(

    Is there a work around for this too? Maybe slap in a hard link or something for someone to click to go back to where they originally were lmao? Just wanted to update everone this.. and thanks again Donncha, most of the errors are hidden now at least.. and I don't have to worry about putting the following two lines in the .htaccess file anymore! Woot Woot!!

    php_flag display_errors off
    php_value error_reporting 7

    We're slowly getting some where folks! Slowly but surely! :D

    spencerp

  26. drmike
    Member
    Posted 13 years ago #

    WHOA! We got another coder handy. heh heh :)

About this Topic