The MU forums have moved to WordPress.org

WordPress MU 1.2 (18 posts)

  1. donncha
    Key Master
    Posted 10 years ago #

    Go grab the new WPMU from the download page. It's a bugfix release, but also has a security fix too. I'll post the fix here in a few days if you can't update.

    Oh, and I'm going to post a tutorial on customizing the signup form but it uses hooks from the new release so that'll be another reason to upgrade!

  2. suleiman
    Member
    Posted 10 years ago #

    very sweet donncha! Looking forward to the upgrade!

  3. lunabyte
    Member
    Posted 10 years ago #

    Is that so...

    And just when I was getting used to 1.1.1, too. :D

    Nice work, Donncha. ;)

  4. zappoman
    Member
    Posted 10 years ago #

    Yeah! I didn't upgrade to 1.1.1 yet... How smart am I now?

    Plus I love the idea of new signup hooks. Thanks Donncha!

  5. JeremyVisser
    Member
    Posted 10 years ago #

    WPMU 1.2 still has the problem where the site-wide theme settings keep snapping back to their original settings.

    I can't use 1.2 until this is fixed.

    Plus, the

    wp-includes/version.php
    doesn't contain the new version.

  6. demonicume
    Member
    Posted 10 years ago #

    did the upgrade., now i have some questions:

    1)my admin screen still reads Mu 1.1.1 at the bottom. what does that mean? i believe the upgrade worked - or at least some things were changed as my
    2) my-plugins (via Main Site Only Hacks ) have all quit working in the My-plugins folder. (My not Mu)

    so is my upgrade all cheezed up?

  7. Farms2
    Member
    Posted 10 years ago #

    Looking forward to the security fix :)

  8. spencerp
    Member
    Posted 10 years ago #

    I'll give it ago once. :) By any chance, were the errors from here down fixed in this update? Just was wondering.. :)

    spencerp

  9. donncha
    Key Master
    Posted 10 years ago #

    Oops, I forgot to update version.php and if I'm reading that 'my-plugins' post right, you'll have to update wp-settings.php again. I presume you copied over that file when you updated?

    JeremyVisser - which ticket is that? I wasn't aware there was a problem like that.

    BTW - visit "Site Admin->Themes" and hit Save on that page. The format of allowed themes changed and needs to be updated.

    Farms2 - it might be worth upgrading, besides the specific security hole I fixed in WPMU, there were a number of secuity fixes and casting of input parameters merged from WP that you should update too.

  10. Farms2
    Member
    Posted 10 years ago #

    Eeek, week long pain process ahead ;)

  11. JeremyVisser
    Member
    Posted 10 years ago #

    Yeah, I did do that but nothing was changed or updated. I even tried deleting my allowed_themes entry in the database and all that, and it was never re-created when I hit the update button, however, if I reverted to a rev. before 936 it would get re-created.

  12. GIGALinux
    Member
    Posted 10 years ago #

    1.2.1 is out!

  13. donncha
    Key Master
    Posted 10 years ago #

    Download page has been updated with a new 1.2.1 release. If you're upgrading from 1.2 only a few files have been changed:

    wp-admin/themes.php
    htaccess.dist
    wp-includes/version.php
    wp-admin/admin-db.php
    wp-admin/themes.php
    wp-admin/wpmu-themes.php

    Unzip the archive somewhere and copy those files into your install.

    The warning message that appears on the themes page is only visible to site administrators. Your users won't see thyat at all!

  14. kosir
    Member
    Posted 10 years ago #

    Upgraded to 1.2.1 and everything is OK for now :)

  15. demonicume
    Member
    Posted 10 years ago #

    1 bad thing and 1 good thing:

    BAD) in a rush of coffee, diapers and keyboards - i cacked up the upgrade to 1.2.1 and had to do a full restore back to 1.2. we're good to go on that front now.
    GOOD) this upgrade fixed my KSES.php issues. it fixed my text widgets (which werent working ) if there's a way to mark threads resolved - then this upgrade will clear up a lot of things i've seen (and all of the things i wrote)

    THANKS!

    maybe i'll get brave and try the upgrade later when my kid isnt in my lap.

  16. enseignement
    Member
    Posted 10 years ago #

    I've tried to update my wp-settings with the my-plugins thing but it fails :

    Fatal error: Cannot redeclare global_categories() (previously declared in C:\Apache\www\blog\wp-content\my-plugins\global-categories.php:3) in C:\Apache\www\blog\wp-content\mu-plugins\global-categories.php on lin

  17. JeremyVisser
    Member
    Posted 10 years ago #

    It looks like you have the same plugin in both my-plugins and mu-plugins. You don't need both, only put it in mu-plugins

  18. gumdrop
    Member
    Posted 10 years ago #

    Well that was rather painless :-{}

About this Topic