The MU forums have moved to WordPress.org

bad .htaccess file in wpmu 1.2 (12 posts)

  1. joshhighland
    Member
    Posted 17 years ago #

    i spent half the night trying to figure out why I was getting 404 errors all over the place (internal to pages like wp-admin)

    I found the problem to be the .htaccess files that the clean install of wpmu 1.2 was generating.

    GENERATED FILE
    --------------
    RewriteEngine On
    RewriteBase /blogs/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    -----------------------------------------------------

    it looked like
    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    was being added more times then needed.

    MY MODIFIED .htaccess file
    --------------------------
    RewriteEngine On
    RewriteBase /blogs/

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]
    ---------------------------------------------------

    what do you know, everything works now! please update the files that generate the .htaccess file to help new users like myself from banging their head on their desk after installing wpmu 1.2

    --Josh Giese

  2. donncha
    Key Master
    Posted 17 years ago #

    Thanks Josh, can you give me some details about your install? Those lines were added to fix another (obscure) problem but if your setup is a common one then it should be reversed.

  3. KKWangen
    Member
    Posted 17 years ago #

    I have the same problem on a non-vhost install, so I had to go with Josh's mod to make it work.

  4. leon3020
    Member
    Posted 17 years ago #

    vi apache/path/conf/httpd.conf

    Add below options to the apache config ,then it'll work.

    Good luck:D

    <Directory "/DocumentRoot/to/wordpressmu">
    RewriteEngine on
    Options FollowSymLinks
    AllowOverride FileInfo Options
    Order allow,deny
    Allow from all
    </Directory>

  5. KKWangen
    Member
    Posted 17 years ago #

    This was fixed in 1.2.1 - at least for me.

  6. suleiman
    Member
    Posted 17 years ago #

    gheeeze...we're up to 1.2.1 already? Feels like only yesterday we were at 1.1.1.

    Anyways, i can't wait till WPMU 2.0

    Will it be all web 2.0? =p

  7. KKWangen
    Member
    Posted 17 years ago #

    I'm still waiting for web 3.0 ;-)

  8. joshhighland
    Member
    Posted 17 years ago #

    i installed 1.2.1 and the problem is gone now.

  9. jelly
    Member
    Posted 16 years ago #

    I had this problem with wpmu 1.2.3, and adding

    <Directory "/DocumentRoot/to/wordpressmu">
    RewriteEngine on
    Options FollowSymLinks
    AllowOverride FileInfo Options
    Order allow,deny
    Allow from all
    </Directory>

    to httpd.conf solved my problem

  10. mdazam
    Member
    Posted 16 years ago #

    What if I dont have access to httpd.conf
    I'm using hosted server ? Please advice.

  11. drmiketemp
    Member
    Posted 16 years ago #

    Ask your host to make the changes.

  12. neosin09
    Member
    Posted 15 years ago #

    didn't work for me... still have the 404 problem

    http://mu.wordpress.org/forums/topic.php?id=12341

About this Topic

  • Started 17 years ago by joshhighland
  • Latest reply from neosin09