The MU forums have moved to WordPress.org

I can't login. Keep getting redirected to login page. (11 posts)

  1. nolageek
    Member
    Posted 17 years ago #

    It was working fine last night, the last time I logged in. I upgraded to 1.2.1 a few hours before that and it was running fine... I was logging in and out of accounts and everything.

    Today, I go to log in and I get tons of errors about the pxsmail plugin. I delete the plugin. (It's been running fine for almost 4 days with it though.)

    I try to login again and I'm redirected to the following page and get asked to log in again:

    http://blognola.org/wp-login.php?action=auth&redirect_to=%2Fwp-admin%2F

    I log in again and I make it to my dashboard, but there is a login box in the middle of the page. I login again, not knowing what else to do and I get redirected to the above address again. I login again and I'm at the dashboard once again. There's multiple login boxes overlaid over each other all over my screen.

    I click on a menu item and I get something telling me a technical support code. I figure out that it's Bad Behaviour.

    I delete the bad behaviour plugin, try to login again and I get the same weird behaviour.

    I check my .htaccess file and it looks good, but overwrite everything just to be safe.

    Now, I can even get into dashboard, I just get looped over and over asking for the login.

    WTF?

    I don't see anything too weird in my access logs.

    Running WPMU 1.2.1

  2. nolageek
    Member
    Posted 17 years ago #

    Here's the error I got re: pxsmail.php

    PHP Warning:  session_start() [<a href='function.session-start'>function.session-start</a>]: Cannot send session cache limiter - headers already sent (output started at /home/nolageek/public_html/wp-content/mu-plugins/pxsmail.php:1) in /home/nolageek/public_html/wp-content/mu-plugins/pxsmail.php on line 1
    [Mon Apr  2 03:54:17 2007] [error] PHP Warning:  session_start() [<a href='function.session-start'>function.session-start</a>]: The session id contains invalid characters, valid characters are only a-z, A-Z and 0-9 in /home/nolageek/public_html/wp-content/mu-plugins/pxsmail.php on line 1
  3. nolageek
    Member
    Posted 17 years ago #

  4. nolageek
    Member
    Posted 17 years ago #

    I just re uploaded all of the wp-admin 1.2.1 and I'm getting the same thing. I've been flushing my cookies and and cache after each attempt.

    tried deleting my /wp-content/cache directory and recreating it. Same thing.

    Set enable_cache to false. Same thing.

    I'm now completely freaked out. I have backup from when I was running 1.1.1 ... should I go to that?

  5. nolageek
    Member
    Posted 17 years ago #

    OK. Restored backup from two days ago and it's still doing it.

  6. nolageek
    Member
    Posted 17 years ago #

    OK. Completely weird. It just stopped, out of nowhere. I'm using the same machine and I haven't changed anything on the server since the last post.

    Could this have been caused by something on the end of the database? I asked my host to restart it but I haven't heard from them that they have yet.

  7. demonicume
    Member
    Posted 17 years ago #

    redirect login issue and no one had a solution for you? now you've been initiated.

  8. suleiman
    Member
    Posted 17 years ago #

    looks like blog nola went blog nada ;)

  9. Jairus
    Member
    Posted 17 years ago #

    I'm having the same issue, but with a fresh install. Haven't been able to login once.

  10. StefanAnion
    Member
    Posted 17 years ago #

    same issue here. i've tried the IT Damage fix for wp-settings.php but it crashes WPMU completely. Does anyone know why this is happening? anyone?

  11. nolageek
    Member
    Posted 17 years ago #

    It was a cookie issue for me... it was also causing lots of problems with bbpress until asmallorange support sent me this:

    I finally figured it out. We have Suhosin installed in PHP, which doesn't show up visibly because it's a security extension designed to keep PHP from being hacked. One of the things it does is encrypt cookies, and that's what tipped me off because I noticed the cookies going out didn't match the ones coming back in. I'm guessing it's a bug in Suhosin, so I've disabled it's cookie encrypting functionality and it's now possible to do all the things you're used to being able to do.

    Also, make sure it's not redirecting you to the oposite www/no-www version of the URL

About this Topic

  • Started 17 years ago by nolageek
  • Latest reply from nolageek