The MU forums have moved to WordPress.org

charset is UTF-8 Unicode, DB collation is utf8_general_ci but still not working (8 posts)

  1. flasharabia
    Member
    Posted 17 years ago #

    i installed WPMU yesterday and wanted to start translating it to Arabic, so whats best to start by stating the site title in Arabic, right? and when I entered the title and saved, I got "???? ??????" for the title.

    I made sure that everything is communicating using the UTF-8 charset, and all is set correctly to my knowledge. So i thought this might be an error in the wp-config.php and I found this:
    define('DB_CHARSET', 'utf8');

    I tried changing to utf-8, but still no luck...

  2. Hassan1
    Member
    Posted 17 years ago #

    Hey, Brother! I have this problem,too
    Any idea?

  3. Londona
    Member
    Posted 17 years ago #

    I have this ptoblem too, please help us

  4. mollonado
    Member
    Posted 17 years ago #

    open wp-config.php and see if DB_CHARSET equals 'utf8'
    define('DB_CHARSET', 'utf8');

  5. Londona
    Member
    Posted 17 years ago #

    It's so of courese, theres something another we don't know

  6. opus123
    Member
    Posted 17 years ago #

    Was your database created as UTF-8? (default is Latin)

    things to check:

    1) DB should be UTF-8 if not then comment define('DB_CHARSET', 'utf8');

    2) you should use: content="text/html; charset=UTF-8"

    3) page content should be in UTF-8

  7. mellowbunny
    Member
    Posted 16 years ago #

    If worst comes to worst and you've made sure that you've completed opus123's list then you can try what I did.

    The problem will probably be that even though your DB and your tables are set to the right UTF your old fields most likely still hold the Latin encoding.

    I used phpMyAdmin to access the DB. I then exported the database into an SQL file with default settings.

    I opened the SQL file into my text editor (gedit on Ubuntu 7.04) and did a Find & Replace on the word 'latin1'. I changed all the results to 'utf8' and saved the file as a UTF-8 encoded file.

    I then went back into phpMyAdmin and dropped all the tables inside my WPMU database. Once that was done I imported the SQL file I had made.

    The result? I now have working UTF-8 database and can enter foreign characters no problem.

  8. Konstan
    Member
    Posted 16 years ago #

    I did the exact same right now...changed servers and all this was new to me. Notepad2 was very usefull (470k lines, all I had to do was replace latin1 to utf8, took less then 20 seconds).

    Some old posts still wont show some characters correctly, but new posts work. I will continue to see whats up, maybe I missed some other steps (first time with own server, have to tweak php and mysql).

About this Topic

  • Started 17 years ago by flasharabia
  • Latest reply from Konstan