The MU forums have moved to

no admin email (3 posts)

  1. peiqinglong
    Posted 17 years ago #

    Because my WPMu is installed on an internal webserver and because of political issues the webserver has no access to a mail server to send out emails.

    Since WPMu depends upon an email being sent out with the password, I cannot login to my WPMu site using my admin account after initial install. I, so far, have tried two methods:

    1. Login into the database and change the wp_user admin's password to something else. This seems to work except when I try to login and instead of taking me into the admin page, it just returns me to the login page with no error message. If I try to input a bad password on purpose, it returns an error. Odd.

    2. I've setup WPMu on another web server offsite and exported the database and reimported the database into the internal webserver's WPMu install and also changing all references to the external webserver to the internal webserver and try to login and it does the same thing as step 1.

    What am I doing wrong?

  2. drmike
    Posted 17 years ago #

    Sounds like a cookie issue if you're being brought back to the login page. What have you setup your URL to be? Can you check to see if you're getting a cokkie? What's the information from that cookie if you're getting one.

  3. peiqinglong
    Posted 17 years ago #

    Hrmmm, I was even thinking about cookies...

    I checked and no cookies are being created for WordPress. I've tried IE7 and FireFox.

    In terms of what the URL I'm using is: http://computername/, which I know probably isn't the best method, but until I can get the other option working, it's the best I got right now. Is there some other place in the database I need to specify the cookies or something?

About this Topic

  • Started 17 years ago by peiqinglong
  • Latest reply from peiqinglong