The MU forums have moved to WordPress.org

Fatal Error with memory size? (12 posts)

  1. TheFLyer
    Member
    Posted 15 years ago #

    Hello,
    I've tried to install Wordpress MU 1.2.1
    But...:
    Creating Database Config File: DONE

    Fatal error: Allowed memory size of 8388608 bytes exhausted (tried to allocate 30720 bytes) in /home/svetlio/public_html/wordpress-mu/wp-content/mu-plugins/pluggable.php on line 131

    Can somebody help me, to debug it?

  2. drmike
    Member
    Posted 15 years ago #

    I politely point you to a Google search. It's a fairly common PHP error.

  3. TheFLyer
    Member
    Posted 15 years ago #

    10x!

  4. skcsknathan001
    Member
    Posted 15 years ago #

    My MU site was working fine.

    But now I get this same error with the allowed memeory size.

    I never had problem before. Could It be in the upgrade?

    When I was running r888 .. there was no problem. But now I upgraded to r967.

    By the way there is no solution to this on the search. Its the web server ppl has to increase the memory.

    Would they do it?

  5. drmike
    Member
    Posted 15 years ago #

    The solution is to upgrade your php memory size. What size did you upgrade to? if you have to get your host to change their settings, that's what you have to do. They're incorrectly set for the software you are running.

  6. heyguy
    Member
    Posted 15 years ago #

    It was working fine for me for awhile until I upgraded to the latest version. I bumped my memory_limit up to a lucky 13M and it's all good again.

    Good luck with getting your host to change that for you. Some might say mu wasn't made for shared hosting.

  7. drmike
    Member
    Posted 15 years ago #

    Some might say mu wasn't made for shared hosting.

    Agreed. Considering it's against most host's AUPs on shared hosting....

  8. lunabyte
    Member
    Posted 15 years ago #

    Doc said it, and I'll agree.

    MU really should not be on shared hosting.

  9. drmike
    Member
    Posted 15 years ago #

    At least reselling or on shared with the approval of the host.

  10. skcsknathan001
    Member
    Posted 15 years ago #

    Okey I asked my host and they increased the php memeory size to 32MB ;)

  11. drmike
    Member
    Posted 15 years ago #

    Fixed, right?

  12. skcsknathan001
    Member
    Posted 15 years ago #

    Yes, yes, I didn't get errors like that so far.

    But I guess, there is a memory leak in the new versions. Or there is somewhere in the new code needs much more memory.

    But this error didn't show up with my older build

About this Topic

  • Started 15 years ago by TheFLyer
  • Latest reply from skcsknathan001