The MU forums have moved to WordPress.org

Installed WPMU but can't create additional blogs... (error message in post) (16 posts)

  1. c0y0te
    Member
    Posted 17 years ago #

    Can anyone tell me where I've gone wrong please? I've installed WPMU and am now trying to create additional blogs to test plugins/themes etc. but I get the following error messages when I do so:-

    WordPress database error: [Table 'aoconce_shamrogue.wp_4_options' doesn't exist]
    SELECT option_value FROM wp_4_options WHERE option_name = 'wp_4_user_roles' LIMIT 1

    WordPress database error: [Table 'aoconce_shamrogue.wp_4_options' doesn't exist]
    SELECT option_value FROM wp_4_options WHERE option_name = 'blogname' LIMIT 1

    WordPress database error: [Table 'aoconce_shamrogue.wp_4_options' doesn't exist]
    SELECT option_value FROM wp_4_options WHERE option_name = 'siteurl' LIMIT 1

    WordPress database error: [Table 'aoconce_shamrogue.wp_4_options' doesn't exist]
    SELECT option_value FROM wp_4_options WHERE option_name = 'post_count' LIMIT 1

  2. drmike
    Member
    Posted 17 years ago #

    What version of Mu are you running?

    How about some details as to your setup as well.

  3. c0y0te
    Member
    Posted 17 years ago #

    I downloaded WPMU 1.2.1

    It's installed on a bog standard Linux/Apache/MYSQL setup.

    The test site is http://www.shamrogue.com

    There were no install errors during the process, but this error shows up when I try to add additional blogs to the site.

    Any other information you need? Let me know. Thanks.

    c0y0te

  4. joshhighland
    Member
    Posted 17 years ago #

    I get the same error when I add a blog. ignore it!
    add the blog, get the error, then go back to the admin page. The blog will be crated and ready to use.

    I havent found any problems doing it that way

  5. theotheragentm
    Member
    Posted 17 years ago #

    I get the message and I understand that it can be ignored, but what is the next step. I see the blog in the admin panel, but I don't know what to do next.

  6. c0y0te
    Member
    Posted 17 years ago #

    The problem Josh is that even though it 'appears' to have created the blog, the blog is not accessible (e.g. blog.domain.com doesn't work).

    Still looking for an answer on this folks. Is there a new version or update of WPMU coming soon which addresses this issue?

  7. new-net
    Member
    Posted 17 years ago #

    This is a known 1.2.1 "issue", blabla read previous threads..

    But i will resume:

    Creating a blog within the admin panel will report errors end probably end up in option tables not being created properly.

    To create working blogs, use the sign in form from the main blog, your blogs will be fully working.

    - Someone : make a sticky post on that thread .. ?

  8. theotheragentm
    Member
    Posted 17 years ago #

    Sorry if this sounds dumb, but what is the sign in from the main blog? Is it in the admin panel? I just ran through it and didn't see anything. Am I missing something?

  9. new-net
    Member
    Posted 17 years ago #

    my english is bad.

    when you first install wordpress, you get a blog with the "home" theme installed.

    now if you browse to your wp-mu's base url, you will see something like :

    You can:

    * Login
    * Create a new blog

    Well.. click that "Create a new blog" link.

    Voila.

  10. theotheragentm
    Member
    Posted 17 years ago #

    Okay. I'll check it out. I changed the original theme. Thanks.

  11. c0y0te
    Member
    Posted 17 years ago #

    What is the link for that 'create blog' page? Sounds like something that should be on every WPMU theme in the meta section

  12. theotheragentm
    Member
    Posted 17 years ago #

    http://yourdomain.com/wp-signup.php The page is here. If you are logged in as admin, you will not see it.

    I just created the blog through this method and it emailed me a confirmation email. This link goes to a NOT FOUND page. I just tried test as a username and test.domain.com doesn't exist. It's like the same problem exists of creating a blog but not actually creating it. According to the answer I got in this thread, the subdomain exists in the database. http://mu.wordpress.org/forums/topic.php?id=4213&replies=4 If the blog name is virtual, how does the browser know how to handle blogname.domain.com?

    Sorry for all the edits and updates. I was able to activate my blog by going to domain.com instead of blogname.domain.com, but blogname.domain.com is still a NOT FOUND page.

  13. new-net
    Member
    Posted 17 years ago #

    how does the browser know how to handle blogname.domain.com?

    That's mod_rewrite magic.

    Make sure your apache config allows .htacces

    Double check apache logs

    Make sure your .htaccess was generated by the install

  14. theotheragentm
    Member
    Posted 17 years ago #

    So if I am getting file not found pages on the blog.domain.com URLs, it's likely that my mod_rewrite is not working? I looked at my hosts FAQ and mod_rewrite is enabled by default. I do have a .htaccess file, but I'm not sure if it was there by default or it was there for some other reason. Is there anything I can look for to see if it is working? I actually do see WP lines of code in there. I don't know what else to look for, so if you can let me know, I would appreciate it.

  15. new-net
    Member
    Posted 17 years ago #

    Enabeld won't mean activated.

    The module is now build & loaded on most systems.

    But :

    1) you need to enabel it (either globaly or in a precise virtualhost).

    2) your current virtualhost must have a directory directive allowing the use of .htaccess and mod_rewrite via htaccess (hmmm Authconfig & Multiviews iirc)

  16. drmike
    Member
    Posted 16 years ago #

    http://trac.mu.wordpress.org/changeset/952

    And please keep your WPMU install up to date.

About this Topic