The MU forums have moved to WordPress.org

Basic Questions About How MU WordPress Functions (7 posts)

  1. theotheragentm
    Member
    Posted 17 years ago #

    1. When I create it a blog, it asks me to create _____.domain.com, and I had a coupld of questions. Do we have to create teh subdomain first in order for this to work? Where do the file reside?

    2. I get an error when creating and deleting a new blog, but there seems to be a fix to suppress the error here. http://trac.mu.wordpress.org/ticket/184 That is all good and well if the blog is functioning, but the blog directory is empty. Should it be empty? Am I supposed to upload a WordPress single blog setup into the blog directory?

    I'm a bit confused as to how MU WordPress handles all of this. Thanks for any help.

  2. drmike
    Member
    Posted 17 years ago #

    The subdomains exists virtually. That's why mod_rewrite is so important. You can't create any directories.

    What blog directory are you looking at?

    Please remember that you need to give specifics. You'r the only one who can see what you're looking at. If you don't give details, we can't help you.

  3. andrea_r
    Moderator
    Posted 17 years ago #

    1. The subdoamin exists only in the database. you don't create anything on the server, everything (except uploaded files like pictures) is stored within the databse.
    this is the hardest thing to wrap your head around, but once you do, you're golden. :)

    2. yes the directory *on the server* should be empty. You aren;t suposed to upload anythign to any directories, especially not a regualr WP install.

    the error is a completely seperate issue. please post the error message and exactly the steps you took.

    Also, did you go to the blog address in question, after you created it? Is it on the list of blogs in Site Admin->Blogs?

  4. theotheragentm
    Member
    Posted 17 years ago #

    Okay, that makes sense now. The directory should be empty. Gotcha. So then how does the blogger start blogging on the blog I created for him?

    Yes the blog shows up in Site Admin > Blogs. Should there be a physical directory created automatically for the blog I created? I noticed this time around there is no directory. I think I added the directory myself last time.

  5. drmike
    Member
    Posted 17 years ago #

    It's virtual. No directories are created. (I think we say that up there)

    What happens when someone tries to view one of the blogs in question?

    With mod_rewrite, it should come up with fine.

  6. theotheragentm
    Member
    Posted 17 years ago #

    I didn't have wildcard DNS entries set up. Duh.

  7. drmike
    Member
    Posted 17 years ago #

    You're not the one one to do that around here. ;)

    Don't feel back.

About this Topic

  • Started 17 years ago by theotheragentm
  • Latest reply from drmike