The MU forums have moved to WordPress.org

Installs fine. Won't allow login. (27 posts)

  1. Zybez
    Member
    Posted 15 years ago #

    I install into the root ( http://www.gamerection.com ) and the DB tables and everything is made without a problem. I get an email with the admin username and password.

    I enter in the username and password accurately into the login form and press the button. The page refreshes, and takes me back to the login form with the fields cleared.

    What's wrong?!

  2. jstyle
    Member
    Posted 15 years ago #

    I am having the same problem I have installed the latest version of the wordpress mu.

  3. waffles
    Member
    Posted 15 years ago #

    The same thing is going on with me. Does anyone have a solution to this at all?

  4. drmike
    Member
    Posted 15 years ago #

    Not without some details. At the very least give us what browser, and version you;re using, what version of WPMu your using (Do note that versions have numbers and 'latest' isn't a number), details about how you have your site installed and a link to your site.

  5. wgfreitas
    Member
    Posted 15 years ago #

    I am having the same problem I have installed WordPress MU v1.2.3.

  6. drmike
    Member
    Posted 15 years ago #

    wgfreitas, see the post directly above yours and follow what is asked for. It's in very bad taste and very rude to ingore folks trying to help.

  7. wgfreitas
    Member
    Posted 15 years ago #

    Sorry.

    - Ubuntu 6.10
    - Apache/2.0.55
    - PHP/5.1.6
    - WordPress MU 1.2.3 (sub-directories)

    I have ran 'a2enmod rewrite' to enable mod_rewrite (Apache2).
    I have edited /etc/apache2/sites-enabled/000-default to change the Allowoverride value to all for the document root directory.
    httpd.conf is empty and I have added this code,

    <IfModule mod_rewrite.c>
    RewriteEngine On
    </IfModule>
    in apache2.conf file.

    DB tables and everything is made without problem.
    I enter in the username and password accurately into the login form and press the button. The page refreshes, and takes me back to the login form with the fields cleared.

    I have tested IE7 and Mozilla Firefox v2.0.0.4
    Thank you.

  8. dgilmour
    Member
    Posted 15 years ago #

    I enter in the username and password accurately into the login form and press the button. The page refreshes, and takes me back to the login form with the fields cleared.

    I've seen these symptoms with WPMU V1.0 RC4 when cookies from the site were blocked by the browser, so that might be worth checking. In Firefox 2 use Tools > Options > Privacy > Exceptions to see if cookies from http://www.gamerection.com are blocked.

  9. rbrandi
    Member
    Posted 15 years ago #

    I'm seeing this same problem. WPMU 1.2.3 installed on Mac OS X 10.4.10. MySQL 4.1.22. PHP 4.4.4. Apache 1.3.33. I have edited /etc/httpd/httpd.conf and /etc/hosts to add a virtual host named "swlfest" pointing at the WPMU installation on 127.0.0.1. All of the tables are created, installation was successful, but I get bounced when I try to log in. When I check the cookies in Firefox 2.0.0.4 or Safari 3.0.2beta, there are no cookies created for host name "swlfest".

  10. andrea_r
    Moderator
    Posted 15 years ago #

    "pointing at the WPMU installation on 127.0.0.1. "

    You can't use the home IP address. Change it to something like local.localhost instead.

  11. rbrandi
    Member
    Posted 15 years ago #

    That did it. I added swlfest.localhost to /etc/hosts and a virtual host of the same name to /etc/httpd/httpd.conf and that fixed the problem. Thanks.

  12. bruceallen
    Member
    Posted 15 years ago #

    I've got this issue too, and have been scouring the forums for hours and trying everything I've found.

    I'm trying to run WPMU as an intranet.

    Versions:

    WPMU - 1.2.4
    Apache - 1.3.33
    MySQL - 4.1.9
    PHP - 4.3.10

    The install runs fine and I can see the site on my local network at http://mht-intranet

    But when I put in the install-generated admin password, it just loops back to the login page.

    I've tried in both IE7 and Firefox 2.0.0.6

    I've wiped out the WP files and even the database to start over, but each time it is exactly the same.

    I'm a little leery of the .conf file stuff and might need some help with that if I'm asked to provide edit that file.

  13. lyons
    Member
    Posted 15 years ago #

    I had this problem. I was using a hostname with no qualifiers as bruceallen is e.g. http://myhost . I reinstalled using the full domain e.g. http://myhost.mydomain.com and login stopped redirecting back to itself

  14. kenwakita
    Member
    Posted 15 years ago #

    I had this problem on Mac OS X 10.4 and now it is fixed. What I have done is as follows.

    1. Remove the WPMU directory.
    2. Delete MySQL database tables.
    3. Add a local.localdomain to the /etc/hosts:127.0.0.1 entry.
    4. Unpack WPMU package.
    5. Follow the standard installation steps.

    I think the second step is important. Also, I have a feeling that 127.0.0.1 might have been used if I deleted db tables created for localhost configuration.

  15. kompol
    Member
    Posted 15 years ago #

    Hello, I have also the Login problem. The WP login site redirect back to it self. The "Lost your password?" link work well. I read here that you added some code on your server (if I understud that right) to fix this problem. I installed WPMU 1.2.5a to Dreamhost (the mod_rewrite is activated), what can I do to get this running?

  16. kenwakita
    Member
    Posted 15 years ago #

    I have not done any coding with my server. I am using a plain WPMU. What I have done is just erasing the entire MySQL tables using phpMySQL before re-installation of WPMU.

  17. kompol
    Member
    Posted 15 years ago #

    kenwakita - Thank you for have a look on my post. I do all this the first time and I am not very familiar with servers and databases but I give my best.

    I looked in my DreamHost admin panel but I could not find a option to create a phpMySQL database.

    It seems that this possibility don't fix my problem, what a bummer!

    Thank you,
    Andreas.

  18. sabas11
    Member
    Posted 15 years ago #

    Having the same issue here. Admin page just refreshes.

    I'm on Dreamhost, just downloaded the most recent MU version. Any help or answers to this yet?

  19. lunabyte
    Member
    Posted 15 years ago #

    Dreamhost is not MU friendly, and MU also apparently violates their TOS.

  20. sabas11
    Member
    Posted 15 years ago #

    What do you mean it's not MU-friendly? Can you expand? Probably got a rep that wasn't aware but they actually looked at my MU install and confirmed that all the permissions were ok.

  21. mcrider
    Member
    Posted 15 years ago #

    just had this problem (on a remote server), and i couldn't log in to the back end for wpmu even if i directly entered its real address. I fixed it by putting 'www' before my domain name. Weird stuff.

  22. veliapola
    Member
    Posted 14 years ago #

    Hi: I have found numerous threads regarding a "loop" from the admin log-in back to itself making it impossible to login but no solutions I can implement. I have installed wordpress mu 1.3 on globat hosting. More specifically, this is a re-install so I am sure everything is OK on the hosting end as nothing has changed. I did create a new database but with the same permissions as the old one, which functioned fine. Is there a fix for this?

  23. bavanyo
    Member
    Posted 14 years ago #

    I am having the same issue. My specifics are:
    Dreamhost,
    MU 1.3.3,
    Apache,
    PHP 5.2.3,
    MySQL 5.0.24

    I don't get the email after setup.

    I have reegular Wordpress running on Dreamhost just fine..

    Any ideas?

  24. Jwagener
    Member
    Posted 14 years ago #

    Wordpress MU 1.3
    PHP5
    Apache
    Mod_rewrite
    MySQL5
    Ubuntu 7.04
    Firefox 2.0.0.12 / Internet Explorer 7

    Hi, my installation worked alright - i got no errors. I chose to use sub-directories instead of sub-domains as i am using my local server for a test installation and dont feel like playing with my dns.

    I am getting a similar problem -- i add my details but then the login loops and wordpress tells me this: "ERROR: WordPress requires Cookies but your browser does not support them or they are blocked.".

    I have gone to the google site about enabling cookies and my setup is exactly the same as theirs is.

    Is there something wrong with my setup or my server?

    Please help as i would like to setup MU quite soon.

    PS. I also put this onto the back of my personal website to see if it was maybe not just my server and it did exactly the same thing. I host with http://www.webapps.co.za

    Kind regards,
    J

  25. veliapola
    Member
    Posted 14 years ago #

    I did a reinstall in a subdirectory on a Godaddy linux hosted site with new Wordpress MU 1.3.3 and everything works like dream! Easier install than Wordpress! (I have main site running Wordpress 2.3 and MU for my members)

  26. Jwagener
    Member
    Posted 14 years ago #

    very nice, but it unfortunately does not answer my Q :P

  27. andrea_r
    Moderator
    Posted 14 years ago #

About this Topic