The MU forums have moved to WordPress.org

MU login problems (8 posts)

  1. jstyle
    Member
    Posted 17 years ago #

    I have installed latest version of Wordpress MU. Installation was a sucess but when I try to login (user id & password are correct) it redirected me to login page instead of admin page and when I try to login again it redirected me to login page again.

    How to fix this issue?

  2. nolageek
    Member
    Posted 17 years ago #

    Sounds like a cookie issue. Make sure you clear your cookies. I was having this problem a while back also when my host had some kind of security module in PHP.. forget the name. It would scramble the cookie and render it unusable since it was different coming back than going out.

  3. c0y0te
    Member
    Posted 17 years ago #

    I've also seen this type of behaviour before when using firewalls (like zonealarm). Basically you need to enable cookies and then setup your site in the trusted zone to allow communication through without any interrupts.

  4. jstyle
    Member
    Posted 17 years ago #

    None of the suggestions worked.

    I try to login from differnt system even different network environment but same isssue.

    It doesn't seems to me a firewall issue.

    I think latest build got some issues related to redirection or may be my hosting service has.

  5. raymond
    Member
    Posted 17 years ago #

    I had a similar problem which occured when I changed a sub-blogs domainname.
    Wordpress MU: domain1.com
    Blog: domain2.com

    I had to make a change in wp-settings.php to make it work:

    around line 261:
    if ( !defined('COOKIE_DOMAIN') )
    define('COOKIE_DOMAIN', '.' . $current_site->domain);

    changed to:
    if ( !defined('COOKIE_DOMAIN') )
    define('COOKIE_DOMAIN', '.' . $_SERVER['HTTP_HOST']);

    which seems to have solved the problem.

  6. seanwedig
    Member
    Posted 17 years ago #

    I've also had a similar problem, regarding case-sensitivity of the login name used vs. what is in the DB.

    I don't remember exactly, but it was something like if you don't have the casing of the login name correct, you will be approved at the login form, but the cookie comparison will fail (and so you'll be redirected to the login form).

    Also, IIRC (possibly not), a mixed-case name can cause problems, because some places convert the user name to all lowercase, but it is inconsistent where it changes everything to lowercase, so sometimes it fails, and other times it does not. (I will need to confirm this for sure)

    I ended up having to login to my DB directly and change my username to an all-lower name, and then make sure that I only use the all-lower version of the login.

    Hope this helps - let us know if anything works!
    -sean

  7. flisespikker
    Member
    Posted 15 years ago #

    I have this same problem in wp-mu 2.7 (and 2.6.5) and solved it by editing wp-settings.php like Raymond suggested. Inspecting the cookies closer I see that the Host: field is set to .domain1.com and not domain2.com as expected.

  8. paico
    Member
    Posted 15 years ago #

    I changed all $current_site->domain of the wp-settings.php, as Raymond suggested, but still the same problem ... anyone know how to resolve?

About this Topic