The MU forums have moved to WordPress.org

"Error establishing a database connection" (8 posts)

  1. billdennis
    Inactive
    Posted 18 years ago #

    I've FTPed WPMU onto my site into a subdirectory called "WPMU." Ive opened that site and tried to fill out the username, database name, password, etc. I keep getting a message saying it can't establish a data base connection. Tech support at my host, "A Small Orange" assured me the Apache settings are corrct, as are the DB settings im inputting. I've even tried opening and manually entering the info in wp-config-sample.php and savign as wp-config.php.

    Does it cause a problem because I've gor a plain old WP site running right in the main directory off my domain? Tech support says there should not be a problem.

  2. jaseone
    Inactive
    Posted 18 years ago #

    Just to double check but did you do the add user to database step within MySQL databases on cPanel? That often gets forgotten.

  3. billdennis
    Inactive
    Posted 18 years ago #

    Yes. That's the first thing I did.

    The hosts keep telling me that everything is OK on their end.

  4. billdennis
    Inactive
    Posted 18 years ago #

    Quick question? if my blog files are kept in the file "/wpmu" then exactly what folder should hold wp-confit.php?

  5. billdennis
    Inactive
    Posted 18 years ago #

    I'm pretty sure I have a mangled installation. This was the confirmation email I received:

    Your new blog has been successfully set up at:
    http://com/wpmu/thecommunitymarketplace/

    You can log in to the administrator account with the following information:
    Username: XXXXX
    Password: XXXXX

    Login Here: http://com/wpmu/thecommunitymarketplace/wp-login.php

    Look at those addresses. Completely wrong. I try typing them commectly and I get nowhere.

    Anyway I can adjust them by manually re-writing some .php?

  6. jaseone
    Inactive
    Posted 18 years ago #

    The problem is the WPMU codebase is more tailored towards installing using the subdomain/virtual host method at the moment as opposed to installing into subdirectories like you have done so there are little quirks like the one with the emails.

    Other people have had similar problems so I suggest you read through the other posts here for workarounds.

    What was the problem with the database? btw I'm with ASO as well as you would be able to tell from their forums :D

  7. wiseoldowl
    Inactive
    Posted 18 years ago #

    Hi Bill, did you ever find out why you got those links that read http://com/? I've been trying to install WordPressmu and get the same stuff. Thanks.

  8. itdamager
    Member
    Posted 18 years ago #

    It's an install bug. You'll have to edit the database and change the domain and path settings manually.

About this Topic

  • Started 18 years ago by billdennis
  • Latest reply from itdamager