The MU forums have moved to WordPress.org

500 Internal Server Error - How I got it to work (4 posts)

  1. quikfire
    Inactive
    Posted 17 years ago #

    While trying to install WordPress MU, I had a 500 Internal Server Error.

    This was tested on Apache 1.3 on a Windows XP box, so it may not work for you. Anyways, this is what I did to remove the error:

    Edit .htaccess:
    1) Changed RewriteBase \/ to RewriteBase /
    2) At the bottom, under the comment '#catch all rules':

    Original:
    RewriteCond c:/wordpress/wp-inst/wp-content/blogs/$1 -d
    RewriteRule ^([_0-9a-z-]+)/ /wp-inst/index.php [L]

    Modified (added double quotes)
    RewriteCond "c:/wordpress/wp-inst/wp-content/blogs/$1" -d
    RewriteRule ^([_0-9a-z-]+)/ /wp-inst/index.php [L]

    3) I added double quotes for the second last line in .htaccess too.

    I'm not sure if these errors are specific to Windows only, though I suspect they are.

    I hope this will be of use to you.

  2. zoemorn
    Inactive
    Posted 17 years ago #

    I just added the double quotes around the pathways for each RewriteCond and that did it for me,
    setup: win2k pc + Apache2 + mysql 4.1.12 (dont forget to ebable BOTH mysql & mysqli (or just mysql) as at the time of this post it doesnt seem that WP works w/ mysqli (ihad a lot of trouble with this until i enabled mysql - i had been trying mysqli.)

    good luck!

  3. zoemorn
    Inactive
    Posted 17 years ago #

    if( defined( 'ABSPATH' ) == false )
    define( "ABSPATH", "../" ); had to do this in the .htaccess file (do a search under yer web directory)

    the first ABSPATH did not originally have the singlequotes. adding the single quotes solved the errors i got w/o them (first error was on line 6 with the ABSPATH

  4. JupitersCollision
    Member
    Posted 15 years ago #

    Some of you might have run into the same problem I did. I was getting an awful error message on my sites.

    "500 Internal Server Error"

    I searched all over the forums only to find minimum help. I even e-mailed tech support to my host provider and they told me to use more of their products because it was a problem with my wordpress installation.I went in and deactivated all the plug-ins that I had activated. Finally coming to one that was the problem.

    "WP-Cache 2.1.2 Plug-in - Very fast cache module. It’s composed of several modules, this plug-in can configure and manage the whole system. Once enabled, go to “Options” and select “WP-Cache”. By Ricardo Galli Granada."

    I went into the options and deleted the cache. Then deactivated it and BAM! back to normal.

    Good luck everyone!

    John

About this Topic

  • Started 2024 years ago by quikfire
  • Latest reply from JupitersCollision