The MU forums have moved to WordPress.org

Importing (24 posts)

  1. billdennis5
    Member
    Posted 15 years ago #

    I am trying to import a WP export file to a different WPMu site. The export file is more than 25M. The limit in WPmu is 2M. Is there any workaround. I am administrator for both sites. Both sites use recent releases.

  2. drmike
    Member
    Posted 15 years ago #

    Try increasing the upload limit size in php.ini

    Here's the first example I found on how to do it:

    http://drupal.org/node/97193

  3. billdennis5
    Member
    Posted 15 years ago #

    Thank you!!!

  4. drmike
    Member
    Posted 15 years ago #

    Not a problem. :)

  5. billdennis5
    Member
    Posted 14 years ago #

    OK. My WordPress export file (from a regular WP installation) is about 7MB. Myphp.ini file is set to allow imports of up to 64MB. I am still getting an error that says the file exceeds the 2MB limit in WPmu.

    Help!!!

  6. billdennis5
    Member
    Posted 14 years ago #

    BTW: I'm trying to import into a member blog, not the front-page blog.

  7. andrea_r
    Moderator
    Posted 14 years ago #

    Chunk it up into smaller files and do them one at a time. :)

  8. amanzi
    Member
    Posted 14 years ago #

    The site admin of a WPMU site can set the "Max upload file size" - although I thought this was just for media. If you're the site admin, try changing that value and see if it allows you to upload the file. It's in the Options section under Site Admin. (If you're not the site admin, then ask at your site.)

    @andrea_r - have you tried slicing up those files into smaller pieces? It's not easy... :)

  9. billdennis5
    Member
    Posted 14 years ago #

    Thanks for the advice.

    However ... I tried to set Max Upload File Size" to 9999 KB. I got a page can't be displayed message. I hit the back button in my browser and I was chastized for trying to upload an empty document. This is the same document it was told earlier was too large.

    Heh.

  10. billdennis5
    Member
    Posted 14 years ago #

    I'm bumping this up.

    Sometime during the next week, I'm going to upgrade to the most recent version of WPMu in hopes this fixes the problem. I have several suckers on the hook, I mean, several Peoria bloggers who want to move to my site from Blogspot.

    But if not, I'll be pestering the forum once again.

  11. billdennis5
    Member
    Posted 14 years ago #

    OK, I'm bumping this up again.

    The basic facts. Need to move posts, comments, categories, etc. from a WP 2.6 blog to one of my member blogs.

    WordPress blog export file is 7.96 BM XML file

    php.ini file says max upload file size if 64mb

    In Site Admin > Options, the "blog upload space" is set to 300 MB.

    The "Max upload file size" is set to 9999 kb.

    Error message when I try to upload file is "The uploaded file exceeds the upload_max_filesize directive in php.ini."

    Help.

  12. andrea_r
    Moderator
    Posted 14 years ago #

    Server setting somewhere. Will your host kick it for you and fix it?

  13. billdennis5
    Member
    Posted 14 years ago #

    I'll try contacting them. It's usually a little taste of Hell dealing with these guys. These people are fond of sloughing off such requests to the Knowledge Base and giving one word answers with little explanation.

  14. andrea_r
    Moderator
    Posted 14 years ago #

    They sound like real nice guys.

    I know I had this issue recently and after upping everything I could find to 20 megs, it would come back with an 8 meg limit. No idea where that came from, but I filed a ticket, my host fixed ti.

    my only complaint was they didn't tell me exactly what they did. :-/

  15. billdennis5
    Member
    Posted 14 years ago #

    FYI: I just submitted a trouble ticket laying out the issues I'm having with the import.

    I'll make a follow up call in the morning.

    If this is resolved, I'll be in hog heaven.

  16. gighen
    Member
    Posted 14 years ago #

    i have the same problem, so if you find a solution let me know ;)

  17. tdjcbe
    Member
    Posted 14 years ago #

    gighen, please review the thread that you posted in as a solution is discussed up above. If that doesn't work for you, you need to provide some specifics as to what is occurring so folks can help you.

  18. billdennis5
    Member
    Posted 14 years ago #

    The host directed me to where the phi.ini file is located,l I changed the max file upload to 20MB, I set the max execution time to 300.

    I got to the point where I was asked to map the files to a user and I chose admin. I chose to NOT upload the attached files.

    I kept getting a 500 Internal Server Error message.

    So I reset the max execution time to 3000.

    Same thing.

    I'll let my host know. Any advice?

  19. andrea_r
    Moderator
    Posted 14 years ago #

    I did the same thing recently on mt(gs). had it jacked up to 60MB across the board, still got 500's.

    Check and see if any posts did get imported. Some of mine did. I still had to chunk the 40+meg file in two. even then I still had the occasional timeout.

  20. billdennis5
    Member
    Posted 14 years ago #

    You keep advising me to break up the database file. How do I do that? How do I "break up" such a file without damaging it. Add no, there were no new posts.

  21. andrea_r
    Moderator
    Posted 14 years ago #

    You mean the xml export file?

    Open it up in a text editor. Select half of it and paste it in a new file.

    There's a bunch of stuff at the top and it's fairly readable. you need to make sure the top bit of code is in each section of import. The posts themselves are wrapped in <item> tags.

    At the botton, there's onyl two tags to say it's the end of the file, </channel> and </rss>. You can make sure they are at the end of each new file you're making, although I've left them off and not had much issue.

  22. billdennis5
    Member
    Posted 14 years ago #

    So, the "breaks" should be be where one item ends </item> and where a new item begins ,item>.

    Do I read you right?

  23. andrea_r
    Moderator
    Posted 14 years ago #

    Yep, exactly.

  24. nickd32
    Member
    Posted 13 years ago #

About this Topic

  • Started 15 years ago by billdennis5
  • Latest reply from nickd32