The MU forums have moved to WordPress.org

WP to WPMu (12 posts)

  1. peiqinglong
    Member
    Posted 17 years ago #

    So I just recently moved my main blog from WP 2.1.3 to WPMu 1.2.1 and I did the export/import feature, but only some of my pages imported. I tried doing searches here and on Google to find out if anyone else had similar problems and I only found brief mentions but no concrete solutions.

    Is there a simple automated method to pull in pages or am I forced to recreate all the pages?

    Thanks!

  2. andrea_r
    Moderator
    Posted 17 years ago #

    It could be a side effect from the cod changes they made a while back to how pages were handled. They had an extra flag in the db that was changed. (I discovered this on my personal blog).
    Search the archives of the posts part and see if the missing pages appear as a post. if so find them in the DB and chage the status to "static".

  3. peiqinglong
    Member
    Posted 17 years ago #

    Andrea,

    On my WPMu blog I checked all the posts and they are all correct, no more or no less than the old blog.

    I looked in the database and found some pages that aren't showing up in my WPMu but exist in the DB. When I try to visit the URL of the missing page that exist in the DB, I get a 404 error. So I visit the actual URL (page_id=? vs. page slug) and it works. I edit the page, make no real changes, saves it and viola, the page slug works now. But still a majority of my new pages are not there.

    I looked in the DB and any pages under post_type is page. Where do I find the static at? Thanks!

  4. drmike
    Member
    Posted 17 years ago #

    Are we talking about a large file? How large is it.

    You don't have the sitemap plugin installed, do you? Make sure you turn it off before importing (heh heh) as it creates an update of the file with every imported post.

    Also clearing out your spam ahead of time is recommended.

  5. andrea_r
    Moderator
    Posted 17 years ago #

    "Where do I find the static at?"

    Argh, i wish I could remember. :( I'm on a different computer and it's way more difficult for me to search for it.

  6. peiqinglong
    Member
    Posted 17 years ago #

    Dr. Mike, I do have sitemap filter installed.

    So this is what happened. Apparently for some reason all my pages' permalinks were thrown out of wack. I had to do to every page and edit it and make sure it was pointing to the correct parent. Then everything started working, but all my permalinks are still messed up. None of the posts maintained their categories.

    At the very least it was an interesting learning experience.

    I'm going to create a "dummy" blog and do another export/import with sitemaps off to see what happens.

    Andrea, whenever you can find it will be fine :)

  7. peiqinglong
    Member
    Posted 17 years ago #

    Ok, so this time I turned off all my plugins and did an export and import. This time was more successful. The posts and categories maintained their structure but the pages came out the same way as last time, mixed matched and file under the wrong things.

  8. andrea_r
    Moderator
    Posted 17 years ago #

    Okay, found it (less fuzzy head this morning). In the wp_posts table the post_type for Pages should be static.
    You have to find that particular page in the db and look at the record for it.

  9. drmike
    Member
    Posted 17 years ago #

    That shouldn't be happening though as the db structure should be the same.

  10. andrea_r
    Moderator
    Posted 17 years ago #

    Should be is right. :) Somewhere along 2.1 stuff got changed the way pages were handled in the db, and I'm assuming got rolled into MU.

    I lost a pile of Pages when I upgraded my regular blog. the .org forums kept insisting it was a plugin to the dozens of people asking about it. *eyeroll*

  11. peiqinglong
    Member
    Posted 17 years ago #

    Andrea,

    In my db, post type for pages are listed as pages. Should they be listed as static for MU?

    *Edit* I just looked at another newly created blog on my WPMu and all the pages are listed as page.

    Am I missing something here?

  12. andrea_r
    Moderator
    Posted 17 years ago #

    Dunno, I coudl very well be confusing the issue. :-/

About this Topic

  • Started 17 years ago by peiqinglong
  • Latest reply from andrea_r