The MU forums have moved to WordPress.org

Wordpress MU + Cpanel = Disaster? (15 posts)

  1. stelabouras
    Member
    Posted 17 years ago #

    Hello everyone!
    I had installed Wordpress MU in one of my servers under public_html/blogs directory and I had chosen the subdomains mode. So everytime someone sign-up he had a http://username.myserver.com/blog page for his blog.

    Recently I moved those wordpress mu files + db in another server (keeping the same domain) which has a cpanel administration frontend and I cannot make it work!

    I followed the tutorial here http://www.blogopreneur.com/2006/11/06/installing-wordpress-mu-on-a-cpanelwhm-server/
    but I think that I am doing something wrong cause I have all wordpress mu files under public_html/blogs and not public_html directory

    After doing exactly what tutorial proposes all my subdomains where ping-able but whenever I go to *.myserver.com subdomain, instead of watching the default http://www.myserver.com page I see the "dummy" apache page that says "Congratulations, etc etc"

    Do I miss something in the tutorial that I have to follow? Is there anyone that has similar problem with wordpress mu install not in the base folder but in a subfolder?

    Thanks in advance for your time!

  2. PinkFloydYoshi
    Member
    Posted 17 years ago #

    Have you wildcarded the domain in Apache's httpd.conf?

    I should mention that before you go in there, you should back up your httpd.conf file. Just incase WHM throws a fit, you can go back and copy the backup over again and it'll work.

    Because you're getting Apache's placeholder page when you goto anything.domain.tld, it means that your registrar is wildcarding (anythinghere.domain.tld points to the same server, instead of throwing up a nasty "Cannot find server, means your problem isn't on the registrars end), which is good because this means it's not a DNS fault, and the entry in httpd.conf might be the fix. There's no setting which enables this in WHM as far as I am aware, to you manually need to go into the httpd.conf file, searching for your domain, and where it says "ServerAlias", next to it, it should have your domain name next to it. Add "*.domain.tld" to the end to make it look like this:

    "ServerAlias http://www.domain.tld *.domain.tld"

    ...and "/etc/init.d/apache2 force-reload" to apply the changes. You should then be in business. If not, have you added * as an A record pointing to your servers public IP in Bind and done 'rndc reload' to apply the changes?

    At least, it sounds like an Apache VirtualHost entry thing to me anyway. Wildcarding is enabled at the registrar, so its not that.

    Try out dnsreport's DNS diagnostics tool to rule out any possibility of it being a DNS issue.

    Add your domain onto the end of here:
    http://dnsreport.com/tools/dnsreport.ch?domain=

    Good luck.

  3. stelabouras
    Member
    Posted 17 years ago #

    Thanks for your reply PinkFloydYoshi,

    I have my domain in httpd.conf wildcarded as stated in the tutorial. The virtual host of my domain looks like this (i replaced the name of the domain with "domain" and the real ip with "ip")

    <VirtualHost ip>
    DocumentRoot /home2/domain/public_html
    BytesLog domlogs/domain.gr-bytes_log
    User domain
    Group domain
    ServerAlias domain.gr *.domain.gr
    ServerName http://www.domain.gr
    ServerAdmin webmaster@domain.gr
    CustomLog /usr/local/apache/domlogs/domain.gr combined
    <IfModule mod_php4.c> php_admin_value open_basedir "/home2/domain:/usr/lib/php:/usr/local/lib/php:/tmp" </IfModule>
    <IfModule mod_php5.c> php_admin_value open_basedir "/home2/domain:/usr/lib/php:/usr/local/lib/php:/tmp" </IfModule>
    ScriptAlias /cgi-bin/ /home2/domain/public_html/cgi-bin/
    </VirtualHost>

    Do I need to place http://www.domain.gr instead of domain.gr in ServerAlias line?
    I also state that I have added a "* 14400 A IP" [where IP is the same with the VirtualHost] entry in the WHM control panel...

    I finally tested http://www.domain.gr and .domain.gr in the dnsreport tool and I face fail status only in the NS categoty for .domain.gr and in the "Open DNS Servers" in http://www.domain.gr

  4. stelabouras
    Member
    Posted 17 years ago #

    [and the problem insists...]

  5. drmike
    Member
    Posted 17 years ago #

    Well, one the files need to be in the root directory, not the blog subdirectory but you already know that. I have a feeling that the htaccess within home/###/public_html/ isn't populated with teh correct information. I think a reinstall is best, making sure that the files are in the correct place.

    Don't use the 'www' bit. It'll screw up your cookies as well as the URLs for the blogs as it will put the www in there.

  6. drmike
    Member
    Posted 17 years ago #

    Also do note that folks including myself have reported the reloading issue when mu is installed as an addon domain in CPanel or when there's a missing trailing slash in the URL. MU should be installed within it's own account and you may want to check this thread which may fix that issue.

    Hope thi shelps,
    -drmike

  7. stelabouras
    Member
    Posted 17 years ago #

    Thanks for the answer drmike!

    What do you mean by "one the files need to be in the root directory, not the blog subdirectory"? Should I install Wordpress Mu in root directory and not in the public_html/blog?

    In the home/###/public_html/ the .htaccess has zero bytes so it is 100% sure that it does not have the correct redirects, but what should I put there?

    Sorry for the -probably naive- questions but I am a bit disappointed of the whole "not-working-at-all" situation

  8. drmike
    Member
    Posted 17 years ago #

    Should I install Wordpress Mu in root directory and not in the public_html/blog?

    Yes, that's probably the cause of your issues.

  9. gabrielparriaux
    Member
    Posted 16 years ago #

    Hello guys,

    I'm facing the same problem than stelabouras...

    Wordpress mu was working perfectly with subdomains and... my host upgraded his server with Apache2!

    Now, when I get to one of my blog, I have this lovely Apache2 congratulation page telling me that Apache2 was well installed :-).

    I contacted the support and they tried several things. Wildcard has been activated, so it should not be a DNS problem.

    Now they tell me that it might be because wordpress mu is not installed in the primary domain, but in an addon domain...

    Do you think I have any chance to make it work in an addon domain???

    Thank you for helping!

    Gabriel

  10. lunabyte
    Member
    Posted 16 years ago #

    When they upgraded, their apache configuration file was overwritten, which killed off any customizations they may have made.

    The virtual host for your site needs fix, including server alias directives.

  11. mrmarko
    Member
    Posted 16 years ago #

    Hello all,

    If you are using Apache2 with cPanel, there will be great differences... You can't just edit httpd.conf as sometimes suggested. In Apache2, there are templates, includes, etc that are called upon when httpd.conf tries to load. I personally was having a problem getting "serveralias *.domain.com" to take... or any changes in the <VirtualHost> to take. Please go to http://www.jangro.com/a/2007/11/23/cpanel-easyapache-and-customizing-httpdconf/ and it should help you as it did me.

    Please feel free to relocate this post if necessary. It took me quite some time to find my fix, but I knew that others had to be experiencing the same thing so I kept searching and suggest others to as well.

    Although this is my first post, I have been lurking around the wpmu forums for over half a year and finally decide to register! I have learned so much by reading, searching, reading and searching over and over. Thanks Dr.Mike, Andrea_R, Lunabyte and others who contribute regularly! If anyone has a problem and finds the fix, definitely post it as I'm sure it will help others.

  12. RCB-IT-Solutions
    Member
    Posted 16 years ago #

    Yeah if you don't want it in the public-html direcotry you can do what I did, change the setup so everything is at blogs.yoursite.com/blogname

  13. petti
    Member
    Posted 15 years ago #

    Hi all ,
    I Installed mu wordpress in cpanel/whm server ,
    and changed the dns zone and httpd.conf for wildcard ( from matt and blogopreneur blog )
    but the subdomain redirect to cpanel apache page .
    and do not show the blog ,
    how to fix this issue ?

  14. d_kc
    Member
    Posted 15 years ago #

    petti, clear your computer's DNS cache or switch to OpenDNS servers temporarily.

    I set up my Cpanel server with MU exactly like all guides. It appeared to didnt work. After an hour of tickering ...I flushed my DNS and it worked

  15. lunabyte
    Member
    Posted 15 years ago #

    Don't forget about cpanel overwriting the conf file when you add something...

    http://www.cpanel.net/support/docs/ea/ea3/customdirectives.html

About this Topic

  • Started 17 years ago by stelabouras
  • Latest reply from lunabyte