The MU forums have moved to WordPress.org

installation problem (16 posts)

  1. Bruce00
    Member
    Posted 17 years ago #

    hi I am trying to install wordpress mu I apache2 2.2.4 php5.2
    MySQL50 I have red the read me and fallowed the instructions
    but when I try to install I keep getting this
    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.
    cant fined out why please help.

  2. Bruce00
    Member
    Posted 17 years ago #

    just for info I have three of the standard wordpress installed on my server that is why i am trying to install the word press mu so i can run one core instead of so meny dont no why this one wont install

  3. heyguy
    Member
    Posted 17 years ago #

    Have you taken care of everything in the readme?

  4. Bruce00
    Member
    Posted 17 years ago #

    yes all but
    wildcard record to your DNS reco
    witch I have no clue how to do
    but it is just my name server domain on my server so for
    have no hosted domains names yet so I dont think that is why
    read every thing on at the debugging site ever thing seems right
    this is the install url if you want to try your self
    http://Kingshomeworld.com/website/blogs/index.php
    right but still get same message

    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.

  5. mikeatkc
    Member
    Posted 17 years ago #

    Did you follow the instructions for chmod 777 if you cannot access the site? Additionally, sometimes you have to chown apache:apache for the directories and files in order for apache to have access to it (versus leaving at root).

    The installation document you followed is similar to the below?
    http://codex.wordpress.org/Installing_WordPress#Famous_5-Minute_Install

    Regards,

    -- Mike

  6. Bruce00
    Member
    Posted 17 years ago #

    Hi Mike thank you for lead it will be help full I think it is
    having tree and four and five word press cores in the same
    domain and same htdocs dir. and sub dir. making conflict.
    I am going to be righting a new master hdrive I will then switch to one core for all blogs using wordpressmu this was just a test so I could take it for a test drive be for the re right
    Bruce

  7. heyguy
    Member
    Posted 17 years ago #

    I'm not sure that the Famous 5-Minute Install applies to Mu. Specifically, if you follow steps 3 and 4 and create your wp-config.php file, your installation will fail. The readme.txt does not say to do it, so you should not do it.

    You can find the real instructions here:
    http://trac.mu.wordpress.org/browser/trunk/README.txt

    Chmod'ing your blog directory to 777 is a good idea, just don't forget to chmod it back when you're done. You shouldn't need to chown anything unless you've got an out-of-the-ordinary Apache setup.

  8. Bruce00
    Member
    Posted 17 years ago #

    yes Heyguy I have used that page as well and no the Apache is the standard setup only running name server domain I have some time been using the wordpress stand with more than one core in the same htdocs on the same domine and run into core conflict I will be coming up this week when I start my new build on a fresh formatted hd with no bugs its time for a drive clean then I will try installing mu first with no other
    bogs in the dir. but thanks for info it is good to have these
    forums

  9. Bruce00
    Member
    Posted 17 years ago #

    Well rebuilt the hard drive and tried to install mu and still get the same message I even put the wordpressmu in the /blogs/ url to match the base have followed all the install
    directions to the letter and still get the message
    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.
    so How do I define wpmu on the host that is not in the install directions at all
    Bruce

  10. heyguy
    Member
    Posted 17 years ago #

    Judging by your other post asking how to chmod, I'm going to guess that you didn't do that, and the wp-config.php wasn't generated.

  11. Bruce00
    Member
    Posted 16 years ago #

    am using windows xp chmod wont work so I am told by Apache lounge and I have edited the wp-config.php and added the database name user and
    password and all the rest of the things on the install list
    now I am going to try the windows registry and see if I can get the read and write permissions need to run the install

  12. lunabyte
    Member
    Posted 16 years ago #

    1) and I have edited the wp-config.php and added the database name user and
    password and all the rest of the things on the install list

    Stop, stop, stop.

    NOWHERE does it tell you to rename and create a wp-config file. The install does that on its own. No touchie!

    2) chmod is a *nix explanation, yes.

    There is a windows equivalent, which should be something you already know. If not, I'll go with the recommendation that someone else made, and that MU may not be for you.

    Editing the registry will not solve your problem. That isn't how it's done. If you can't change a simple file permission on windows, you may want to consider WordPress.com instead.

  13. Bruce00
    Member
    Posted 16 years ago #

    in the read me file it dose say to edit the the the config file and I am using the wordpress I want to try the mu so I can rum more than one blog with one word press core and I am new only 6 month of server on my home computer it was wordpress that sent me to wordpressmu to try we all start as newbes or beginners and learn as we go I thank you all for eney help Bruce
    ps with the ntfs file system setting permission is not always simple

  14. lunabyte
    Member
    Posted 16 years ago #

    P.S. Yes, setting file permissions on windows is easy.

    P.S.S. Here's the README file, aka the directions in a nutshell...

    1) Download...
    2) Create a database...
    3) Put files in desired location...
    4) Set file permissions...
    5) RUN INSTALL SCRIPT...

    Nope, doesn't say ANYWHERE to edit the configuration file, aka renaming wp-config-sample.php to wp-config.php, and adding in your db info or anything else.

    It DOES say later on (Under the Apache section) that in order to use subdomains for user blogs, that you will need to modify the APACHE config file, but that's completely different.

  15. alvintck
    Member
    Posted 16 years ago #

    dear all, i also got same problem with install WPMU,
    just get this message "No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance."
    http://blogs.maxcrosoft.com/blogs/

    i had try install in root dir, also same. ><

  16. alvintck
    Member
    Posted 16 years ago #

    i just found a solutions for installing WPMU,
    1) delete wp-config.php if the file in your directory
    2) put wp-config-sample.php into your directory
    3) refresh then can install alr.

About this Topic

  • Started 17 years ago by Bruce00
  • Latest reply from alvintck