The MU forums have moved to WordPress.org

Database Error (9 posts)

  1. dbUNIT16
    Member
    Posted 17 years ago #

    I'm getting this error on my index.php file:

    WordPress database error: [You have an error in your SQL syntax near '.* FROM wp_1_posts WHERE 1=1 AND (post_type = 'post' AND (post_status = 'publi' at line 1]
    SELECT SQL_CALC_FOUND_ROWS wp_1_posts.* FROM wp_1_posts WHERE 1=1 AND (post_type = 'post' AND (post_status = 'publish')) ORDER BY post_date DESC LIMIT 0, 10

    WordPress database error: [You have an error in your SQL syntax near '()' at line 1]
    SELECT FOUND_ROWS()

    Help is appreciated!

    Thanks,

    Jon

  2. mikeatkc
    Member
    Posted 17 years ago #

    The error could indicates a database corruption. Either restore the wp_1_posts database from backup or use "myisamchk -r" on the database (for more help go to http://www.mysql.com or search/google for the error message).

    After the restore, reload the table or simply restart mysqld (/etc/init.d/mysqld stop (wait a couple of seconds) then /etc/init.d/mysqld start).

    You could restart mysqld and see if this will automatically correct your situation before doing anything else.

    Regards,

    -- Mike

  3. dbUNIT16
    Member
    Posted 16 years ago #

    I'm sorry, I'm very new to this, exactly what steps do I need to take to solve this problem? Thanks!

  4. dbUNIT16
    Member
    Posted 16 years ago #

    Is it because my server needs SQL 4.0 or higher?

  5. heyguy
    Member
    Posted 16 years ago #

    I can't imagine anybody would NOT be using 4.0 or higher. What are you using?

  6. dbUNIT16
    Member
    Posted 16 years ago #

    3.23, is this the problem?

  7. dbUNIT16
    Member
    Posted 16 years ago #

    I've emailed them asking to upgrade, so we'll see if that solves the problem.

  8. lunabyte
    Member
    Posted 16 years ago #

    Heh... I keep a machine with php 4.3 and mysql 3.23 around for app testing.

    Kinda nice to know if your app will run on it or not.

    Granted, coding it I already know, but still.

  9. drmike
    Member
    Posted 16 years ago #

    You need to have mysql 4.0 or above for mu to work.

    Sorry. First I've seen of this thread.

About this Topic