The MU forums have moved to WordPress.org

Invite email troubleshooting help needed. (4 posts)

  1. Frequent
    Member
    Posted 17 years ago #

    I have invites working now but the invite address in the email is incorrect. This is probably due to the fact that I have WPMU installed in a directory (/blogs/)instead of the root. The invite address in the email appears as follows:

    http://www.example.com/invite/khasdfi8wf8438foa

    http://www.example.com/blogs/invite/khasdfi8wf8438foa

    I've done some digging but I can't seem to find where this address can be corrected in the invite email.

    Any help would be appreciated.

    Freq---

  2. Frequent
    Member
    Posted 17 years ago #

    OK, visitor_pass is what pulls the invitation address into the invite email. Can anyone tell me where this is generated and how I can correct it so that it passes the subdirectory as I described above?

    I assume I may need to change the base or basedomain somewhere. I am currently looking for the proper place to change it where it won't mess anything else up.

    One note, before I got invites working I had no problems with setting up a new blog. The welcome email with their password did include the correct address to the new blog including the /blogs/ subdirectory as noted in my first post.

    Is anyone else running WMPU in a subdirectory instead of at the root?

    Thanks,

    Freq---

  3. Frequent
    Member
    Posted 17 years ago #

    I just realized that my first post was not very clear. The invite email provides the invite url as below:

    http://www.example.com/invite/khasdfi8wf8438foa

    But it needs to be this for it to work:

    http://www.example.com/blogs/invite/khasdfi8wf8438foa

    Donncha, could you or one of the other WPMU wizards give me clue as to where I need to look to fix this?

    I would really like to get thinks working at dakotablogs.com so I can start sending out some invites.

    Thanks,

    Freq---

  4. kalam
    Inactive
    Posted 16 years ago #

    Same problem too
    I have found where to change it, in the invite.php file,
    $msg = str_replace( "REGURL", get_option( "siteurl" ) . "/invite/".md5( $email ), $msg );

    This should be the line, but after changing it, it doesn't work !!
    I wonder why !!

About this Topic