The MU forums have moved to WordPress.org

WordPress Hijacking Other Files (9 posts)

  1. lwatkins
    Member
    Posted 15 years ago #

    I have another password protected folder on my website. I am positive the URL is correct, but when I try to access it I get a 404 error generated by WordPress. I think that it probably has something to do with the password system. I set the password up for it using an htaccess file, but it appears to be trying to generate a password through the wordpress files, but it never asks for me to enter one.

    Any ideas on how to remedy this?

    Leisa

  2. drmike
    Member
    Posted 15 years ago #

    Well wordpress is over at http://wordpress.org These are the forums for wordpress multiuser. There is a difference as we put a fair amount more into the htaccess file.

    Are you sure you're in the right place?

  3. lwatkins
    Member
    Posted 15 years ago #

    Sorry, This is a wordpress MU install.

    Leisa

  4. quenting
    Member
    Posted 15 years ago #

    if you get the 404, it's likely the url got rewritten by MU. add a line in your htaccess to disable mod_rewrite.

  5. lwatkins
    Member
    Posted 15 years ago #

    Thanks quenting

    That is what I thought at first, but the URL is correct. I think that it is trying to run the password for that folder through the MU password system, seeing that the blog doesn't exist and then giving me the error message.

    It is a password protected directory that has nothing to do with wordpress.

    Leisa

  6. quenting
    Member
    Posted 15 years ago #

    it wouldn't go through MU if the URL wasn't rewritten. Did you try disabling mod_rewrite in that folder ?

  7. kingler
    Member
    Posted 15 years ago #

    check the access log in your apache server log if you can. Since it is a 404, there might be some useful info in the log.

    How are your folders structured? WPMU in the HTTP document root? And the protected folder as a subfolder in WPMU?

  8. peacearena
    Member
    Posted 15 years ago #

    Gee, I'd love to know how this got resolved.

    I have WPMU in root with subdomains structure. I have (or want) a password-protected directory at public_html/personal/private

    I set the protection for "private" in Cpanel.

    I tried adding "rewriteengine off" to the .htaccess file (tried it in both "personal" and "private" actually since I wasn't sure).

    But I still get 404 page. Nothing in the logs.

    Any ideas?

  9. peacearena
    Member
    Posted 15 years ago #

    I also tried this method:

    http://www.javascriptkit.com/howto/htaccess3.shtml

    But same result.

About this Topic

  • Started 15 years ago by lwatkins
  • Latest reply from peacearena