The MU forums have moved to WordPress.org

Can't login (10 posts)

  1. ivanhallberg
    Member
    Posted 15 years ago #

    Everything seems to be working fine, I can set up new blogs and there are no error messages but I can't login even though I get the password to the mail.

    By the way I'm using dreamhost if that says anything to any one.

  2. Novocain
    Member
    Posted 15 years ago #

    are you trying to login from the maindomain? or from a blogg that u created? are u trying to login to a sub blogg or the maindomain? example: if you are trying to login to domain.com, you would use the adress domain.com/wp-login.php altough if you are trying to logon to a blog that you created, you would use, the-name-of-the-blog.domain.com/wp-login.php in simple words you cant login to a sub-blog from the maindomain you have to use the full adress. (now im not sure that this is even your problem), altough figuerd it might be a chanse that it is.

  3. ivanhallberg
    Member
    Posted 15 years ago #

    That's not the problem and the blogs are set up with sub directories not sub domains.

    The problem is that there is no output at all not even

    ERROR: Invalid username.

    or something like that.

  4. ronanlumb
    Member
    Posted 15 years ago #

    I still whit trouble too.

    Everytings work. But don't login

    look
    blogs.nfsbrasil.com

    You can create one account but can't login there.

    What i have to do now?

    Make the test.

  5. drmike
    Member
    Posted 15 years ago #

    ronanlumb: Worked fine for me. Was able to login and everything.

  6. ronanlumb
    Member
    Posted 15 years ago #

    I "FIX" the problem.

    Dont's is a problem is one errof of configuration.
    The blogs is hosted in dreamhost, and when i create the domain i joice the option, add www ever.

    So when loged the wordpress redict form http://www.domain.com and not to domain.com, so don't loged.

    I resolve in painel, o joice the option don't add www in domain, whit this here redirect ok and don't apear problem whit session.

    Sory, mi english.
    Thanks.

    Just one casual question.
    What's version of Wordpress?

  7. ivanhallberg
    Member
    Posted 15 years ago #

    Thank you so much ronanlumb now everything seems to work.

  8. ColourDreamer
    Member
    Posted 15 years ago #

    I am on Dreamhost too and am having this problem.

    The problem is also that we must have set in our control panels to set domain.com redirect to http://www.domain.com

    and WordPress MU tells us not to include the http://www., so if we get stupey and follow that, it won't work to log in.

    It's kind of dumb on WP's end to make us think we can't use www. Some domains if you type it in without the www, you won't even get the site, just a blank page (Never will understand that, it's bad for potential visitors and harder on linkers.)

    So the solutions are either (sorry, didn't understand the broken English, here's my version of the only solutions I see for Dreamhost) to uninstall then reinstall WP, PAIN don't do that! Or BETTER DO THIS: Set to allow either www or non or switch to just non www, like just domain.com, then log in, fix the setting in options (I assume) and then switch the setting in Dreamhost's CP the way we want it again.

  9. ColourDreamer
    Member
    Posted 15 years ago #

    By the way, having both work is bad for SEO, especially Google, or at least, I don't know about other search engines.

  10. drmiketemp
    Member
    Posted 15 years ago #

    Some domains if you type it in without the www, you won't even get the site, just a blank page (Never will understand that, it's bad for potential visitors and harder on linkers.)

    That's because the 'A' record of the domain is incorrectly setup in that case. It's probably setup as http://www.mydomain.tld where the RFCs state that an 'A' record must be setup as mydomain.tld.

    It would also cause an issue with the subdomain setup of WPMu as the 'www' needs to be replaced by the username.

    I'm afraid the issue is on your end. The 'www' is not required and forcing the 'www' is incorrect.

    May want to open up a support ticket with Dreamhost and inquire about the forced 'www'. We've had many folks here and over in the regular wordpress forums and the issue has not come up in the past. Sounds more like you have something incorrectly set.

    And, for reference, Google makes no different between having the 'www' and not having it. The only time it's an issue is when it's used incorrectly (ie http://www.machinename.mydomain.tld)

    Good luck,
    -drmike

About this Topic

  • Started 15 years ago by ivanhallberg
  • Latest reply from drmiketemp