The MU forums have moved to WordPress.org

default comments.php used, not theme's (7 posts)

  1. wyardley
    Member
    Posted 15 years ago #

    We have a new WPMU install (1.2.1), and have installed a new theme for one of the blogs. The theme is roughly based on the theme "Greeny", from http://sp.webarea.ro.

    In any event, it seems as if the comments.php from the default theme is being used, rather than the comments.php in the theme we've set for the blog. I tried adding a comment (<!-- This is default -->) in the comments.php in the default theme, and it shows up when I load a page.

    Is this normal? Is there something I can do to "fix" this? Is it likely due to the theme not being compatible with WPMU?

  2. drmike
    Member
    Posted 15 years ago #

    Is the theme's comments.php file reading by the webserver?

  3. dsilverman
    Member
    Posted 15 years ago #

    try setting the comments.php file permissions to 644 (rw-r--r--).

  4. wyardley
    Member
    Posted 15 years ago #

    All of the files in the theme are world readable, and all the other theme files are being read just fine; they're currently 664 not 644 (though I tried setting to 644 just now just to make extra sure that wasn't the problem).

    Any other ideas?

  5. andrea_r
    Moderator
    Posted 15 years ago #

    DId you compare the content of that theme's comments.php with the default theme to make sure they aren't actually the same?

  6. wyardley
    Member
    Posted 15 years ago #

    That's irrelevant (though I did compare them and they're different) - because when I EDIT the default theme's comments.php, the changes show up, and when I edit the one in the theme they don't.

  7. CoreyCampbell
    Member
    Posted 15 years ago #

    Have you tried clearing your browser cache?

About this Topic

  • Started 15 years ago by wyardley
  • Latest reply from CoreyCampbell