The MU forums have moved to WordPress.org

scheduled posts not published (24 posts)

  1. Bike
    Member
    Posted 16 years ago #

    My apologies if this is more Wordpress, but I thought it might be WPMU specific. I have scheduled some posts by editing the timestamp and publishing them. So all these posts are marked as 'published' under Status with a future timestamp. The 'publish' button still remains there when going back in admin to check or edit the future post.

    However, once the publish date passes, the posts do not appear on the site.
    It is not a servertime issue, as when I press 'publish' again (I think that button should have disappeared?) it gets published immediately (and the 'publish' button is gone).

    Of course this defeats the purpose of scheduled posting :)

    Has anyone seen this before, is it a WPMU or server issue, and how can it be fixed?
    Thanks

  2. andrea_r
    Moderator
    Posted 16 years ago #

    All I can say is I know future posting has been working on my site.

  3. Bike
    Member
    Posted 16 years ago #

    Thanks Andrea. I cannot find it, but it simply does not happen. I just tested on another blog and watched the dashboard: scheduled posts are under 'scheduled posts' and slowly count down to the minute they should be published.

    But just when it is down to one minute, it starts counting up again?!? If I go to the post and press Save or Publish, it appears, but just scheduling does not work.

    Has anybody seen this before of have a clue how to fix it?
    I have MU 1.2.3, PHP5

  4. quenting
    Member
    Posted 16 years ago #

    I've had reports from users of only some of the scheduled posts being published and the others not, but that was on my old nightly, since i migrated to 1.1.1 I haven't seen this happend again.

  5. rwgraeber
    Member
    Posted 16 years ago #

    I'm using WordPress mu 1.2.1 and we are having the same problem, Bike. Before switching to MU a few months ago, our users took advantage of scheduling future posts quite a bit, but now we have never been successful with it.

    In the database, the post record has "future" as the post_status value and will remain as "future" after the post date passes. It only changes to "publish" if you go to the post and click the Publish button.

  6. Bike
    Member
    Posted 16 years ago #

    rwgraeber, are you on PHP5 as well by any chance? I am wondering if that is causing it as there seems to be a strong resistance to bring the general WP code up to date with it.

  7. lunabyte
    Member
    Posted 16 years ago #

    Well the resistance isn't because of what they would "like" to support, I'm sure.

    Unfortunately, most hosts aren't on PHP 5, and with all the hosts people are using for WP, moving to where it is required wouldn't be good.

    Heck, look at a default install of RHEL. Apache 2.0.52, PHP 4.3.9, MySQL 4.1.20 are all the default installed packages. Granted, you can upgrade, but what does that say about their level of confidence in anything more current for a default install? They're patched current, by the way.

    So, the problem doesn't necessarily lie with what a developer wants to support, it comes down to what an average host supports. And that doesn't include the "good" ones out there alone. It encompasses all hosts out there. A lot of which do a default install, as that's what comes with the server they rented, and that's the end of it.

    Which, is sad, but they're out there. And a dime a dozen at that.

  8. rwgraeber
    Member
    Posted 16 years ago #

    Bike -

    Yes, we are at PHP version 5.2.1.

  9. ThinIce
    Member
    Posted 16 years ago #

    hrm this interests me on a couple of counts. Firstly my wp and wpmu installs are running on php5 - I'll have to have a test of future posting tomorrow and report back (we're on 1.2.3 incidentally).

    Secondly isn't php4 now coming up for EOL?
    http://derickrethans.nl/php_quebec_conference_rip_php_4.php - not wanting to mess up this thread with a big discussion on it of course :p

  10. rwgraeber
    Member
    Posted 16 years ago #

    After I've done some reading on the whole PHP4 vs. PHP5 issue, I tend to think the smart thing is to drop down to PHP4. Since we control our servers and MU installation, it really isn't a major issue to do.

    Expecting the WordPress code to be rewritten in PHP5 is unrealistic, at least in the short term.

    If this future post problem is due to my using PHP5, then that is definitely the thing to do.

  11. SteveAtty
    Member
    Posted 16 years ago #

    I'm running PHP 5.2.1 but I can switch back to php 4.x easily (changing one line in my apache worker config file) so I'll see if its a specific 5.2.1 error or something else.

  12. Bike
    Member
    Posted 16 years ago #

    Well, let's first try to find out whether PHP5 is likely the cause before we get into Mac-vs-Windows type of discussions.

    Frankly I would not care what version, except for MediaWiki requiring PHP5, that's why I have it on my VPS.

    ThinIce, did it work? Any others on PHP5?

  13. ThinIce
    Member
    Posted 16 years ago #

    I can confirm that scheduled publishing has worked on my installation of 1.2.3 on PHP Version 5.2.3 - this was originally an install of the previous release (of MU) that has been upgraded.

    This is an install with a few plugins installed, but none of the core files have been modified.

  14. rwgraeber
    Member
    Posted 16 years ago #

    I have just confirmed that this looks to be a problem between PHP 5.2.1 and PHP 5.2.3.

    I have a test setup for the same site. Everything is the same. The only difference is that the test setup has been recently upgraded to PHP 5.2.3.

    Scheduled posting works correctly on the test site.

  15. lunabyte
    Member
    Posted 16 years ago #

    Sounds like it should be added to trac then.

    If it happens on your regular WP install(s) in the same manner, then I'd add it into the main WP trac instead. It sounds like that will probably be the end result, as I don't think (at least remember off the top of my head) if that's an area that has any special edits for MU.

  16. rwgraeber
    Member
    Posted 16 years ago #

    Thanks, lunabyte. I'm trying to figure out if there is anything else that could be causing this, but I'm pretty sure the scheduled post didn't work on the test site prior to the upgrade to PHP 5.2.3.

    Another thing that I hope upgrading our production server will solve is some goofy PHP errors that show up in the Windows event logs on our current install. 10 - 20 times per day, an application error is logged. The error points to php5ts.dll in each instance. If I let too many of those errors build up without rebooting the server, MU will stop responding to requests and returns a database connection error.

    I'll report back if the upgrade solves that problem as well.

  17. Bike
    Member
    Posted 16 years ago #

    Well, it does not work for me, I am on PHP5.2.3 as well, with My SQL 4.1.22-standard. Fresh 1.2.3 install..

    Is there any setting in PHP.ini that might influence the scheduled behaviour?

  18. rwgraeber
    Member
    Posted 16 years ago #

    I've compared the php.ini files between the two servers (one running PHP 5.2.1 and the other running PHP 5.2.3). Both servers are running mySQL version 5.0.27. The php.ini files are identical. The server running PHP 5.2.1 does not allow scheduling a post, while the one running 5.2.3 does.

    I am going to be upgrading the 5.2.1 server to 5.2.3 over the weekend and will have more to report afterwards.

  19. Bike
    Member
    Posted 16 years ago #

    Hey rwgraeber, did you upgrade? What's the verdict?

  20. rwgraeber
    Member
    Posted 16 years ago #

    I did not upgrade PHP on the production server over the weekend.

    However, I did move all of the WordPress MU related files (except for wp-config.php, /wp-content/blogs.dir/, wp-content/cache/ and wp-content/uploads/) from the dev server to the production server. We had done a layout change and were moving those changes live.

    And, now, scheduled posts work on the production server. I am going through the files to see what has changed to see if I can determine what the culprit was.

    So, it is not a PHP 5.2.1 vs. 5.2.3 issue.

  21. webmaestro
    Member
    Posted 16 years ago #

    Any results from your search through the files?

    I posted my problem on another thread, but this sounds very similar. I'm running:

    SunOS flog1 5.10 Generic_127112-07 i86pc
    PHP Version 5.2.5
    MySQL Version 5.0.51a
  22. danielpereira
    Member
    Posted 15 years ago #

    Well, everyone's talk in this feed is slightly over my head, but I too had problems with scheduled postings for my wordpress blog and it just so happens that after 2 days of stress and 5 hours of research, I found the simple solution to my problem. I hope that this helps some of you that are also reading this feed.

    http://www.thefreetrafficformula.com/blog/?p=211

    Please comment and let me know if by chance you have been making the same mistake that I made.

    Daniel Pereira

  23. andrea_r
    Moderator
    Posted 15 years ago #

    If you're using the single-blog version of Wordpress you're in the wrong forum.

  24. TheVirtualPreacher
    Member
    Posted 15 years ago #

    Hi,

    I had the same problem, and this is how I solved it.

    http://howtogeeksl.com/archives/326

    Please be kind enough to leave a comment if you find this useful.

About this Topic

  • Started 16 years ago by Bike
  • Latest reply from TheVirtualPreacher