The MU forums have moved to WordPress.org

Are you using PHP4 or PHP5? (11 posts)

  1. selad
    Member
    Posted 15 years ago #

    Hello,

    I'm working on a plugin that I will share soon and I like to know how many are using php5?

    Let have a quick poll :)

  2. lunabyte
    Member
    Posted 15 years ago #

    5.2.3

    For the record though, for greatest compatibility I'd target PHP4.

  3. ekusteve
    Member
    Posted 15 years ago #

    4.3.11

    Steve

  4. lunabyte
    Member
    Posted 15 years ago #

    Ouch, Steve...

    Hope its patched. ;)

  5. SteveAtty
    Member
    Posted 15 years ago #

    5.2.1

    But am planning to upgrade it - bit of pain as I have to compile from source

  6. lunabyte
    Member
    Posted 15 years ago #

    I've had to do that 4 times since Thursday, narrowing down a bad extension/module. :(

  7. SteveAtty
    Member
    Posted 15 years ago #

    I kept finding I'd missed things. I've also spent quite a bit of time removing stuff from it that I don't think I need (or rather nothing I'm running needs it).

    Don't forget to strip it afterwards ;)

  8. ekusteve
    Member
    Posted 15 years ago #

    "Ouch, Steve..."

    Yea, I know. I need to upgrade, but just haven't found the right time yet. I'm not a server admin guru, so I always have to give myself about a month to fix all the problems I cause myself when I do a major upgrade of server software :-).

    Steve

  9. SteveAtty
    Member
    Posted 15 years ago #

    Anyone checked php.net?

    PHP 4 end of life announcement
    [13-Jul-2007]

    Today it is exactly three years ago since PHP 5 has been released. In those three years it has seen many improvements over PHP 4. PHP 5 is fast, stable & production-ready and as PHP 6 is on the way, PHP 4 will be discontinued.

    The PHP development team hereby announces that support for PHP 4 will continue until the end of this year only. After 2007-12-31 there will be no more releases of PHP 4.4. We will continue to make critical security fixes available on a case-by-case basis until 2008-08-08. Please use the rest of this year to make your application suitable to run on PHP 5.

  10. lunabyte
    Member
    Posted 15 years ago #

    Heh... someone better be calling all the idiot hosts out there. LOL

  11. selad
    Member
    Posted 15 years ago #

    Information about moving to php5 is here:
    gophp5.org

About this Topic