The MU forums have moved to WordPress.org

Widget error on update. (19 posts)

  1. Novocain
    Member
    Posted 16 years ago #

    With the latest update (from site admin) i cant change my widgets any more, i can move them around and replace them as usual, but i cant click the box to edit them anymore, anyone know what this is from? and offcource how to solve this?

    Best regards Fredrik

  2. lunabyte
    Member
    Posted 16 years ago #

    clear cache, clear cookies, try again.

  3. Novocain
    Member
    Posted 16 years ago #

    hi Luna, sorry to say that i dont even save thoose. Using firefox and has it set to always clear on closedown, also i have tried in IE, same thing. it seems as the "buttons" arent linkeable anymore, the marker changes on mouseover, but cant be clicked.

    also replaced all the widgets from a fresh widget install.

    dont know what to do, have been trying to inspectthe code, but cant se anything unusual, as far as iknow, this happend on the update from 1.2.2 - > 1.2.3

    Best regards - Fredrik

  4. lunabyte
    Member
    Posted 16 years ago #

    Strange, unless there is some conflicting JS somewhere, that didn't get overwritten, or maybe you also have the "old" widgets plugin still in mu-plugins?

  5. Novocain
    Member
    Posted 16 years ago #

    No still not better, i have first of all confirmed that it isnt my computer by asking a user to try the same thing, he comfirmes that he can move the boxes around and add them to the list, altough he cant hit the "configure" buttons (same as me)

    i have also made sure that there is no parts left from the old folder, and also no widget related php files, not in plugins, nor in mu-plugins. i also downloaded a new copy from "Automatiq" to see if it helped, but it didnt.

    any ideas?

    as i tried it again now i noticed this line:

    Plugin could not be activated because it triggered a fatal error.

    that was definetly not there before the update.

    best regards, Fredrik

  6. lunabyte
    Member
    Posted 16 years ago #

    "downloaded a new copy from "Automatiq" to see if it helped, but it didnt."

    Widgets are now built into WP, so the use of that plugin is no longer required.

  7. lunabyte
    Member
    Posted 16 years ago #

    Just confirmed it on a clean 1.2.3.... Works just fine.

  8. drmiketemp
    Member
    Posted 16 years ago #

    Make sure you delete the widget.php file out of the mu-plugins subdirectory as it will conflict if you don't.

  9. Novocain
    Member
    Posted 16 years ago #

    yes u mean the file that calls the catalog? all files conserning the previous widget install is gone, since i reinstalled all plugins, still no solution im affraid.

  10. Novocain
    Member
    Posted 16 years ago #

    I have now reinstalled the entire plugins folder and the mu-plugins folder, so now it contains nothing but the original plugins that comes with mu 1.2.3.

    the problem is still there. can my installation of automattics have damaged any core files?

  11. Novocain
    Member
    Posted 16 years ago #

    Should i clear my root with ftp access and reinstall?

  12. lunabyte
    Member
    Posted 16 years ago #

    It is possible that you missed a file or something with the update.

    Just don't wipe out your config or htaccess file. ;)

  13. Novocain
    Member
    Posted 16 years ago #

    hehe yeah... did that last time, by mistake i saved the setings file instead of the config =)

    in a short summary, im going to save the entire Wp-content folder, .htaccess, wp-onfig.php. NOW, should this be all i nead to save for my users to not loose anything at all from there blogs?

    best regards, and thx so much as always for keeping this place alive. - Fredrik

  14. Novocain
    Member
    Posted 16 years ago #

    Holy crap, did not see this one comming:

    reinstalled all files from a fresh 1.2.3 install and added my backup copies off wp-content, wp-settings wp-config and wpmu-setitngs, and last the .htaccess file. the widget error is still there, and further more all boxes that where choosen before, are still added in the sidebar! please someone help me.

    Best regards.

  15. mysorehead
    Member
    Posted 16 years ago #

    I probably shouldn't be posting as I'm not 100% sure and I haven't upgraded yet but...

    You don't need widget.php in your mu-plugins folder anymore do you. Your not copying widgets back along with your other wp-content stuff.

    If you get errors after an upgrade the first thing I'd do is check my plugins by removing them and see if they go away. Oh, I;d check my core edits as well (just thought I'd throw that in as well)

    Richard

  16. Novocain
    Member
    Posted 16 years ago #

    That was indeed a good tought, but im using the original mu-plugin and the plugin folder from the install, in other words i havenĀ“t installed any extra plugins yet.

  17. Novocain
    Member
    Posted 16 years ago #

    where the settings for "widget" saved in any of the files i mentioned abobe?

  18. Novocain
    Member
    Posted 16 years ago #

    Found it to be the wpmu-settings file, or the wp-settings file that keept that info, everything is running smoothly now.

    thx for everyones help.

  19. greatbig47
    Member
    Posted 16 years ago #

    Wait... I've got the same problem, and I can't find a solution. When I go to activate a plugin, I STILL get the

    " Plugin could not be activated because it triggered a fatal error."

    The last MU release had no plugins, so thats not it...I've taken them out and put them back in, but nothing. I also updated wp-setting and wpmu-settings, and nothing?

    Someone help?

    Thanks!

About this Topic

  • Started 16 years ago by Novocain
  • Latest reply from greatbig47