The MU forums have moved to WordPress.org

localization of wpmu (7 posts)

  1. papricek1
    Member
    Posted 16 years ago #

    Hi, I am trying to create a czech localization file for wpmu, especially the wp-signup.php file.

    What I did:
    1) I take poEdit, create new catalog, set the directory to my directory with wpmu, set keywords to _ and _E. poEdit generates a lot of string, about 1700. I try to translate some of them using poedit. I save it.

    2) I open the po file in a text editor, choose only the strings that I want to translate. I add these strings as a text into an already working translation file for regular wordpress. I save it.

    3)I open the new file with both my new translations and a translation for regular wordpres with poEdit, and save it. My mo file gets actualized. I upload it to the web. And nothing happens. My new localized wp-signup strings do not appear, the text is still in english.

    Where is the problem?

    I use WP MU 1.2.1 with k2 v.096 theme with regular wordpress and k2 czech file.

    Thanks

  2. drmiketemp
    Member
    Posted 16 years ago #

    I don't see that you mention that you did the lines in teh wp-config.php file. (Sounds like you did everything else right though.) May want to double check the rest of the process to see if you missed a step:

    http://codex.wordpress.org/Installing_WordPress_in_Your_Language

    I do hope you will consider uploading the language file to http://wpmudevorg.wordpress.com as there are others there as well. Heck, you may even want to download the previously done ones.

  3. papricek1
    Member
    Posted 16 years ago #

    I have no idea what is wrong - I take wpmu.pot, open it in poEdit, translate some strings, save as cs_CZ.po (it creates cs_CZ.po and cs_CZ.mo) and upload it into wp-includes/languages - but still not working. doesn't someone know what am I doing wrong?

  4. drmike
    Member
    Posted 16 years ago #

    Um, first sentence of my response to you? The lines you have to add into the wp-config.php file?

    Evereyone else does see them, right? Just wondering if Matt's mucking with me again.

  5. papricek1
    Member
    Posted 16 years ago #

    its ok, the lines are in the right place - if I upload a translation file for regular wordpress, everything works fine. The problem must be somewhere in the mo file

  6. papricek1
    Member
    Posted 16 years ago #

    its ok, the lines are in the right place - if I upload a translation file for regular wordpress, everything works fine. The problem must be somewhere in the mo file

  7. papricek1
    Member
    Posted 16 years ago #

    ok, is there someone who could advice me instructions, how to add strings from wpmu to an already working translation file for wp? Because, when I use poEdit and simply add the strings to the po file, the mo file works just for the regular wordpress strings, the new strings do not work, and I dont know what is wrong...

    Thanks

About this Topic

  • Started 16 years ago by papricek1
  • Latest reply from papricek1