The MU forums have moved to WordPress.org

500 Internal Server Error (14 posts)

  1. ericodom
    Member
    Posted 15 years ago #

    All seemed to be going well until I ran into a page in install that told me I had to delete an htaccess file that cpanel had created. I did that and then edited the file that came with WPMU files as per the instructions. I then uploaded the new file and went on to move through the install guide.

    Once I hit submit I was met with a 500 Internal Server Error.
    http://blogaught.com/index.php

    I'm hosted with asmallorange should the question come up...

    Any ideas?

  2. drmiketemp
    Member
    Posted 15 years ago #

    As per the error:

    More information about this error may be available in the server error log.

    What files are you editing by the way? I do hope you mean the apache and bind config files.

    I believe cpanel doesn't like not having a .htaccess file. Put one back into the root of your install and please try again. Just make sure the file is empty.

  3. ericodom
    Member
    Posted 15 years ago #

    "I believe cpanel doesn't like not having a .htaccess file. Put one back into the root of your install and please try again. Just make sure the file is empty."

    The WPMU files included one called htaccess.dist. When installing, the guide told me that these two could not co-exist, prompting me to delete the one that was already there. So I deleted it. But then, it told me I didn't have one and needed to edit htaccess.dist and rename it. I did, published it, and hit submit. That is where the error came in.

  4. ericodom
    Member
    Posted 15 years ago #

    "More information about this error may be available in the server error log."

    *may* being the keyword. There is no info available.

  5. ericodom
    Member
    Posted 15 years ago #

    OK, here is what I'm now getting in the error logs...

    "[Fri Aug 10 16:10:32 2007] [alert] [client 75.141.200.148] /home/ericodom/public_html/.htaccess: Invalid command 'RewriteHOST', perhaps mis-spelled or defined by a module not included in the server configuration"

    As per the instructions, I changed "BASE" to "HOST" in the file. This is where the error started happening.

    I just tried changing it back to "BASE" and now get this.
    [Fri Aug 10 16:15:43 2007] [alert] [client 75.141.200.148] /home/ericodom/public_html/.htaccess: RewriteBase: argument is not a valid URL

  6. drmiketemp
    Member
    Posted 15 years ago #

    What are you using to edit the htaccess file and how specifically are you saving it? I'm wondering if you're getting formatting in there and that's what's causing the error. If you haven't done so, please make sure you're using Notepad or another text editor and saving it into UTF format. That and uploading via ascii format.

  7. drmiketemp
    Member
    Posted 15 years ago #

    Change BASE to be a slash mark -> /

    So it looks like this:

    RewriteBase /

  8. ericodom
    Member
    Posted 15 years ago #

    Right now it looks like this:
    RewriteEngine On
    RewriteBASE BASE/

    #uploaded files
    RewriteRule

    I need to change it to this?
    RewriteEngine On
    RewriteBASE/

    #uploaded files
    RewriteRule

  9. drmiketemp
    Member
    Posted 15 years ago #

    If your install is within root, the first two lines of the .htaccess file should look like this:

    RewriteEngine On
    RewriteBASE /

    Do note I asked you a question up there about how you edited the file.

    Also what specific instructions do you keep mentioning? A lot of what you;ve done is not in the readme text file included within the download.

    To be honest, I would do what I suggested up above. Create an empty .htaccess file, set it to be writeable by the webserver (ie 777) and try installing wpmu again.

  10. ericodom
    Member
    Posted 15 years ago #

    drmike, first of all... thanks for helping out on this. I know it's time consuming and I appreciate your assistance.

    OK, now, I edited the file in NP, which was probably a mistake to begin with, but life goes on.

    The instructions I keep mentioning are the instructions given -during- installation.

    I've removed all files and started from scratch.
    http://blogaught.com/index.php

    Notice the error at the bottom? I DID create a new .htaccess file that is blank. It is the ONLY one there and it is writeable.

    This is what I can't figure out. Why is the install telling me there is mutliple instances of this file when there isn't? Or, is it trying to create one?

    I've tried both ways. I tried the install with -no- .htaccess file as well as one -with- the file. Both attempts have failed.

    *scratching head*

  11. ericodom
    Member
    Posted 15 years ago #

    We got it. It was a combination of deleting, adding, deleting, adding, deleting, and then again adding the .htaccess file that finally got the install to take.

    What a circus that was. Anyway... thanks!

  12. sphereboy
    Member
    Posted 15 years ago #

    so i ran into the same problem.
    what i did was use an .htaccess file i had from a previous back up of my ftp server. I just recently upgraded to WP 2.2 so i had replaced/deleted the original .htaccess file.

    I was using the following, and it wasn't working:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    So the backup was this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    The latter worked.
    So what do you say the difference was?

    Not much. it had commented lines, and an extra empty space before the data and extra break before the last commented line and extra spaces after.

    Call me crazy, but it's working now.

  13. ladynada
    Member
    Posted 15 years ago #

    I have lost my mind trying to fix my mu in subdirectories to do a page 2 correctly off the homepage on site news.

    I figured out how to get extra pages on the homepage with this:

    query_posts("what_to_show=posts&posts_per_page=3&paged=$paged");
    if (have_posts()) : ?><?php while (have_posts()) : the_post(); ?>

    and it works on my local WAMPX

    but on the live board I get

    http://motheronearth.com/members/page/2/

    and what I want is

    http://motheronearth.com/members/index.php?paged=2

    the paging on member blogs seems to be fine

    nothing I put in htaccess works

    anyone have any ideas what goes in htaccess when your mu is using subdirectories?

    thanks for any help,
    if you need more info please ask.. I'm not sure, kinda new to mu

    nada

  14. JupitersCollision
    Member
    Posted 15 years ago #

    Some of you might have run into the same problem I did. I was getting an awful error message on my sites.

    "500 Internal Server Error"

    I searched all over the forums only to find minimum help. I even e-mailed tech support to my host provider and they told me to use more of their products because it was a problem with my wordpress installation.I went in and deactivated all the plug-ins that I had activated. Finally coming to one that was the problem.

    "WP-Cache 2.1.2 Plug-in - Very fast cache module. It’s composed of several modules, this plug-in can configure and manage the whole system. Once enabled, go to “Options” and select “WP-Cache”. By Ricardo Galli Granada."

    I went into the options and deleted the cache. Then deactivated it and BAM! back to normal.

    Good luck everyone!

    John

About this Topic

  • Started 15 years ago by ericodom
  • Latest reply from JupitersCollision