The MU forums have moved to WordPress.org

Cant install on local server (20 posts)

  1. nims
    Member
    Posted 16 years ago #

    Hi, while trying to install wpmu 1.2.4 on local server I get this error
    "Warning!
    Installing to http://localhost/ is not supported. Please use http://localhost.localdomain/ instead."

    Can someone help.

  2. SteveAtty
    Member
    Posted 16 years ago #

    WMPU need a properly constructed domain name to work.

    If you are just testing then you will need to add localhost.localdomain to your local DNS (or hosts file) and then configure apache to support localhost.localdomain in its vhosts

  3. nims
    Member
    Posted 16 years ago #

    looks complicated :-(

  4. SteveAtty
    Member
    Posted 16 years ago #

    And of course unless you have local DNS set up you will only be able to install in the subdirectory mode rather than the subdomain mode as you wont be able to resolve blogname.domain.name

  5. drmike
    Member
    Posted 16 years ago #

    All you do is add in 'localhost.localdomain' to your hosts file along with 127.0.0.1, just like the localhost in there appears. It's not hard.

  6. nims
    Member
    Posted 16 years ago #

    I am using WAMP5 on winXP, so where do I put this ? In httpd.config file or php.ini file or my.ini file. I guess thats what is available to edit ?

  7. kaneda18
    Member
    Posted 16 years ago #

    Goto Start > Run
    Type in "system32" (without the quotations)
    Goto the folder called "drivers"
    Goto the folder called "etc"
    The hosts file should be in there. Just open it up with notepad or something and add in

    127.0.0.1 localhost.localdomain

    Though, I doubt this even has to be done as I got the same error when I first installed and all I did was click on the link it provides, which took me to localhost.localdomain. It resolved to 127.0.0.1 without it even being in the hosts file (as I cannot edit my file since I'm running a terminal server desktop)

  8. lyons
    Member
    Posted 16 years ago #

    It is worth making clear that it isn't just localhost that needs to be properly qualified. When installing to something such as http://myofficehost/ you will get the same issues but no warning message as you do for localhost.

  9. paddelboot
    Member
    Posted 16 years ago #

    Same problem here. Even running the installer script, I get the first PHP Notice:

    -- PHP Notice: Undefined variable: err in D:\Entwicklung\wpmu\index-install.php on line 173

    Then after the screen which tells me about the "successful" installation, I get more notices:

    -- PHP Notice: Constant DB_NAME already defined in D:\Entwicklung\wpmu\wp-config.php on line 4 PHP Notice: Constant DB_USER already defined in D:\Entwicklung\wpmu\wp-config.php on line 5 PHP Notice: Constant DB_PASSWORD already defined in D:\Entwicklung\wpmu\wp-config.php on line 6 PHP Notice: Constant DB_HOST already defined in D:\Entwicklung\wpmu\wp-config.php on line 7 PHP Notice: Constant VHOST already defined in D:\Entwicklung\wpmu\wp-config.php on line 10 install_blog - ID: 1 URL: http://wpmu/ Title: WordPress MU Test Site

    After all this, I cannot login, but get redirected to the login screen every time. I am using a local webserver with the virtual host http://wpmu. Anyone knows how to proceed to install WP MU locally?

    Paddelboot

  10. lunabyte
    Member
    Posted 16 years ago #

    First off, a PHP notice doesn't mean anything. It's a notice, not an actual error.

    Next, you absolutely have to tie MU to some sort of domain. AKA: FQDN

    Meaning that installing it as http://wpmu/ is not acceptable. 127.0.0.1 is not acceptable.

    http://wpmu.loc/ or http://wpmu.local/ is acceptable.

  11. sgrunt
    Member
    Posted 16 years ago #

    i've installed wordpressmu locally.
    i have win xp and so i use Xamp. I have modified the host file adding the 127.0.0.1/wordpressmu directory.

    One thing: i don't use localhost in configuration but always 127.0.0.1, i don't know remember why, but it works!
    and sub.127.0.0.1 for subdomains (sub is a test name you must change it).

  12. lunabyte
    Member
    Posted 16 years ago #

    Must be a bug in the package then, as IP addresses are not supposed to be allowed.

  13. paddelboot
    Member
    Posted 16 years ago #

    All right. Next problem is that my local webserver doesn't know mod_rewrite, so all the links in the blog are dead.

    Without mod_rewrite = no local installation?

    Regards,

    Michael

  14. lunabyte
    Member
    Posted 16 years ago #

    No mod_rewrite = No MU.

  15. SteveAtty
    Member
    Posted 16 years ago #

    Why not enable mod_rewrite. If you are running a WAMP stack its just a matter of uncommenting it in the configuration file (if its not actually active by default)

  16. rajeshatbuzz
    Member
    Posted 15 years ago #

    Hi,
    This is raj from bangalore. I am trying to test wordpress mu in my local env but i am not able to install and getting same error. I have already added 127.0.0.1 localhost.wordpress in etc file...am i missing somthing...
    Raj

  17. kaiserthegreat
    Member
    Posted 15 years ago #

    http://localhost/wpmu didn't work for me, but typing http://127.0.0.1/wpmu/ did, so maybe try that...

  18. famous
    Member
    Posted 15 years ago #

    I have a website that I am making changes to live and I have decided to create a test site in dreamweaver to stop annoying people by making changes live.
    It took forever, however I installed apache, php and mysql and now I have downloaded my database from the remote server at 68MB's and now I am trying to upload that database to my computer. However, I have had no luck.
    I just tried:
    mysql -u root - p DATABASE < nameOfSQLdatabase.sql
    &
    mysqldump -u root - p DATABASE < nameOfSQLdatabase.sql
    I got no error message it looks like it went through, but still no data?

    I have also tried connecting direct to my remote host from the test server and the homepage localhost.localdomain shows
    No WPMU site defined on this host. If you are the owner of this site, please check Debugging WPMU for further assistance.

    Can someone give insight as to how I can accomplish this? Thanks

  19. VentureMaker
    Member
    Posted 15 years ago #

    Did you correct settings wp-config.php file? I think you did not.

  20. ruinai
    Member
    Posted 15 years ago #

    was having the same problem.. http://127.0.0.1/wpmu/ worked for me. thanks!

About this Topic