Ok, so here is an error I am getting:
[18-Aug-2007 19:34:10] WordPress database error: [You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'AND comment_approved = '1' ORDER BY comment_date_gmt DESC LIMIT 10' at line 1]
SELECT wp_332_comments.* FROM wp_332_comments WHERE comment_post_ID = AND comment_approved = '1' ORDER BY comment_date_gmt DESC LIMIT 10
I checked the latest visitors and found out that this error was caused when someone tried to access the feed for a post that has been deleted via google.
Now, its not a biggie, but it still bothers me because my error_log gets full of these. Is this a software bug or do I have something configured wrong?
The error only appears when someone tries to view the feed for a post that doesnt exist. You can access the feed, but it wont show you anything. If I delete the /feed/ from the url I get a 404 message. The /feed/ doesnt show me the mysql error, it just loads the typicall feed page but blank.
Anyway to fix this?