The MU forums have moved to WordPress.org

More sitemap questions (2 posts)

  1. WWDay3
    Member
    Posted 15 years ago #

    My apologies for being a pest, but I'm still getting nowhere fast.

    First, let me ask: Is the mu-stemap plugin THE official sitemap plugin for MU? Or, is there another I should be looking at? Is there official documentation for the mu-stemap plugin? (The WPUMDEV site "says" go to the author's blog, but there is no blog listed). I've read numerous posts regarding the sitemap, but since everybody just seems to call whatever they are dealing with "sitemap" or "google sitemap", and I have no way of knowing which (mu or Arne's or another) they are talking about.

    Question. Neither I, nor Google Webmaster, seem to be able to see the sitemap. Always a 404 error. I can pull up files/robots.txt (although it's incorrect - see below). But the sitemap, which I can easily browse with my FTP client, does not some up.

    I thought perhaps the problem was the $mime types in blogs.php, so I added application/xml and text/xml. No change.

    Here's what I've tried so far.

    Restored the .htaccess file to it's original version.
    Removed mu-sitemap from mu-plugins.
    Removed Arne's sitemap completely.
    Put mu-sitemap in "regular" plugins.
    Activated it for some test blogs.
    (By the way, simply activating userthemes seems to modify the blogs.dir path to allow the /files folder).
    Made the $mime changes in blogs.php listed above.
    Added xml to site-admin/upload files values.
    Added "RewriteRule ^sitemap.xml wp-content/blogs.php?file=sitemap.xml [L]" to the .htaccess file following "RewriteRule . - [L]".
    Changed almost everything to 777.
    "Played around" with the .htaccess file to see what might happen if I do this... - or this... - or this... (made the site crash a couple of times).
    Deleted the /files/robots.txt and /files/sitemap.xml files, updated a post which successfully recreated them.

    At this point, I'm not even sure blogs.php is being executed. I tried putting an echo in at the very top of the function, but I get no alert (is that the best way to debug?).

    Robots.txt:

    When I view the /files/robots.txt file using my FTP client, the file looks OK except for the sitemap directive which points to the root folder rather than the blogs.dir folder. The version that comes up when I view in the browser has no such sitemap directive. When I go to Google Webmaster tools and view the robots.txt, I get to wp-signup.php.

    Please help?

  2. BradWaite
    Member
    Posted 15 years ago #

    In case you're still looking WWDay3, check out my post here.

About this Topic

  • Started 15 years ago by WWDay3
  • Latest reply from BradWaite