The MU forums have moved to WordPress.org

New installation with subdomains on Mac OS X server (7 posts)

  1. Rubyducky
    Member
    Posted 15 years ago #

    Hello,
    I'm trying to install wpmu on a Mac OS X server with support for subdomains. I've installed it, but now, for example, links such as http://<domain>/blog/2007/08/22/hello-world/ give a 404. Wp-admin, and wp-login files work fine, I can access the control panel and have pretty much full functionality. I searched and found that another person using OS X server was having the same problem just about, but was not using subdomains. Mod_rewrite is active. Is there anything I need to change in the .htaccess or anywhere else? In addition, subdomains don't work, but I'm not sure if that's wpmu's problem or mine. Thanks for your help!

  2. lunabyte
    Member
    Posted 15 years ago #

    Did you make the right edits to apache's config file, as well as make sure that htaccess files are allowed?

    I didn't have a lick of trouble on OS X, or OS X Server.

  3. Rubyducky
    Member
    Posted 15 years ago #

    Server Admin made all the changes to the config file, I didn't touch it manually, so I assume there's no errors there. Not sure how to make sure that .htaccess files are allowed in apache, though. There is an .htaccess file in the web directory though.

  4. lunabyte
    Member
    Posted 15 years ago #

    I'd first look to the configuration file for apache, and make sure htaccess files are allowed to be read, and that the edits to the virtual host were made correctly. Just because the htaccess file exists, doesn't mean apache is allowing it.

  5. Ustice
    Member
    Posted 15 years ago #

    I had the same trouble when I installed it on an OS X server. Here is the thread where I had the issue, and what I did to resolve the problem. I hope that it helps.

  6. netspencer
    Member
    Posted 14 years ago #

    I am running my WPMU on Leopard Server and had a similar error with URI's like you mentioned above and wp-admin was working. This was because wp-admin, wp-login.php etc are real files. The URI's you mentioned are permalinks. I simply was able to fix it by going into wp-settings and switching permalinks to the basic structure and then switching it back

  7. lunabyte
    Member
    Posted 14 years ago #

    Just so you know, double posting is really bad form, and quite frowned upon over here.

About this Topic

  • Started 15 years ago by Rubyducky
  • Latest reply from lunabyte