The MU forums have moved to

can't login to Admin page (5 posts)

  1. krucke
    Posted 16 years ago #

    When I try to login to the admin page through blog/wp-login.php, I receive a 500 internal server error. I had previouosly not been able to see my subdirectories, so I changed my conf file from "AllowOverride None" to "AllowOverride FileInfo Options" in the directory. I don't believe this would change the login ability. The only other place that could cause this error is my .htaccess file, but it seems alright. Here it is:

    RewriteEngine On
    RewriteBase /

    # Rewrite to
    RewriteCond %{HTTP_HOST} ^www\.(.*)
    RewriteRule ^(.*) http://%1/$1 [R,L]

    #uploaded files
    RewriteRule ^(.*/)?files/$ index.php [L]
    RewriteRule ^(.*/)?files/(.*) wp-content/blogs.php?file=$2 [L]

    RewriteCond %{REQUEST_FILENAME} -f
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule . - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-.*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    ErrorDocument 404 /index.html
    ErrorDocument 401 /index.html
    ErrorDocument 403 /index.html

  2. drmiketemp
    Posted 16 years ago #

    Please get into the habit of checking your webserver's error logs. I believe that the 500 error even suggests that you do so. I know the debugging page mentioned within the readme file included with the download does:

  3. krucke
    Posted 16 years ago #

    When I get the 500 error from trying to login to the admin page is:

    [Mon Sep 10 13:45:02 2007] [error] [client] mod_rewrite: maximum number of internal redirects reached. Assuming configuration error. Use 'RewriteOptions MaxRedirects' to increase the limit if neccessary.

    Well with more searching I found the following code in my site .conf file in the webserver

    <Directory "/Library/WebServer/Documents">
    Options All +Includes +Indexes +MultiViews +ExecCGI
    AllowOverride FileInfo Options
    <IfModule mod_dav.c>
    DAV On

    This allows the subdirectories to be viewed and allows navigation through all the blogs, but does not allow you to login. If you change "AllowOverride FileInfo Options" to "AllowOverride None", you can login to the admin page, but you can't view the sub directories.

    Any help would be greatly appreciatted.

  4. drmiketemp
    Posted 16 years ago #

    You can get that error for a number of reasons. One possible solution is to increase the memory allocated to php, (check for 'memory_limit' within your php.ini file. Most OSes default that to 8 megs. Try 32 megs.) You may also want to try the increasing MaxRedirects limit as well as mentioned by the error.

    FileInfo Options should be in the AllowOverride setting. Please return them if you haven't done so already.

    Try that and see if any of them helps.

  5. krucke
    Posted 16 years ago #

    I switched the limit to 32megs, but didn't seem to work. Where do you go to increase MaxRedirects limit?

    Any other ideas?

About this Topic