The MU forums have moved to

Upgrade through admin errors in wpmu-upgrade-site.php (5 posts)

  1. Bike
    Posted 16 years ago #

    Hi all, I noticed that when trying to update the blogs (using the admin tool, I get 2 errors per blog:

    warning: fopen(0) [function.fopen]: php_network_getadresses: getaddrinfo failed: Name or service not known in /site/wp-admin/wpmu-upgrade-site.php on line 32
    Warning: fopen(http://blog.domain.tld/wp-admin/upgrade.php?step=1)[function.fopen]: failed to open stream: Permission denied in /site/wp-admin/wpmu-upgrade-site.php on line 32

    I had to take a screenshot in order to read the messages as it appears and disappears within a second.
    Then it jumps to the result page and joyfully tells me "All Done!"

    Of course I am wondering what exactly is (not) done :)
    Anybody seen this before?
    using PHP5, WPMU 1.2.4 on a VPS

    * VHOST: true
    * path to WordPress MU install: "/"
    * Does the information in wp_blogs, wp_users and wp_site match your blog, user and site: yes
    * Plugins in place? Have you tried turning them off and seeing if that affects the issue: yes, turned all off for two blogs, but these blogs are still giving same errors as well.
    * Server environment: Apache, centos-4-x86 no proxy or cache server in place?

    The line in question is:

    $fp = fopen( $siteurl . "wp-admin/upgrade.php?step=1", "r" );


  2. drmiketemp
    Posted 16 years ago #

    That's a host issue as they've disallowed the use of fopen. Some hosts do that as a security procedure. You need to talk to them about it as you may have issues with rss feeds as well.

  3. Bike
    Posted 16 years ago #

    Hi DrMike, thanks for your response.
    I checked PHP.ini through WHM:

    -> allow_url_fopen "This option enables the URL-aware fopen wrappers that enable accessing URL object like files. Default wrappers are provided for the access of remote files using the ftp or http protocol, some extensions like zlib may register additional wrappers."

    There is a radio button: on/off and it is set to on, so it should be enabled?
    Should I put something in "include_path" (is empty now)

    "(Specifies a list of directories where the require(), include(), fopen(), file(), readfile() and file_get_contents() functions look for files. The format is like the system's PATH environment variable: a list of directories separated with a colon in Unix or semicolon in Windows.)"

    or is there another place where fopen could be limited?
    Thanks, Bike

  4. drmiketemp
    Posted 16 years ago #

    To be honest, I don't know. We're Direct Admin, not CPanel.

    Might want to flip through the CPanel support forums for 'fopen'. By now, someone else should have had the issue.

  5. Bike
    Posted 16 years ago #

    Thanks, though my host's support first directed me towards as they seem to have fopen errors discussed, they came back a bit later with a solution:
    "We adjusted the resolver settings on the server"

    and that seems to have worked, now the upgrade is going without errors.

    Cheers, Bike

About this Topic