The MU forums have moved to WordPress.org

Theme strings are not being translated (2 posts)

  1. theworkisdone
    Member
    Posted 14 years ago #

    • I'm running WPMU 1.2.5a.
    • I'm using poedit for creating my .po and .mo files.
    • I'm using latest Sandbox-Theme from the 0.9 branch.
    • My de.po-File looks like this
          #: wp-content/themes/sandbox/archive.php:37
          #: wp-content/themes/sandbox/author.php:26
          #: wp-content/themes/sandbox/index.php:23
          #: wp-content/themes/sandbox/search.php:27
          #, php-format
          msgid "Posted in %s"
          msgstr "Veröffentlicht in %s"
      
    • I've enabled define('WPLANG', 'de'); in wp-config.
    • I've set default language in options menu on every blog to 'de'
    • I've placed my de.mo in wp-includes/languages and tried also wp-content/languages'

    Still no string in sandbox theme is being translated though all strings are present in my de.po/mo file.

    Any help is appreciated.

    Thanks!

  2. theworkisdone
    Member
    Posted 14 years ago #

    Well, placing a seperate .mo only with the the theme specific language strings into /wp-content/themes/sandbox did the trick. Reminder: Remove sandbox-strings from global .mo-file

About this Topic

  • Started 14 years ago by theworkisdone
  • Latest reply from theworkisdone