The MU forums have moved to WordPress.org

IIS problem: Can only edit main blog (25 posts)

  1. gammera
    Member
    Posted 15 years ago #

    I know, big surprise - we're having trouble with an IIS install of WPMU (v1.2.4) on a Windows 2003 server with PHP & MySQL. We also installed "IIS Mod-Rewrite Pro" which seems to be working great:
    http://www.micronovae.com/ModRewrite/articles/CleanPermalinks.html

    Right now we have the main WordPress MU installed with 1 additional sub-blog. From a users perspective, the site works correctly, meaning when you go to the main blog or the sub-blog you see the the appropriate posts.

    But when you login to the admin panel, you can only edit the main blog. When you switch to the sub-blog the url in the browser location bar changes to display the sub-blog url - but the admin display still shows the posts for the main blog.

    We also tried setting up a separate user for the sub-blog, but then we are not able to login at all. Trying to login creates an endless redirect loop (between the main blog login url and the sub-blog login url) and Firefox gives the infamous error message:

    "The page isn't redirecting properly. Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

    Of course the identical files loaded onto a Linux box work perfectly, but unfortunately we are being forced to use the IIS platform.

    We have spent several days trying to find potential solutions to this problem (here and around the net) with no luck. If anyone has any suggestions they would be greatly appreciated.

  2. lunabyte
    Member
    Posted 15 years ago #

    According to the download page:

    Requirements

    Apart from WordPress Requirements

    * Apache mod_rewrite - if you had WP installed already with fancy URLs then you should be fine.

    Downloads Page is here.

  3. gammera
    Member
    Posted 15 years ago #

    Thanks for the reply. Yea, it's strange - the fancy URLs are working fine with "IIS Mod-Rewrite Pro" installed. It's just the admin panel that is the problem... only the main blog can be updated.

    Do you think we would need to install Apache on the Windows 2003 server to get the whole thing working correctly?

    Would love to hear any ideas on what else may be causing this. It's especially frustrating since the same files work on Linux but we are locked into IIS...

  4. peiqinglong
    Member
    Posted 15 years ago #

    At my office, I'm a running a Windows 2003k Enterprise server with Apache, MySQL, PHP and WPMu in subdomain mode on Active Directory.

    I would highly suggest moving to Apache. The only issue is the PHPMail. I may need to activate IIS just to use the SMTP server.

  5. gammera
    Member
    Posted 15 years ago #

    Thank you for the info. I saw in another post here that you can install Apache on same server with IIS as long as it is configured to run on a port other than 80 (the default for IIS).

    I guess if no one has any other possible solutions that is what we'll have to try.

  6. MrWize
    Member
    Posted 15 years ago #

    gammera,

    did You get it to work? I'm also on a windows server 2003 web edition (dedikated server) and would like to get WPMU to run on that box so to speak.

    The urlrewrite ISAPI I use doesn't do the job, so I wonder if You can recomend the IIS ModRewrite PRO?

    /Patrik

  7. gammera
    Member
    Posted 15 years ago #

    Nope, still no luck with just IIS. We're going to install Apache (along with IIS) on the Windows server this week. It sounds like that is the only real solution. So I wouldn't spend any money on IIS ModRewrite Pro, just use the free Apache module. Here's a post in another forum that explains a couple of ways to get Apache & IIS working on the same box...

    http://p2p.wrox.com/topic.asp?TOPIC_ID=13366

    PS - You can also download IIS ModRewrite Pro for free and see if it works for you before buying it (something we should have done)...

    http://www.micronovae.com/ModRewrite/Download.html

    IIS Mod-Rewrite download comes as "try before you buy" product. It will work in full function for a limited time (30 minutes, or 1000 requests, whichever is reached first), until your webserver is restarted.

  8. man999
    Member
    Posted 15 years ago #

    Gammera,

    I have the same exact problem with WPMU admin panel on IIS. However, I found everything working perfect when changed WMPU to work with subdomain based blogs (eg myblog.site.dom instead of site.dom/myblog).

    Just in case, here is the topic I posted regarding this issue

    http://mu.wordpress.org/forums/topic.php?id=5483

  9. man999
    Member
    Posted 15 years ago #

    Update!

    I found a little hack that makes everything work perfect.

    Copy the following line of code at the beginning of wp-config.php

    $_SERVER[ 'REQUEST_URI' ] = $_SERVER[ 'HTTP_X_ORIGINAL_URL' ];

    Note that micronovae's solution suggests doing this in index.php. I guess that works for Wordpress SU, but for MU edition do it in wp-config.php.

    This hack works perfect with both subdirectory and subdomain based blogs.

  10. gammera
    Member
    Posted 15 years ago #

    man999-

    Thank you! Thank you! Thank you!

    I spent about a week of my life trying to get this to work... I can't believe you came up with such a simple solution.

    It works great! That fixed the admin problem.

    You really made my day, thanks again...! We had been procrastinating about installing Apache and now we won't have to.

  11. shanmuganathan
    Member
    Posted 14 years ago #

    Thanks a lot i wast lot of time to workout WPMU in IIS using below code it works perfectly paste below code in wp-config.php

    $_SERVER[ 'REQUEST_URI' ] = $_SERVER[ 'HTTP_X_ORIGINAL_URL' ];

    and enjoy WPMU in windows

  12. WILDexX
    Member
    Posted 14 years ago #

    Hi guys!
    I have the sme problem.
    I have windows dedicated server and xammp running on it.
    So if i trying to add a new blog, and try to visit it after activation, it rederecting me to wp-admin/install.php.
    simple: toster.grunge.com.ua
    Can anyone help me?

  13. max.favilli
    Member
    Posted 14 years ago #

    I have tried in all the way, using the info collected in this forum we succeded in making it work under IIS, but when the last WPMU release comes out it stopped working.
    We tried with both IIS_rewrite and others available, no luck. The only iis rewrite lib which worked was http://code.google.com/p/wp-url-rewriting-on-iis/

    But as you will see is not maintained anymore, and we resolved... Using apache.

    I think wpmu developer should ensure compatibilty.
    We should be free and have options.
    Ignore the fact apache is not the only webserver around is frankly sciovinist.

  14. lunabyte
    Member
    Posted 14 years ago #

    I think wpmu developer should ensure compatibilty.
    We should be free and have options.
    Ignore the fact apache is not the only webserver around is frankly sciovinist.

    A) The download page says Apache.
    B) IIS is a piece of junk. There's a reason it's only used to serve that proprietary .net crap.

    It's not a shame at all. It's a choice to not support broken, security hole laden crap, and waste resources to support an incapable web server.

  15. andrea_r
    Moderator
    Posted 14 years ago #

    and isn't Apache the most common webserver?

  16. bloggus
    Member
    Posted 14 years ago #

    lunabyte is as ususal negative toward IIS, but a properly confugured php on IIS and a rewrite-software gives actually good results. I have no problem at all running WPMU on IIS.

    Beside the rewrite-property of the code, there isn't really anything else that makes the code incompatible with IIS.

    I had one problem so far during an installation, but that was just bad configuration in php.ini ...

  17. lunabyte
    Member
    Posted 14 years ago #

    Um, do you think that maybe there is a reason for that?

    Apache vs IIS... guess which one is going to use less, require less, and cost less?

    IIS is just a poor web server. Whether it's MU, or anything else.

  18. bloggus
    Member
    Posted 14 years ago #

    Well, doesn't matter what you or me think. The bottom line is that with proper rewrite-software this code is runing without any problem on IIS that has php configured right.

  19. max.favilli
    Member
    Posted 14 years ago #

    bloggus, which rewrite software are you currently using? And are you using it with the latest wpmu available release?

  20. bloggus
    Member
    Posted 14 years ago #

    isapirewrite.com (v.3) and yes - I have 2.6.1 installed

  21. riff-raff
    Member
    Posted 14 years ago #

    Trying to get this working with iis6, wpmu 2.6.5 as subdirectory blogs, and isapi rewrite v3. but as the title suggests, can only edit the main blog.
    bloggus - would be interested in any checklist you may have or pointers you might suggest.

  22. bloggus
    Member
    Posted 14 years ago #

    riff-raff;

    hard to say. I had never had this problem. Runing the latest 2.6.5 and there is no such a problem. I think you have to find the error ... is is hard to say otherwise , from the top of my head, what the problem is.

  23. andrej1c
    Member
    Posted 14 years ago #

    I have this problem with 2.7 beta r1589. On LAMP server (Dreamhost). It's set up to use subdirectories, not sub-domains for blogs. Can't reproduce the issue on Vista 64 using XAMPP.

    I inserted $_SERVER[ 'REQUEST_URI' ] = $_SERVER[ 'HTTP_X_ORIGINAL_URL' ]; into wp-config.php (just hoping and crossing my fingers that your fix will work for me on Linux) but it didn't resolve the issue.

    Any ideas? Stupid me rolled this into production with 400+ student blogs before I noticed this. Yes, I have a backup of files and database and I'll roll back tonight if I can't fix this. Never again beta. 2.7, please come soon.

  24. Kristian File
    Member
    Posted 14 years ago #

    shanmuganathan's solution worked for me. Thumbs up and thank you for the help.

  25. dsantucci
    Member
    Posted 13 years ago #

    Actually, it appears they've tried to address this problem in version 2.7, but unsuccessfully.

    In wp-settings.php, I came accross this:

    // Fix for IIS, which doesn't set REQUEST_URI
    
    if ( empty( $_SERVER['REQUEST_URI'] ) ) ....
    (assign custom header to $_SERVER['REQUEST_URI'])

    ...except that IIS actually *does* set $_SERVER['REQUEST_URI'], so their fix never executes.

    Also, when setting $_SERVER['REQUEST_URI'], you'll have to check your documentation to see in what custom header the original url is stored.

    For example, Helicon's ISAPI_Rewite (http://www.helicontech.com/isapi_rewrite/) uses 'HTTP_X_REWRITE_URL', not 'HTTP_X_ORIGINAL_URL', as quoted above.

About this Topic

  • Started 15 years ago by gammera
  • Latest reply from dsantucci