The MU forums have moved to WordPress.org

wp-login.php 'download' problem (14 posts)

  1. webmaestro
    Member
    Posted 15 years ago #

    Greetings,

    We have a problem with our WordPress 1.2.1 installation. We are planning an upgrade, but haven't made it yet.

    Over the past few of weeks, we've been noticing slow admin functionality: every admin submission took 22+ seconds (login, new blog, add user, etc.). The front-end has been working quickly, so actually 'fixing' the problem hasn't been of highest priority. We have a DBA who tells me there doesn't appear to be anything wrong with our wpmu database (except for the fact that we've got ~200 blogs, each with ~10 tables).

    Our DBA has run 'repair' table many times, but it always indicates status OK. He's watched the DB during ADMIN functions, and the select or update call comes through and is completed in under 1 second. Nevertheless the action still takes 22+ seconds to complete.

    Yesterday, the problem has escalated. At present we cannot do *any* admin function. In fact, we cannot even login. When I go to /wp-admin/ WPMU no longer recognizes my 'logged in cookie' so it re-directs me to /wp-login.php. When I enter my LOGIN & PASSWORD, WPMU waits for 40-70 seconds and finally Firefox asks where I want to save the file 'wp-login.php'.

    Our problem appears to be similar to this one (related to eAccelerator, although I don't believe we have it installed):

    http://wordpress.org/support/topic/98966?replies=6#post-494379

    I don't believe any binaries or resources (httpd, mysql, php, etc.) have been upgraded recently.

    [clay@widget1 ~]$ /web/apache/bin/httpd -v
    Server version: Apache/1.3.37 (Unix)
    Server built: Dec 13 2006 15:06:38
    [clay@widget1 ~]$ php -v
    PHP 5.2.0 (cli) (built: Aug 6 2007 17:21:41)
    Copyright (c) 1997-2006 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend Technologies
    [clay@widget1 ~]$ mysql --version
    mysql Ver 14.12 Distrib 5.0.27, for pc-solaris2.10 (i386) using EditLine wrapper
    [clay@widget1 ~]$ uname -a
    SunOS widget1.domain.com 5.10 Generic_118855-19 i86pc i386 i86pc

    Also, 'widgets1' is a part of a cluster of 4 computers plus one beefy db server.

    Any ideas?

    Thanks!

    Clay

  2. lunabyte
    Member
    Posted 15 years ago #

    Bandwidth?

    Traffic latency?

    Extra code generation (like from javascript)?

    Do you have caching enabled, and if so have you tried clearing it? If not, have you tried enabling it? (Referring to object cache)

    Just a couple thoughts off the top of my head.

    Oh, and check if eaccelerator or a similar product is installed. I use APC myself on my servers. If it is present (or similar), you probably need to add kses.php to the exclusion list for that program (method varies by program) if it isn't already. Although if that were the case, you'd "most likely" get a white screen of death vice just slow (or almost stopped) page loads.

  3. webmaestro
    Member
    Posted 15 years ago #

    Thank you so much for the quick reply! Let me answer your questions one at a time:

    Bandwidth?

    Tons of bandwidth (OC-3?)

    Traffic latency?

    I don't think there's any I'm aware of. We have a fairly fat pipe, serving millions visitors per day on our many sites, and none of our other sites are exhibiting these types of problems.

    However that brings to mind the fact that there was some maintenance on the load balancing server a week or so ago. One strange thing, however is that going to /wp-admin/ *immediately* brings up the /wp-login.php script, but clicking submit takes a while.

    Extra code generation (like from javascript)?

    None that I'm aware of, and I'm the only PHP developer making changes to the WPMU web app. I do have a plugin/theme combo I created to present a common interface for our 200+ blogs, but that's been functioning for the last 6 months without problems.

    Do you have caching enabled, and if so have you
    tried clearing it? If not, have you tried enabling
    it? (Referring to object cache)

    Caching is not currently enabled.

    Just a couple thoughts off the top of my head.
    
    Oh, and check if eaccelerator or a similar product
    is installed. I use APC myself on my servers. If
    it is present (or similar), you probably need to
    add kses.php to the exclusion list for that
    program (method varies by program) if it isn't
    already. Although if that were the case, you'd
    "most likely" get a white screen of death vice
    just slow (or almost stopped) page loads.

    We do have this, but I don't see any accelerators (I don't see apc, zend optimizer or eaccelerator anywhere):

    Zend Engine v2.2.0, Copyright (c) 1998-2006 Zend
    Technologies

    Clay

  4. webmaestro
    Member
    Posted 15 years ago #

    BTW...

    Do you have caching enabled, and if so have you
    tried clearing it? If not, have you tried enabling
    it? (Referring to object cache)

    We haven't enabled caching yet, nor have I tried. I'll look into that if you think it'll help.

    Clay

  5. lunabyte
    Member
    Posted 15 years ago #

    Add this to your wp-config file:

    define('ENABLE_CACHE', true);

    It turns on object caching (WP's internal caching), and it does help. It basically caches common queries and such, so there isn't a need to actually go to the DB every time.

    In terms of latency/bandwidth, I was referring more to the internal side of it, between boxes. Maybe a firewall/router or something slowing it down.

  6. webmaestro
    Member
    Posted 15 years ago #

    I added it, but it doesn't appear to make a difference. I'm using wordpressmu-1.2.1 ATM. I plan on updating to 1.2.5a shortly, so I'll make the change there as well.

    I saw somewhere that kses.php should be excluded from wpmu's cache system, but I don't see any examples of excluding single or multiple files.

    Thanks again for your help!

  7. webmaestro
    Member
    Posted 15 years ago #

    BTW, I talked to one of my Blog Admins, and he says that he's still able to access Admin features (he retained his cookie--I had deleted mine for another project--d'oh!).

    Although he can access Admin features, he is unable to 'save' or modify any information. The main difference between he and I, is that I cannot log in, and he is already logged in.

  8. lunabyte
    Member
    Posted 15 years ago #

    The kses.php thing is for external caching programs.

    Using the ENABLE_CACHE definition is just the internal object cache.

    Since you mentioned that you don't have eaccelerator or APC running (although I would recommend it), you wouldn't need to "skip" that file.

    You probably have, but have you tried restarting apache?

    It "could" be getting into a memory issue, or something obscure like that.

  9. webmaestro
    Member
    Posted 15 years ago #

    I've restarted httpd (on all four servers in the cluster) a couple of times... I'll try again just for kicks...

    BTW, I just created the wp-content/cache/ directory (and made it world-writeable). I had some trouble finding documentation in the mu.wordpress.org world. I found it in a few forum postings, but a 'complete' reference doesn't appear to exist, which discusses how/where to enable, that you have to create the wp-content/cache/ directory (and made it world-writeable), as well as how one would exclude certain files and why. If it does exist, I didn't find it.

    Anyway, I'm still banging on this. At this point, none of my blogs currently can do any admin functions (can't post, can't create new blogs, can't create new users, etc.). Fortunately the front-end is fast and responsive.

  10. lunabyte
    Member
    Posted 15 years ago #

    Hmmm... could there maybe be a corrupt file in the back end? Maybe a permission or something got hosed?

    As I mentioned, no need to worry about excluding files with the internal object cache.

    If the front is still fine, which at least is a positive sign, in theory it should be something that is wp-admin/ related, and common to all files.

    If it "just" started happening, without any changes whatsoever, that would tend to point to a corrupt file or something like that. Then again, sometimes the strangest things can have an impact.

  11. webmaestro
    Member
    Posted 15 years ago #

    BTW, I 'resolved' this problem by disabling plugins (D'oh! Should've been my first step!)...

    When I reintroduced plugins one by one, the BadBehavior 2.0.10 and Did You Pass Math plugins caused problems so I couldn't re-enable them.

    I don't have time ATM to identify/troubleshoot/workaround the problem. I hope to have time later in the week to troubleshoot.

    Thank you for your help!

  12. lunabyte
    Member
    Posted 15 years ago #

    So was it both combined, or did they still cause problems when 1 or the other was enabled?

  13. billnoyes
    Member
    Posted 15 years ago #

    I saw this issue today on WPMU 1.2.5 running on a single server. Of the plugins mentioned I am using Bad Behavior 2.0.10. I was able to restart the server as I noticed that MYSQL was using a lot of memory when the wp-login.php save as a file issue was happening. I did not have cache enabled or any accelerators running.

  14. webmaestro
    Member
    Posted 15 years ago #

    Sorry for not responding sooner...

    The problem goes away if I remove Bad behavior. I have recently re-enabled Did You Pass Math, and believe it is not the culprit... We're 'testing' now (i.e., DYPM is active in mu-plugins again), so if there's a problem, we'll find out in short order... :-)

About this Topic

  • Started 15 years ago by webmaestro
  • Latest reply from webmaestro