The MU forums have moved to WordPress.org

simpletagging url for home blog problems (3 posts)

  1. ladynada
    Member
    Posted 15 years ago #

    Hello,
    My home blog's simpletagging urls were sending users to the signup page. so, the Lord helped me.

    I had to use phpmyadmin, and in the database, and only on the #1 blog, I had to change the permalink from:

    /blog/index.php/%year%/%monthnum%/%day%/%post_id%/

    to

    /index.php/%year%/%monthnum%/%day%/%post_id%/

    the leading blog/ folder is hardcoded and cannot be changed in the options menu in admin, so that is why I had to change it with phpmyadmin

    nada

  2. ladynada
    Member
    Posted 15 years ago #

    I am glad someone came from this thread to my blog, I saw in my logs, because I was looking for this thread to change what I said before.

    It is better to leave the blog/ in your database entry for the home blog and the permalink setting.

    I ended up doing something else to solve my problem. I had to change code in the core of wpmu to suit my needs. Through searches I was told where the program was going to send people to the login, and I changed that code to simply add an index.php to the url if the url had my base folder name and tag in it.

    For example if your blogs are in a folder called awesomeblogs, then I had to do an if statement to test if the domain and folder name had

    awesomeblogs/tag in it, and then insert the index.php into it, so that on only the home blog, the tag url would be fixed. I also had to set simpletagging to put in a trailing slash.

    I hope this helps someone.
    nada

    I mentioned the fix here also
    http://mu.wordpress.org/forums/topic.php?id=3672&page&replies=15

  3. lunabyte
    Member
    Posted 15 years ago #

    "It is better to leave the blog/ in your database entry for the home blog and the permalink setting."

    If you are running subdirectories, yes it is.

About this Topic

  • Started 15 years ago by ladynada
  • Latest reply from lunabyte